Столмен, Ричард ! Право читать

Richard Stallman

The Right to Read

http://www.gnu.org/philosophy/right-to-read.ru.html

© Richard Stallman, 1996

© перевод с англ.: Сергей Короп, 2000 * svk@lib.ru

Разрешается копирование и распространение этой статьи любым способом без
внесения изменений, при условии, что это разрешение сохраняется.

Verbatim copying and distribution of this entire article is permitted in any
medium, provided this notice is preserved.

   Эта статья была опубликована в феврале 1997 г.
   Communications of the ACM (Volume 40, Number 2).

Перевод выполнен по версии статьи от 23 апреля 2000.

Предисловие переводчика

Не расстраивался бы и вас бы не расстраивал, но жить люблю - поэтому и
хочется.

М. Жванецкий.

Будет ли при коммунизме КГБ?
Нет, все научатся самоарестовываться.

(Народное)

Автора статьи, предлагаемой вашему вниманию, как говорится, представлять не
надо. Ричард Столмен - легендарный автор текстового редактора EMACS и
основатель Free Software Foundation - известен и своей неутомимой борьбой за
пересмотр существующих сегодня правовых и моральных норм, известных как "право
на интеллектуальную собственность". Фантастическое эссе "Право на чтение"
посвящено возможной эволюции этих норм.

Выбор для перевода именно "Права на чтение" не случаен. Честно говоря, я был
просто поражен, насколько идея стукачества и, фактически, лишения
пользователей программ всех принадлежащих им прав, кроме, конечно, права
оплатить все это своими же деньгами :-), оказалась распространенной "у них".

Вообще-то приведенные аргументы кажутся несколько слабоватыми для бывших
советских граждан. Мы настолько привыкли к жизни в окружении абсурда и к
непрерывной борьбе с Системой, что нас уже ничем не удивишь. Да и когда еще
все эти механизмы у нас заработают? Как говорится, пока гром не грянет...

Действительно, пока что мы далеки от реалий американской жизни, но кто сегодня
не слышал о СОРМ-2? А разве наши родные разработчики не выпускают демо-версий
своих навороченных программ, которые ведут себя почти как вирусы? А еще в
одном ВУЗе вынули из машин все флоповоды, чтоб студенты чего ненароком не
принесли. Нехорошая перспектива вырисовывается - гремит если не над головой,
то уже достаточно близко. Поэтому пора действовать. Давайте, для начала,
просто задумаемся о происходящем. Я надеюсь, что мой перевод поможет в этом
хотя бы одному человеку.

Конструктивные замечания о качестве перевода и стиле изложения будут с
благодарностью рассмотрены. Пишите - постараюсь ответить на все письма, но не
обещаю, что сделаю это немедленно.

Я хочу искренне поблагодарить

*  Михаила Кимельмана
*  Олега Тихонова
*  "dim"

которые помогли мне своей конструктивной критикой сделать перевод точнее и
понятнее.

Ричард Столмен

Право читать

   (из "Пути к Тихо" [1] (The Road To Tycho), собрания статей о
   предыстории Лунной Революции, опубликованного в Luna City, 2096 год)

Дэн Халберт (Dan Halbert) начал свой путь к Тихо в колледже - когда Лиза Ленц
(Lissa Lenz) попросила у него взаймы компьютер. Ее собственный сломался, и
курсовая работа была бы невыполнена, не найдись другой. Она не решилась
обратиться к кому-либо еще, кроме Дэна.

Это поставило его перед дилеммой. Нельзя было не помочь, но если одолжить свой
компьютер, Лиза могла бы читать его книги. Помимо того, что за это можно было
сесть в тюрьму на много лет, шокировала сама идея. С первого класса в школах
внушали, что поделиться книгой - ужасное преступление, сравнимое с морским
пиратством.

Шансов ускользнуть от бдительного ока SPA - Software Protection Authority
(службы защиты программного обеспечения) - практически не было. Изучая
программирование, Дэн узнал, что каждая книга имела контрольный Монитор,
который сообщал, кто и когда ее читает, в Центр Лицензирования (Central
Licensing). (Центр использовал эту информацию не только для поимки "пиратов",
но продавал книготорговцам сводки личных пристрастий читателей). Как только
компьютер войдет в сеть, Центр может это засечь, а Дэн, как владелец
компьютера, понесет самое тяжелое наказание за то, что не предупредил
преступления.

Конечно, Лиза не обязательно собирается читать его книги. Компьютер мог быть
ей нужен только для выполнения курсовой работы. Но Дэн знал, что ее семья
принадлежит к среднему классу и с трудом оплачивает обучение, так что на книги
и вовсе не хватает. Чтение чужих книг для нее могло быть единственным способом
завершить образование. Ситуация была знакомой: он сам влез в долги, оплачивая
статьи, которые приходилось читать. (10% этих средств получали авторы;
поскольку Дэн мечтал об академической карьере, он надеялся, что на его
собственные исследования будут ссылаться достаточно часто, и он сможет вернуть
долг).

Позднее Дэн узнал, что было время, когда каждый мог пойти в библиотеку и
бесплатно получить журнальную статью и даже книгу. В те годы существовали
независимые студенты, которые могли читать тысячи страниц, не прибегая к
правительственным библиотечным грантам. Но в 1990-х годах как коммерческие,
так и бесприбыльные издатели журналов начали взимать плату за доступ. В 2047
библиотеки, которые бесплатно предоставляли учебную литературу всем желающим,
были историей.

Конечно, были способы обойти контроль SPA и Центра Лицензирования. Но и они
были незаконными. Вместе с Дэном слушал курс программирования Фрэнк Мартуччи
(Frank Martucci) [2], который достал запрещенный отладчик и с его помощью
обходил код Монитора, когда читал книги. Но он рассказал об этом слишком
многим, и кто-то донес на него SPA, чтобы получить вознаграждение (нуждающиеся
студенты легко становились доносчиками). В 2047-м Фрэнк был посажен не за
пиратское чтение, а за хранение отладчика.

Дэн позднее узнал, что было время, когда каждый мог иметь отладочные
инструменты. Были даже свободные отладчики, доступные на CD либо в Сети. Но
пользователи начали использовать их для обхода Мониторов; в конечном счете,
суд постановил, что такое их применение стало основным. Как следствие,
отладочные средства были объявлены вне закона, а их разработчики оказались за
решеткой.

Конечно, программисты не могли обойтись без отладчиков, но в 2047-м их
производители выпускали только номерные копии, которые предоставлялись
исключительно программистам с официальной лицензией. Возможности отладчика,
который Дэн использовал в классе, были ограничены с помощью специального
брандмауэра, так что он годился лишь для выполнения учебных задач.

Другой возможностью обойти Монитор была установка модифицированного системного
ядра. Дэн мог бы узнать о свободных его реализациях, даже о полностью
свободных операционных системах, которые существовали на рубеже веков. Но мало
того, что они считались запрещенными, подобно отладчикам, оказывалось
невозможным их установить, даже если удавалось достать такую систему -
требовался привилегированный пароль. Но ФБР и сервисная служба Microsoft
держали его в секрете.

Дэн решил, что не может просто одолжить Лизе свой компьютер. Но он не мог ей
отказать, поскольку любил ее. Каждая встреча с ней была для него праздником.
То, что она обратилась именно к нему, могло означать, что и она к нему
неравнодушна.

Дэн разрубил этот гордиев узел еще более немыслимым способом - он одолжил ей
свой компьютер и назвал свой пароль. Таким образом, если Лиза прочтет его
книги, в Центре Лицензирования решат, что он сам их читает. Это также было
преступлением, но SPA оказывалось в состоянии немедленно его обнаружить,
только если Лиза сообщит о нем.

Конечно, если бы в школе узнали, что Лиза получила его пароль, это означало бы
конец их учебы, независимо от того, для чего этот пароль использовался.
Согласно школьным правилам, любая помеха наблюдениям за ученическими
компьютерами была достойна дисциплинарного взыскания. Никого не интересовало,
случилось ли что-нибудь вредоносное, преступлением считалось помешать
администрации в слежке за вами. Предполагалось, что это автоматически
подразумевает и другие нарушения, неважно, какие именно.

Явного наказания не было предусмотрено. Но учащихся лишали доступа к школьным
компьютерам, так что они попросту проваливали сдачу всех заданий.

Позднее Дэн узнал, что такая политика сформировалась только в 1980-х, когда
компьютеры нашли широкое применение в университетах. До этого существовал иной
подход к дисциплине: наказывались лишь те, кто реально наносил ущерб своей
деятельностью, но не те, кто только вызвал подозрения.

Лиза не сдала Дэна SPA. Его решение помочь впоследствие привело их к свадьбе и
породило сомнения в незыблемости правил, которые им внушали с детства. Супруги
взялись изучать историю авторских прав, ограничений на копирование,
существовавших в Советском Союзе, и даже изначальную Конституцию Соединенных
Штатов. Они отправились на Луну, где встретили других беглецов от длинных рук
SPA. Когда в 2062 г. началось Восстание Тихо (Tycho Uprising), всеобщее право
на чтение вскоре стало одной из главных его целей.

Послесловие

Сражение за право читать идет уже сегодня. Хотя может потребоваться полсотни
лет развития событий в нынешнем направлении, чтобы позабыть былые свободы,
большая часть описанных законов и практических мер уже предложена либо
Администрацией Клинтона, либо издателями.

Единственное исключение: пока что ФБР и Microsoft не владеют монопольно
привилегированными паролями. Но эта идея естественно следует из проекта чипа
Clipper и схожих предложений Администрации Клинтона об обязательном
предоставлении всеми пользователями криптосистем своих ключей соответствующим
органам, [3] вместе с наблюдаемой долговременной тенденцией: компьютерные
системы предоставляют вечно отсутствующим операторам все большую власть над
теми, кто реально их использует.

SPA, означающее в действительности Software Publisher's Association
(Ассоциацию Издателей Программ), сегодня не является официальным полицейским
формированием, но действует, как будто это так. Они предлагают людям "стучать"
на своих друзей и сотрудников; подобно Администрации Клинтона, оправдывают
политику коллективной ответственности, согласно которой владельцы компьютеров
должны активно принуждать других соблюдать авторские права или самим быть
наказанными.

Сегодня SPA угрожает малым Internet-провайдерам, требуя разрешения следить за
всеми пользователями. Большая часть провайдеров пошла на это, поскольку они не
имеют средств отстаивать свои права в суде. (Atlanta Journal-Constitution, 1
Oct 96, D3.) Как минимум один провайдер, Community ConneXion (Oakland CA),
ответил отказом, после чего против него был подан иск. Недавно, по некоторым
данным, SPA его аннулировала, но собирается продолжить кампанию иными
средствами.

Университетская политика безопасности, описанная выше, не выдумана. К примеру,
в одном из университетов вблизи Чикаго компьютер выводит при входе в систему
следующее сообщение (пунктуация оригинала):

"This system is for the use of authorized users only. Individuals using this
computer system without authority or in the excess of their authority are
subject to having all their activities on this system monitored and recorded
by system personnel. In the course of monitoring individuals improperly using
this system or in the course of system maintenance, the activities of
authorized user may also be monitored. Anyone using this system expressly
consents to such monitoring and is advised that if such monitoring reveals
possible evidence of illegal activity or violation of University regulations
system personnel may provide the evidence of such monitoring to University
authorities and/or law enforcement officials".

В переводе

"Эта система предназначена для уполномоченных пользователей. Лица,
использующие эту систему в отсутствие полномочий либо с их превышением, будут
выявляться обслуживающим персоналом, а их действия - протоколироваться. В
целях администрирования либо при наблюдении за лицами, использующими систему
некорректно, действия полномочных пользователей также могут фиксироваться.
Каждый, кто использует систему, тем самым соглашается на мониторинг и
уведомляется, что, в случае обнаружения нелегальных действий или нарушения
правил Университета, свидетельства этих нарушений будут предоставлены
обслуживающим персоналом руководству Университета и/или официальным силам
поддержания правопорядка".

Это является интересным подходом к Четвертой Поправке: [4] заставить каждого
заранее отказаться от прав, которые она гарантирует.

Ссылки

*  The administration's "White Paper": Information Infrastructure Task Force,
   Intellectual Property and the National Information Infrastructure: The Report
   of the Working Group on Intellectual Property Rights (1995).

*  An explanation of the White Paper: The Copyright Grab, Pamela Samuelson,
   Wired, Jan. 1996
   http://www.wired.com/wired/archive/4.01/white.paper_pr.html

*  Sold Out, James Boyle, New York Times, 31 March 1996
   http://www.ese.ogi.edu/sold.out.html

*  Public Data or Private Data, Washington Post, 4 Nov 1996
   http://wp2.washingtonpost.com/cgi-bin/displaySearch?WPlate+33653+(database&geneva)%3adescription&and&19961102%3cevent_date

*  Union for the Public Domain-недавно созданная организация, выступающая
   против раздувания прав интеллектуальной собственности и за возврат к прежней
   политике.
   http://www.public-domain.org/

*  Философия GNU - коллекция статей о целях и принципах свободного
   программного обеспечения и проекта GNU.
   http://www.gnu.org/philosophy/philosophy.ru.html

В послесловии автора говорится о битве за право на чтение и против электронной
слежки. Эта битва начинается в настоящее время: вот ссылки на пару статей о
технологиях, которые разрабатываются, чтобы лишить вас права читать.

*  Electronic Publishing: Статья посвящена распространению книг в электронной
   форме и вопросам авторских прав, затрагивающих право читать копию.
   http://www.zdnet.com/zdnn/stories/news/0,4586,2324939,00.html

*  Books inside Computers: Программное обеспечение, предназначенное для
   контроля за тем, кто может читать книги и другие документы на PC.
   http://channels.microsoft.com/presspass/press/1999/Aug99/SeyboldPR.htm

Примечания переводчика:

1) Для тех, кто никогда не бывал на Луне: Тихо - это лунный цирк Тихо Браге.

2) Автор этого не планировал (я спрашивал), но "frank" можно перевести как
   "откровенный" - вот он и доболтался...

3) Такая политика получила название "key escrow". Информацию о ней можно найти
   на www.epic.org.
   http://www.epic.org/

4) Переводить Четвертую Поправку к Конституции США я не рискну:

   Amendment IV

   The right of the people to be secure in their persons, houses, papers, and
   effects, against unreasonable searches and seizures, shall not be violated,
   and no warrants shall issue, but upon probable cause, supported by oath or
   affirmation, and particularly describing the place to be searched, and the
   persons or things to be seized.

Проще говоря, это гарантия права на частную жизнь, неприкосновенность жилища,
запрет несанкционированных обысков, ареста и т.п.

Информация к размышлению (от переводчика):

Спустя примерно полгода после выхода в свет первой версии перевода этого
произведения я увидел в COMPUTERWORLD РОССИЯ #34/99 заметку "Экранный текст
станет четче", в которой сообщалось о разработке Micro$oft специального
программного обеспечения, предназначенного для "электронных книг". Больше
всего меня заинтересовало следующее заявление вице-президента Micro$oft Дика
Брасса:

   Издательствам нужны гарантии, что их книги нельзя будет нелегально
   тиражировать. Поэтому нам приходится готовить также инструменты защиты
   информации от копирования.

Комментарии излишни.
© Gazlan 2009 * gazlan@yandex.ru