Fruit Chiffon in a Chocolate Cookie Crust | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fruit Chiffon in a Chocolate Cookie Crust

Ingredients:
One can (16 ounces) fruit cocktail, packed in juice
One envelope unflavored gelatin
One large egg yolk
3 tablespoons lemon juice
2 teaspoons fresh grated lemon peel
Granulated sugar substitute to equal 1/2-cup sugar, divided
2/3 cup evaporated skim milk
Chocolate Cookie Crust (recipe follows)

Directions:
Drain fruit cocktail, reserving juice. Add enough water to juice to measure 3/4-cup. Cover and refrigerate fruit.

In small saucepan, sprinkle gelatin over juice. Let stand one to two minutes. Add egg yolk, lemon juice, lemon peel and sugar substitute to equal 1/4-cup sugar; beat with whisk until blended. Cook over medium heat, stirring constantly, until mixture boils; boil and stir one minute.

Remove from heat. Pour mixture into bowl; refrigerate, stirring occasionally, until mixture has consistency of unbeaten egg whites, 20 to 30 minutes.

Meanwhile, pour evaporated milk into metal bowl; place in freezer until very cold and ice crystals begin to form around edges, about one hour. Beat chilled milk and remaining sugar substitute on high speed of electric mixer until foamy.

Add gelatin mixture, beating until well blended. Pour into Chocolate Cookie Crust. Refrigerate three to four hours or until set. Garnish with reserved fruit cocktail.

divider

Chocolate Cookie Crust

Ingredients:
1/2 cup butter or margarine, softened
1/4 cup sugar
Sugar substitute to equal 1/2-cup granulated sugar
One egg
1 teaspoon vanilla extract
1-1/3 cups all-purpose flour
3 tablespoons Hershey's cocoa
1/2 teaspoon baking soda
1/8 teaspoon salt
2 tablespoons skim milk

Directions:
In large mixer bowl, beat butter, sugar and sugar substitute until light and fluffy. Add egg and vanilla; beat well. Stir together flour, cocoa, baking soda and salt; add alternately with milk to butter mixture, beating until well blended. Shape dough into two 6-inch long rolls. Wrap in plastic wrap. Freeze six to eifgt hours. Heat oven to 350-degrees. Lightly grease 9-inch pie square baking pan. Cut dough into 1/8-inch thick slices; arrange enough slices, edges touching, to cover bottom and sides of prepared pie plate. Bake seven to nine minutes. Cool.

Note:
Leftover dough can be used for cookies. Slice as directed. Bake at 375-degrees. on ungreased cookie sheet seven to nine minutes. Cookies can be crushed in blender or food processor and used to top sugar-free frozen yogurt, folded into sucrose-free whipped topping or used as a garnish on sugar-free cakes or puddings.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 190
Fat: 9g
Protein: 5g
Carbohydrates: 23mg
Cholesterol: 45mg
Sodium: 180mg
Exchanges: 1-1/2 Carbohydrate (1 fruit, 1/2 whole milk), 1 fat

Next
Chocolate Silk Mousse

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Chocolate Silk Mousse | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Silk Mousse

Ingredients:
1-1/4-ounce envelope unflavored gelatin
1/4 cup cold water
8 packets sweetener
1/3 cup unsweetened cocoa powder
3/4 cup nonfat (skim) milk
1/2 cup part-skim ricotta cheese
2 tablespoons natural vanilla
2 tablespoons rum extract
1/2 cup frozen non-dairy whipped topping
Thawed fresh strawberries (optional)

Directions:
In a small bowl, sprinkle gelatin over water; allow to stand two minutes to soften.

In a medium saucepan, stir together the Diabetisweet and cocoa. Stir in milk and cook over medium heat, stirring constantly, until the mixture is very hot. Add the gelatin mixture, stirring until gelatin is dissolved.

Transfer mixture to a medium bowl and refrigerate until slightly cold (do not allow to gel).

In a food processor or blender, combine ricotta cheese, vanilla, and rum extract. Blend until smooth. Transfer to a small bowl. Add the whipped topping; stir until well combined.

Gradually fold ricotta mixture into the cocoa mixture. Spoon into 4 dessert cups. Refrigerate until set, about 4 hours. If desired, decorate each serving with strawberries.

Recipe makes four servings.

Nutrition information per serving (mousse only):
Calories: 151
Total Fat: 6g
Saturated Fat: 5.6g
Protein: 8g
Carbohydrates: 13mg
Cholesterol: 16mg
Sodium: 150mg
Fiber: 2g
Calories from fat: 40% Exchanges: 1/2 very lean meat, 1 carbohydrate (1 bread/starch), 1 fat

Next
Pineapple Dessert

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Pineapple Dessert | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pineapple Dessert

Ingredients:
One can (14 ounces) unsweetened crushed pineapple in juice, undrained
1/4 cup pecan pieces (optional)
2 tablespoons lemon juice
Six packets sweetener
1 teaspoon cornstarch
4 tablespoons margarine, at room temperature
12 packets sweetener
One egg
1 cup cake flour
1-1/2 teaspoons baking powder
1/2 teaspoon baking soda
1/4 teaspoon cinnamon
1/4 teaspoon ground nutmeg
1/8 teaspoon ground ginger
1/3 cup buttermilk

Directions:
Drain pineapple, reserving 1/4-cup juice. Mix pineapple, pecans, 1-tablespoon lemon juice, six packets sweetener and cornstarch in bottom of 8-inch square or 9-inch round cake pan; spread mixture evenly in pan.

Beat margarine and 12 packets of sweetener in medium bowl until fluffy; beat in egg. Combine flour, baking powder, baking soda and spices in small bowl. Add to margarine mixture alternately with buttermilk, 1/4-cup reserved pineapple juice and remaining 1-tablespoon lemon juice, beginning and ending with dry ingredients. Spread batter over pineapple mixture in cake pan.

Bake in preheated 350-degree oven until browned and toothpick inserted in center comes out clean, about 25 minutes. Invert cake immediately onto serving plate. Serve warm or at room temperature.

Note:
If desired, maraschino cherry halves may be placed in bottom of cake pan with pineapple mixture.

Next
Chocolate Pineapple Desert

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Chocolate Pineapple Dessert | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Pineapple Dessert

Cookie crust ingredients:
2 cups biscuit mix
1/4 cup pecan pieces
2/3 cup pitted dates
Two egg whites
1 teaspoon vanilla
3 tablespoons warm water
6 tablespoons butter

Fillng ingredients:
One 20-ounce can crushed pineapple in its own juice
1/4 cup pineapple juice concentrate
1-1/4 cup 1% milk
6-serving package non-instant sugar-free chocolate pudding
2 tablespoons pecans (reserved)

Crust directions:
Use a blender or food processor to chop pecan pieces until finely ground. Sift biscuit mix, and stir in 1/4-cup pecans. Set aside.

Use a food processor or blender to purйe dates, gradually adding egg whites and warm water. Beat several minutes until creamy. Melt butter, and then stir in date cream and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended. Press the moist dough to the edges of a 9 x 11-inch pan or into two 9-inch pie pans. The crust will be about 1/4-inch thick.

Bake seven to ten minutes at 350-degrees until light brown on top edges. Set aside.

Filling:
Leave oven at 350-degrees.

Drain 3/4-cup juice from pineapple into a pan to be used later. Finish draining crushed pineapple, and distribute pineapple bits evenly on the baked cookie crust. Set aside. Returning to the pan of pineapple juice, add pineapple juice concentrate, and whisk milk into juices until blended. Add chocolate pudding powder. Heat on medium, stirring constantly, until at a full boil.

Pour hot pudding mix evenly over pineapple, just covering the edges of the crust. Bake at 350-degrees seven to ten minutes; then sprinkle on top 2-tablespoons finely chopped pecans, and bake for an additional three minutes.

Allow at least 15 minutes to cool and set. Serve warm or at room temperature.

Recipe makes 18, 2 x 3-inch servings.

Next
Sour Cream Apple Dessert

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Sour Cream Apple Dessert | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Sour Cream Apple Dessert

Cookie crust ingredients:
2 cups biscuit mix
1/4 cup pecan pieces
2/3 cup pitted dates
Two egg whites
1 teaspoon vanilla
3 tablespoons warm water
6 tablespoons butter

Fillng ingredients:
1-1/2 cups apple juice concentrate
2 teaspoons cinnamon
2 teaspoons vanilla
Five medium apples (about 6 cups)
2 cups light (or nonfat) sour cream
6-serving package non-instant sugar-free vanilla pudding
2 tablespoons pecans (reserved)

Crust directions:
Preheat oven to 350-degrees.

Use a blender or food processor to chop pecan pieces until finely ground. Sift biscuit mix, and stir in 1/4-cup pecans. Set aside. Use a food processor or blender to purйe dates, gradually adding egg whites and warm water. Beat several minutes until creamy. Melt butter, and then stir in date cream and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended.

Press the moist dough to the edges of a 9 x 11-inch pan or into two 9-inch pie pans. The crust will be about 1/4-inch thick.

Bake seven to ten minutes at 350-degrees until light brown on top edges. Set aside.

Filling:
Leave oven at 350-degrees.

Quarter, core, peel, and thinly slice apples.

In a microwave or on the stove, warm apple juice concentrate, cinnamon, and vanilla. Place sliced apples in a bowl of the warm apple juice mixture. Heat two minutes on high in the microwave; then stir apple pieces, and heat three more minutes on high. (If you don't have a microwave or would rather not use one, heat in juice on stove until apples are soft.) Using a slotted spoon, spread apple slices (without juice) evenly over the cookie crust.

Pour off the apple juice into a pot. Whisk sour cream into apple juice mixture until blended. Add vanilla pudding powder. Heat on medium, stirring constantly, until at a full boil.

Pour hot pudding mix evenly over sliced apples, just covering the edges of the crust.

Sprinkle on top 2-tablespoons finely chopped pecans, and bake at 350-degrees, 7-12 minutes.

Allow at least 20 minutes to cool and set. Serve warm or at room temperature.

Recipe makes 18, 2 x 3-inch servings.

Next
Sugar Free Rugelach

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Sugar Free Rugelach | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Sugar Free Rugelach

Ingredients:
1 cup margarine
8 ounces cream cheese, softened
2-3/4 cups all-purpose flour
2 teaspoons vanilla extract
1 cup chopped raisins
1 cup chopped walnuts
2 tablespoons ground cinnamon
1 cup apricot spreadable fruit

Directions:
Cream together the margarine and cream cheese in the bowl of an electric mixer. Blend in the vanilla. Mix in the flour. Chill the dough.
To make the Filling:
Mix together the chopped raisins, chopped walnuts, and cinnamon. If you have a food processor, place the whole walnuts and raisins into the bowl, sprinkle with the cinnamon, and chop them together by processing in short pulses.

Divide the dough into four equal portions. Roll out each portion into a 10 to 12-inch circle, 1/8-inch thick on a lightly floured board or between two sheets of waxed paper.

Spread a light layer of preserves (approximately 2-tablespoons) onto each dough circle. Sprinkle each circle with approximately 1/4-cup of the chopped nut-raisin-cinnamon mixture.

Cut each circle into 16 wedges using a pastry cutter or a pizza cutter. Roll each wedge from base to point. Place point down on a lightly greased or parchment lined baking sheets.

Filling:
Leave oven at 350-degrees.

Quarter, core, peel, and thinly slice apples.

Bake for 15-17 minutes at 375-degrees (or until golden). Remove to racks to cool.

Next
Cheesecake Dainties

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Cheesecake Dainties | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cheesecake Dainties

Source: Sugar Twin

Ingredients:
1 cup unbleached all-purpose flour
1/2 cup chopped walnuts
1/4 cup Brown SugarTwin
1/3 cup firm margarine, cut into pieces
8 ounces cream cheese
One large egg
2 tablespoons SugarTwin
1-1/2 tablespoons fresh lemon juice
1 tablespoon skim milk
1 teaspoon vanilla extract

Directions:
Preheat oven to 350-degrees. Prepare an 8-inch square pan with a baker's no-stick baking spray.
Mix together flour, walnuts, Brown Sugar Twin, and margarine. Remove 1/2-cup for topping. Press remainder firmly in pan. Bake for 12 minutes.

Meanwhile, beat cream cheese, egg, Sugar Twin, lemon juice, milk, and vanilla until smooth. Spread over baked crust, spreading to cover. Sprinkle with remaining crumb mixture. Return to oven and bake 25 minutes. Cool.

To serve, cut into 2-inch squares.

Recipe makes 32, 2-inch squares.

Nutrition information per serving:
Calories: 70
Total Fat: 6g
Saturated Fat: 2.1g
Protein: 1g
Carbohydrates: 4mg
Cholesterol: 13mg
Sodium: 48mg
Calories from fat: 70% Exchanges: 1 fat

Next
Pineapple Squares

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Pineapple Squares | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pineapple Squares

Ingredients:
Oil and flour nonstick spray
3/4 cup juice-packed canned pineapple chunks, drained
One large egg
1/2 cup unsweetened pineapple juice
1/4 teaspoon orange extract
1 tablespoon olive oil
1 1/2 cups flour
1 teaspoon baking soda
1 teaspoon baking powder

Directions:
Preheat oven to 350-degrees. Spray an 8-inch square baking pan with aerosol spray. Measure out 1/4-cup of the pineapple chunks. Puree until smooth in a food processor or blender. In the bowl of an electric mixer, beat together pureed pineapple, egg, pineapple juice, orange extract, and oil. Add the flour, baking soda and powder and beat again Stir in the remaining 1/2-cup pineapple chunks.
Spoon the batter into the prepared pan. Smooth the top and bake for 25 minutes until a knife inserted in the middle comes out clean. Cool and cut into 25 squares.

Recipe makes 25 squares.

Nutrition information per square:
Calories: 82
Total Fat: 1g
Saturated Fat: 0.2g
Protein: 2g
Carbohydrates: 14mg
Cholesterol: 18mg
Sodium: 146mg
Fiber: trace
Calories from fat: 19% Exchanges: 1 carbohydrate (bread/starch)

Next
Peanut-Butter Squares

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Peanut-Butter Squares | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut-Butter Squares

Ingredients:
Oil and flour aerosol spray
One large egg
1/4 cup all natural peanut butter
1 cup ripe mashed banana
1/4 cup skim milk
1 cup flour
1 teaspoon baking soda
1 teaspoon baking powder
1/4 cup chopped dry-roasted peanuts

Directions:
Preheat oven to 350-degrees. Spray an 8-inch square baking pan with aerosol spray. In the bowl of an electric mixer, beat together the egg, peanut butter and banana until smooth.

Beat in the milk and flour, baking soda and powder, and then stir in the peanuts. Spread the batter evenly in the pan. Bake for 30 minutes until browned. Cool and cut into 25 squares.

Recipe makes 25 squares.

Nutrition information per two squares:
Calories: 108
Total Fat: 4g
Saturated Fat: 0.8g
Protein: 4g
Carbohydrates: 14mg
Cholesterol: 18mg
Sodium: 148mg
Fiber: 2g
Calories from fat: 37% Exchanges: 1 carbohydrate (bread/starch), 1 fat

Next
Pears with Creamy Chocolate Sauce

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Pears with Creamy Chocolate Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pears with Creamy Chocolate Sauce

Delectable on pears, this creamy sauce is wonderful on cakes and frozen desserts.

Ingredients:
1 tablespoon butter or margarine
1 tablespoon all purpose flour
One can (28 ounce) no sugar added pear halves in fruit juice
2 tablespoons cocoa
One can 2% evaporated milk
3 tablespoons measurable sweetener

Directions:
In small saucepan, melt butter; whisk in flour; cool one minute. Drain pears reserving 1/3-cup liquid; set pear halves aside. Whisk cocoa into reserved liquid; add to flour mixture in saucepan. Stir in evaporated milk. Cook over medium heat until mixture boils and thickens. Remove from heat and stir in sweetener. Divide pear halves on serving plates; drizzle with warm chocolate sauce.

Recipe makes eight servings.

Next
Blueberry Grunt

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Blueberry Grunt | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blueberry Grunt

Ingredients:
1-1/2 tablespoons cornstarch
3/4 cup measurable sweetener
1/2 cup water
1 teaspoon lemon juice
1 teaspoon grated orange rind
4 cups fresh or frozen blueberries
1 cup all-purpose flour
1-1/2 teaspoons baking powder
1/3 cup measurable sweetener (or eight packets)
1/2 teaspoon ground cinnamon
1/8 teaspoon ground nutmeg
1/2 teaspoon salt
3 tablespoons cold margarine, cut into pieces
1/2 cup skim milk
1/2 teaspoon grated orange rind

Directions:
Mix cornstarch, 3/4-cup sweetener, water, lemon juice, and 1-teaspoon grated orange rind in 8-inch skillet. Add blueberries and heat to boiling. Boil, stirring constantly, until mixture is thickened, one minute. Reduce heat and simmer, uncovered, five minutes.

Combine flour, baking powder, remaining sweetener, spices, and salt in medium bowl; cut in margarine with pastry blender until mixture resembles coarse crumbs. Stir in milk, forming soft dough; stir in 1/2-teaspoon orange rind. Spoon dough in six mounds on simmering blueberry mixture. Cook, covered, on low heat until dumplings are done, 12 to 14 minutes. Serve warm.

Tip:
Blueberry Grunt is delicious served with fat-free, no-sugar-added ice cream or frozen yogurt, or with dollops of light whipped topping.

Next
Country Peach Tart

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Country Peach Tart | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Country Peach Tart

Country Peach Tart

Ingredients:
1 tablespoon flour
1/3 cup measurable sugar substitute (or eight packets)
1/3 cup skim milk
1/3-cup apricot preserves with artificial sweetener OR apricot spread-able fruit 4 cups sliced pitted, peeled fresh peaches (about four medium) or frozen peaches, thawed
Ground nutmeg

Directions:
Roll pastry on floured surface into 12-inch circle; transfer to ungreased cookie sheet. Combine flour and sweetener, sprinkle over peaches and toss. Arrange peaches on pastry, leaving a 2-inch border around edge of pastry. Sprinkle peaches lightly with nutmeg. Fold edge of pastry in. Bake tart in preheated 425-degrees oven until crust is browned and fruit is tender, 25 to 30 minutes.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 124
Total Fat: 5g
Protein: 2g
Carbohydrates: 20mg
Cholesterol: 5mg
Sodium: 60mg
Fiber: 2g
Calories from fat: 40% Exchanges: 1/2 Fruit, 1 Bread, 1 Fat

Next
Bittersweet Chocolate Torte

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Bittersweet Chocolate Torte | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Bittersweet Chocolate Torte

Ingredients:
6 tablespoons margarine
4 ounces unsweetened chocolate
1/3 cup skim milk
1/3-cup apricot spread-able preserves
2 teaspoons instant coffee crystals
1 egg yolk
1 teaspoon vanilla
36 packets artificial sweetener or 1-1/2 cups measurable sweetener
Three egg whites
1/8 teaspoon cream of tarter
1/4 cup all-purpose flour
1/8 teaspoon salt
Rich Chocolate Glaze - optional (recipe below)

Directions:
Heat margarine, chocolate, milk, apricot preserves and coffee crystals in small pan, whisking frequently, until chocolate is almost melted. Remove pan from heat; continue whisking until chocolate is melted and mixture is smooth. Whisk in egg yolk and vanilla, add sugar substitute, whisking until smooth. Beat the egg whites and cream of tarter to stiff peaks in large bowl. Fold chocolate mixture into egg whites; fold in combined flour and salt. Lightly grease bottom of 8-inch round cake pan and line with parchment or baking paper. Pour cake batter in pan. Bake in preheated oven, 350-degree oven until cake is just firm when lightly touched, 20 to 25 minutes, and toothpick comes out clean (Be careful to not overbake). Carefully loosen side of cake from pan with small sharp knife, which will keep cake from cracking as it cools. Cool cake completely in pan on wire rack; refrigerate until chilled, one to two hours. Remove cake from pan and place on serving plate. Spread with Rich Chocolate Glaze, if desired.

Recipe makes 12 servings.

Nutrition information per serving:
Calories: 139
Total Fat: 11g
Protein: 3g
Carbohydrates: 11mg
Cholesterol: 18mg
Sodium: 108mg
Exchanges: 1/2 Bread, 2 Fat

divider

Rich Chocolate Glaze

Ingredients:
1/4 cup skim milk
2 ounces unsweetened chocolate, cut into small pieces
1/2 cup sugar substitute for recipes, or 12 packets sweetener

Directions:
Heat milk and chocolate in small saucepan, whisking frequently, until almost melted; remove from heat and whisk until chocolate is melted and smooth. Whisk in sugar substitute. Cool to room temperature, refrigerate glaze, if necessary, until thick enough to spread.

Recipe makes about 1-cup of glaze.

Nutrition information for 1-cup glaze:
Calories: 30
Total Fat: 3g
Protein: 1g
Carbohydrates: 3mg
Cholesterol: 18mg
Sodium: 3mg
Exchanges: 1/2 Fat

Next
Pumpkin Cheese Cake

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Pumpkin Cheesecake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pumpkin Cheesecake

Cookie crust ingredients:
1/4 cup pecan pieces
2 cups biscuit mix
2/3 cup pitted dates
Two egg whites
3 tablespoons warm water
1 teaspoons vanilla
6 tablespoons butter
2 tablespoons pecans (reserved)

Pumpkin layer ingredients:
1-1/2 cups light cream cheese
1 cup solid pack pumpkin
3/8 teaspoon pumpkin pie spice
3/8 teaspoon cinnamon
12 packets sweetener
1/2 teaspoon vanilla
Three drops maple flavoring (if available)
1/2 cup whipping cream

Crust:
Preheat oven to 350 degrees.

Use a blender or food processor to chop pecan pieces until finely ground. Sift biscuit mix, and stir in the pecans. Set aside.

Use blender or food processor to puree dates, gradually adding egg whites and warm water. Beat several minutes until creamy. Melt butter, and then stir in date cream and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended.

Spread the moist dough to the edges of a 9 x 11-inch pan. The crust will be about 1/4-inch thick. Bake at 350-degrees for seven to ten minutes until slight touches of light brown can be seen. Set aside to cool.

Pumpkin layer:
Puree in food processor or blender all ingredients except whipping cream. Meanwhile, beat whipping cream until stiff.

Then fold whipped cream into the pumpkin puree. Spread this pumpkin mixture evenly across the cooled cookie crust, and sprinkle on top 2-tablespoons finely chopped pecans. Refrigerate until within one to two hours before serving. Then place the pan of pumpkin squares on an even surface in the freezer for 30 to 90 minutes until ready to serve.

Recipe makes 18, 2 x 3-inch servings.

Next
Pumpkin Cheesecake II

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Pumpkin Cheesecake II | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pumpkin Cheesecake II

Ingredients:
1-cup graham cracker crumbs
1/2-cup gingersnap cookie crumbs
3 packets sweetener or 2 tablespoons measurable
5 tablespoons margarine, melted
Two packages (8 ounces each) fat-free cream cheese, softened
One package (8 ounces) reduced-fat cream cheese, softened
1 cup canned pumpkin
Two eggs
Two egg whites
24 packets sweetener or 1-cup measurable sweetener
2 tablespoons cornstarch
2 teaspoons ground cinnamon
1 teaspoon ground ginger
1/2 teaspoon ground cloves

Directions:
Mix graham crackers and gingersnap crumbs, three packets (or 2-tablespoons) sweetener, and melted margarine in bottom of 8 or 9-inch spring form pan; reserve 2-tablespoons crumb mixture. Pat remaining mixture evenly on bottom and 1/2-inch up side of pan. Bake in preheated 350-degree oven until crust is lightly browned, about eight minutes. Cool on wire rack.

Reduce oven to 300-degrees. Beat cream cheese until smooth in mixing bowl; mix in pumpkin, eggs and egg whites. Mix in 24 (or 1-cup) packets sweetener, cornstarch and spices. Pour mixture into crust in pan. Wrap the bottom of spring form pan with aluminum foil and place in roasting pan on middle oven rack; add 1-inch of hot water to pan. Bake in preheated 300-degree oven just until set in the center, 45 to 50 minutes. Remove cheesecake from roasting pan; sprinkle with reserved crumbs and return to oven. Turn oven off and let cheesecake cool with door ajar for three hours. Refrigerate eight hours or overnight. Remove side of spring form pan before serving.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 168
Total Fat: 8g
Protein: 2g
Carbohydrates: 16mg
Cholesterol: 37mg
Sodium: 311mg
Fiber: 2g
Calories from fat: 40% Exchanges: 1 Milk, 1/2 Starch, 2 fat

Next
Chocolate Swirl Cheesecake

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Chocolate Swirl Cheesecake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Swirl Cheesecake

Ingredients:
1-1/4 cups vanilla wafer crumbs
4 tablespoons margarine or butter, melted
3 packets sweetener or 2-tablespoons measurable sweetener
Two packages (8 ounces) fat-free cream cheese, softened
One package (8 ounces) reduced fat cream cheese
5-1/2 teaspoons sweetener for recipes or 3/4-cup measurable sweetener
Two eggs
Two egg whites
2 tablespoons cornstarch
1 cup reduced-fat sour cream
1 teaspoon vanilla
1/2 cup semi-sweet chocolate chips, melted

Directions:
Mix vanilla wafer crumbs, margarine or butter and 1-teaspoon sweetener in bottom of a 9-inch spring form pan. Pat mixture evenly on bottom and 1/2-inch up side of pan. Bake in preheated 350-degree oven about 8 minutes. Cool on wire rack. Reduce oven temperature to 300 degrees.

Beat cream cheese and 5-1/2 teaspoons sweetener in a large bowl until fluffy; beat in eggs, egg whites and cornstarch. Stir in sour cream and vanilla until well blended. Remove 1/2-cup cheesecake mixture. Pour remaining mixture into crust in pan. Add melted chocolate to 1/2 cup reserved cheesecake batter; mix well. Place dollops of chocolate mixture on top of cheesecake. Using butter knife or spatula, gently swirl chocolate mixture into the cheesecake.

Wrap the bottom of spring form pan with aluminum foil and place in roasting pan on middle oven rack; add 1-inch hot water to pan. Bake in preheated 300-degree oven just until set in center, 45 to 60 minutes. Remove cheesecake from roasting pan and return to oven. Turn oven off and let cheesecake cool in oven with door ajar for three hours. Refrigerate eight hours or overnight. Remove side of spring form pan; place cheesecake on serving plate.

Recipe yields 16 servings.

Nutrition information per serving:
Calories: 206
Total Fat: 11g
Protein: 8g
Carbohydrates: 15mg
Cholesterol: 43mg
Sodium: 243mg
Exchanges: 1 Milk, 2-1/2 Fat

Next
New York Cheesecake

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


New York Cheesecake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

New York Cheesecake

New York Cheesecake

Ingredients:
1-1/4 vanilla wafer crumbs
4 tablespoons butter or margarine, melted
2 tablespoons measurable artificial sweetener or three packets artificial sweetener
Three packages reduced-fat cream cheese, softened
ѕ cup measurable artificial sweetener or 18 packets
Two eggs
Two egg whites
2 tablespoons cornstarch
1 cup reduced-fat sour cream
1 teaspoon vanilla
One pint strawberries, sliced, or raspberries and blueberries (optional)

Directions:
Preheat oven to 325-degrees.

Mix vanilla wafer crumbs, butter and three packets sweetener in bottom of a 9-inch spring form pan. Reserve 1-tablespoon of crumb mixture. Pat remaining mixture evenly on bottom and Ѕ-inch up the inside of pan.

Bake in preheated oven until crust is lightly browned, about eight minutes. Cool on wire rack.

Beat cream cheese and ѕ-cup sweetener in a large bowl until fluffy; beat in eggs, egg whites and cornstarch. Mix in sour cream and vanilla until well blended. Pour mixture into crust in pan.

Place cheesecake in oven. Bake in preheated oven until just set in center, 45-50 minutes. Remove from oven, sprinkle with reserved crumbs. Cool completely.

Refrigerate eight hours or overnight. Remove side of pan; place cheesecake on serving plate. Serve with fresh fruit if desired.

Recipe yields 12 servings.

Nutrition information per serving:
Calories: 158
Total Fat: 10g
Protein: 7g
Carbohydrates: 10mg
Cholesterol: 50mg
Sodium: 234mg
Exchanges: 1 milk, 2 fat

Next
No Bake Cheesecake

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


No Bake Cheesecake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

No Bake Cheesecake

Ingredients:
1-3/4 cups graham cracker crumbs
1/2 cup butter
1/2 teaspoon ground cinnamon
One (.6 ounce) package sugar free lemon flavored gelatin
1 cup boiling water
One (8 ounce) package reduced fat cream cheese
2 teaspoons vanilla extract
1 cup frozen light whipped topping, thawed

Directions:
Preheat oven to 350-degrees. In a medium bowl, combine graham cracker crumbs, butter and cinnamon. Mix well and press into the bottom of a 9-inch square pan. Bake in preheated oven for eight to ten minutes. Remove from oven and allow to cool.

Dissolve lemon gelatin in boiling water. Let cool until thickened, but not set. In a large bowl, beat cream cheese and vanilla until smooth. Blend in lemon gelatin. Fold in whipped topping.

Pour filling into crust. Sprinkle top with graham cracker crumbs. Refrigerate over night.

Next
Best Pineapple Cheesecake

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


Best Pineapple Cheesecake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Best Pineapple Cheesecake

Graham Cracker Crust:
Butter-flavored cooking spray
14 double graham cracker cookies, finely crushed (1 cup)
2 tablespoons butter, melted

Pineapple Cheesecake:
1/2 cup non-fat buttermilk
One slice white bread
1/3 cup part-skim ricotta cheese
1 large egg
2 tablespoons natural vanilla
6 packets sweetener
1/4 cup water
One 12-ounce can crushed pineapple, packed in natural juice, well drained

Directions:
To prepare crust: Preheat the oven to 350°F. Lightly coat a 9-inch pie pan with cooking spray.

In a medium bowl, thoroughly mix the graham cracker crumbs and melted butter. Press into prepared pan.

Bake for 15 minutes, until lightly browned. (Since ovens vary in temperature, check after 12 minutes. Do not allow it to over-brown.) Cool before filling.

To prepare filling: In a food processor or blender, combine everything except the pineapple. Process until smooth. Fold in crushed pineapple.

Bake for 45 minutes, until set. Cool in refrigerator.

Note:
The filling can be baked without the crust.

Recipe makes six servings.

Nutrition information per serving (with crust):
Calories: 190
Total Fat: 8g
Saturated Fat: 3.9g
Protein: 5g
Carbohydrates: 24mg
Cholesterol: 51mg
Sodium: 212mg
Fiber: 1g
Calories from fat: 38% Exchanges: 1-1/2 carbohydrate (1 bread/starch, 1/2 fruit), 1 fat

Back
Main Contents

Desserts

To Your Health!
Fitness and Freebies

space Fruit Chiffon in a Chocolate Cookie Crust | Chocolate Silk Mousse | Pineapple Dessert | Chocolate Pineapple Desert | Sour Cream Apple Dessert | Sugar Free Rugelach | Cheesecake Dainties | Pineapple Squares | Peanut-Butter Squares | Pears with Creamy Chocolate Sauce | Blueberry Grunt | Country Peach Tart | Bittersweet Chocolate Torte | Pumpkin Cheesecake | Pumpkin Cheesecake II | Chocolate Swirl Cheesecake | New York Cheesecake | No Bake Cheesecake | Best Pineapple Cheesecake | space


About eBook Dedicated to the Diabetic Diet | Fitness and Freebies

About

Fitness and Freebies is run, maintained and owned by "Just Jeni", a certified Fitness and Nutrition Consultant.

The main focus of Fitness and Freebies is your health. Nutrition is fast becoming a serious health concern for all persons. Portion sizes are totally out of control in our society as is the intake of fast and "junk" foods. All it takes is a bit of guidance in the right direction regarding your diet, and you can be well on your way to a healthier, fit life. Proper diet and nutrition need not be as painful as they may sound when one first begins their quest to a healthier lifestyle.

There are recipes in many different diet categories on Fitness and Freebies as well. F & F respects all diet choices/needs, and holds the belief that each individual is unique. Therefore, each person may find a particular diet better suited to his or her health needs/desires. In addition, one need not give up every food they love. Perhaps some modifications will be necessary, but the rewards are well worth it. As you find yourself feeling better, healthier and more in control of your fitness/wellness destiny, the road will be much easier to travel.

Fitness and Freebies also offers support and help in the most common fitness concerns and problems regarding fitness goals for a healthier lifestyle - as opposed to athletics and/or sports related fitness. The techniques and the approach are geared to those seeking a normal lifestyle - not that of an athlete. They are realistic, simple to follow and require very little investment or time. It is the firm belief of F & F that knowledge truly is power.

To your health!

Next
Diabetes

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Cooking With Alcohol | Fitness and Freebies

Cooking With Alcohol

If you have diabetes and you decide that you want to have an occasional alcoholic drink, it is important that you talk with your doctor first to determine if it is safe for you to do so. Alcohol in mixed drinks, wine, or beer can affect blood sugar levels differently, depending on whether you have type 1 or type 2 diabetes, the medications that you are taking, the level of your diabetes control, etc.

But, what about cooking with alcohol? This seems to be of concern to some of you as we occasionally call for alcohol in our cooking -- it's an excellent way to add flavor to foods. Most, but not all of the alcohol disappears, or evaporates, leaving few calories.

The U.S. Department of Agriculture has published the following information concerning the alcohol content in cooked foods. You may find the results interesting and helpful in your cooking of other recipes which include alcohol.

Preparation Procedure: Alcohol added to boiling liquid & removed from heat
Percent alcohol retained: 85% alcohol

Preparation Procedure: Alcohol flamed
Percent alcohol retained: 75%

Preparation Procedure: No heat, stored overnight
Percent alcohol retained: 70%

Preparation Procedure: Baked, 25 minutes, alcohol not stirred into mixture
Percent alcohol retained: 45%

Preparation Procedure: Baked/simmered, alcohol stirred into mixture:
15 minutes 40%
30 minutes 35%
1 hour 25%
1.5hours 20%
2 hours 10%
2.5 hours 5%

Perhaps your doctor said "Nope, no alcohol at all". Well, okay we can deal with this! There are substitutions you can make in recipes calling for wine, beer, etc. Here are some suggestions:

In savory dishes for each cup (240 ml) of wine in the recipe, substitute 7/8 cup (210 ml) of fat-free low-sodium chicken, beef, vegetable broth, apple juice, white grape juice, or tomato juice, with 2 tablespoons (30 ml) fresh lemon juice or vinegar.

In desserts, substitute fruit juice for the wine, adding a dash of balsamic vinegar to the juice.

For orange liqueur such as Grand Marnier, use an equivalent amount of frozen orange juice concentrate plus some grated orange zest.

For coffee liqueur, use double-strength espresso or instant coffee made with 4 to 6 times the amount of coffee normally used.

For brandy or rum, try a small amount of brandy or rum extract, or pure vanilla extract.

Next
Your Personal Eating Style

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Almond-Apricot Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Almond-Apricot Bread

Ingredients:
3-3/4 cups all-purpose flour
One package active dry yeast
3/4 cup milk
1/4 cup sugar
1/4 cup butter or margarine
1/2 teaspoon salt
Four eggs
1 teaspoon finely shredded lemon peel
3 tablespoons apricot preserves
2/3 cup ground almonds
1/2 cup finely snipped dried apricots
3 tablespoons sugar
1/4 teaspoon lemon juice
1 tablespoon water

Directions:
In a large mixing bowl stir together 1-1/2 cups of the flour and the yeast. Set flour mixture aside.

In a medium saucepan heat and stir the milk, the 1/4-cup sugar, butter, and salt just until warm (120 to 130-degrees) and butter almost melts. Add milk mixture to flour mixture. Separate one of the eggs (reserve and chill egg white add two of the whole eggs and the egg yolk to the milk-flour mixture. Beat with an electric mixer on low to medium speed 30 seconds, scraping side of the bowl. Beat on high speed three minutes. Using a wooden spoon, stir in lemon peel and as much of the remaining flour as you can.

Turn dough out onto a lightly floured surface. Knead in enough of the remaining flour to make a moderately soft dough that is smooth and elastic (six to eight minutes total). Shape the dough into a ball. Place dough in a lightly greased bowl, turning once to grease the surface of the dough. Cover and let rise in a warm place until double (1 to 1-1/2 hours).

For filling, in a small saucepan heat apricot preserves just until melted. Remove from heat and stir in the almonds, apricots, the 3-tablespoons sugar, the reserved egg white, and lemon juice; set aside.

Punch dough down. Turn dough out onto a lightly floured surface Divide dough in half. Cover and let rest for ten minutes.

In a small mixing bowl use a fork to beat the remaining whole egg and the water. Set aside.

Roll each half of the dough into a 12 x 10-inch rectangle. Cut each rectangle into three 10 x 4-inch strips (six strips total). Spread 3 tablespoons of the apricot filling down the center of each strip. Brush edges of the rectangles with some of the egg mixture. Fold long sides of dough over filling. Press edges to seal.

To shape the bread, place three filled ropes, seam sides down, 1-inch apart on a lightly greased baking sheet. Starting in the middle, loosely braid the ropes by bringing the left rope underneath the center rope; lay it down. Bring the right rope under the new center rope; lay it down. Repeat to end. On the other end, braid by bringing outside ropes alternately over center rope to the center. Press ends together to seal. Tuck ends under. Braid the remaining three ropes on another lightly greased baking sheet. Cover and let rise in a warm place until nearly double (45 to 60 minutes).

Brush loaves with some more of the egg mixture. Bake in a 350-degree. oven about 30 minutes or until bread sounds hollow when lightly tapped. (If necessary, cover loosely with foil the last 15 minutes of baking to prevent overbrowning.) Remove from baking sheets and cool on wire racks. Make-ahead tip: Prepare and bake bread as directed; cool completely. Place loaves in an airtight container or bag and store at room temperature or in the refrigerator. Or place bread in a freezer container or bag and freeze for up to three months. Before serving, thaw bread at room temperature for two to three hours.

Next
Orange Chocolate Chip Bread

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Angel Food Cake with Blueberry Yogurt Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Angel Food Cake with Blueberry Yogurt Sauce

Ingredients:
Ѕ cup frozen blueberries
One purchased round (12 ounces) angel food cake
Ѕ cup vanilla nonfat yogurt
3 teaspoons granulated sugar
1 teaspoon lemon juice

Directions:
Allow blueberries to thaw slightly. Cut angel food cake into 12 slices. Stir together yogurt, sugar and lemon juice in small bowl. To serve, spoon yogurt mixture and blueberries evenly over cake slices.

Recipe makes 12 servings.

Note: This is a favorite recipe from The Sugar Association, Inc.

Nutrition information per serving:
Calories: 84
Total Fat: <1g
Saturated Fat: <1g
Carbohydrates: 19g
Cholesterol: 0mg
Protein: 2g
Sodium: 218mg
Fiber: <1g
Exchanges: 1 Starch

Next
Hearty Corn Cakes

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Ants on a Log | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Ants on a Log

Ingredients:
One large celery rib, washed
3 tablespoons reduced-fat cream cheese
12 dark raisins

Directions:
Fill the celery with the cream cheese. Top with the raisins.

Cut into four "logs" and serve.

Recipe makes two servings.

Nutrition information per serving:
Calories: 69
Total Fat: 4g
Saturated Fat: 2.5g
Carbohydrate: 6g
Cholesterol: 13mg
Sodium: 85mg
Fiber: 1g
Protein: 3g
Calories from fat: 51%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1/2 carbohydrate (1/2 fruit), 1 fat

Next
Peanut Butter Granola

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Apple Cranberry Streusel Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Apple Cranberry Streusel Pie

Ingredients:
Pastry for single crust 9-inch pie
24 packets sweetener or 1 cup measurable sweetener
1 tablespoon cornstarch
1-1/2 cups fresh or frozen, thawed cranberries
1-cup apple cider or unsweetened apple juice
6 packets sweetener or 1/4-cup measurable sweetener
3/4 teaspoon ground cinnamon
1/4 teaspoon ground nutmeg
1/4 teaspoon salt
5 cups sliced cored peeled Granny Smith or other baking apples (about five)
Streusel Topping (recipe follows)

Directions:
Roll pastry on floured surface into circle 1-inch larger than inverted 9-inch pie pan. Ease pastry into pan, trim and flute edge. Combine 24 packets and cornstarch in small saucepan; stir in cranberries and apple cider. Heat to boiling; reduce heat and simmer, stirring constantly, until thickened, about one minute. Combine six packets sweetener, cinnamon, nutmeg and salt. Sprinkle over fruit in large bowl and toss to coat. Pour cranberry mixture over apples and mix gently. Arrange fruit in pie pastry, sprinkle Streusel Topping (follows) over fruit. Bake pie in preheated 400-degree oven until pastry is golden and apples are tender, about 50 to 60 minutes. Cover pie loosely with aluminum foil during last 20 to 30 minutes of baking time. Recipe makes eight servings.

Divider

Streusel Topping

1/4 cup quick-cooking oats
3 tablespoons flour
12 packets sweetener or 1/2-cup measurable sweetener
1 teaspoon ground cinnamon
1/2 teaspoon nutmeg
4 tablespoons cold margarine cut into pieces

Directions:
Combine oats, flour, sweetener, cinnamon and nutmeg in small bowl; cut margarine with pastry blender until mixture resembles coarse crumbs.

Nutrition information per serving:
Calories: 238
Total Fat: 11g
Carbohydrates: 35g
Cholesterol: <1mg
Protein: 1g
Sodium: 20mg
Fiber: <1g
Exchanges: 1-1/2 Fruit, 1 Starch, 2 fat

Next
Banana Cream Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Applesauce Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Applesauce Cake

Ingredients:
Three eggs
1/4 cup olive oil
1 cup unsweetened applesauce
1 cup frozen apple juice concentrate, thawed
2-1/4 cups all-purpose flour
1 tablespoon baking soda
1 teaspoon ground ginger
1-1/2 cups ground almonds
Two apples - peeled, cored and finely chopped
One (8 ounce) package cream cheese
3 tablespoons unsweetened apple butter
2 tablespoons frozen apple juice concentrate, thawed

Directions:
Preheat oven to 350-degree. Grease and flour one 9-inch square baking pan. Beat the eggs until they drop like ribbons from the beaters. Continue beating and add the oil in a thin stream.

Beat in the 1-cup applesauce and the 1-cup unsweetened apple juice concentrate.

Beat in the flour gradually until well blended. Add the baking soda, ground ginger, ground almonds and apples, mix to combine. Pour the batter into the prepared pan and bake at 350-degrees for about 40 minutes or until the cake tests done. Let cake cool on a rack for 15 minutes before turning out of pan. Cool completely before frosting.

Carefully slice the cake in half horizontally with a long serrated knife. Fill and frost with Apple Butter Frosting.

To Make Apple Butter Frosting:
Beat the cream cheese until soft and fluffy. Gradually beat in the apple butter and remaining 2-tablespoons apple juice concentrate.

Next
Jewish Apple Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Jewish Apple Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Jewish Apple Cake

Ingredients:
3 cups flour
2-1/2 cup sugar
1 cup applesauce
Four eggs
1/3 cup orange juice
2-1/2 teaspoons vanilla
3 teaspoon baking soda
Six Granny smith apples
2 teaspoon cinnamon
5 tablespoon sugar

Directions:
Beat together the first seven ingredients until smooth.

Peel and thinly slice apples. Add sugar and cinnmaon to the apples.

Put a thin layer of batter on the bottom of a prepared tube pan, then a layer of apples, more batter, more apples and top off with remaining batter.

Bake at 350-degrees for 1 hour and 45 minutes. ( you may want to put a layer of alumium foil over the top during the last 15 minutes of baking to avoid too much browning).

Next
German Apple Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


German Apple Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

German Apple Cake

Ingredients:
1/4 cup margarine, softened
5 teaspoons measurable sweetener
2 tablespoons strawberry spreadable fruit
One egg, beaten
1 teaspoon vanilla
1/4 cup skim milk
1 cup self-rising flour
One medium Granny Smith apple
2 teaspoons lemon juice
1/2 teaspoon cinnamon
1/4 teaspoon measurable sweetener

Directions:
Beat margarine, sweetener and spread-able fruit together until combined and creamy.

Mix together the egg, vanilla and milk. Add to the margarine mixture alternately with the self-rising flour. The mixture will be thick. Spoon mixture into a greased and parchment-paper lined 8-inch round cake pan.

Peel and core apple; cut into slices. Dip slices into lemon juice. Place decoratively on top of cake mixture.

Bake in preheated 350-degree oven for 30 minutes or until toothpick comes out clean. Turn out onto a towel; peel off parchment paper. Invert onto a wire rack with apple on top. Sprinkle with cinnamon and additional Equal while cake is still warm.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 120
Total Fat: 5g
Carbohydrate: 16g
Cholesterol: 21mg
Sodium: 230mg
Protein: 2g
Exchanges: 1 Bread, 1 Fat

Next
Peach Almond Upside Down Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Chunky Applesauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chunky Applesauce

Ingredients:
30 medium tart apples, peeled and quartered
4 cups water
2 tablespoons cinnamon
Sweetener to equal eight teaspoons sugar

Directions:
Place apples and water in a large kettle. Cover and cook over medium heat 30 to 40 minutes or until apples are tender. Remove from heat. Using a potato masher, mash apples to desired consistency. Stir in cinnamon and sweetener.

Recipe makes about 14-cups.

Nutrition information per 1/2-cup serving:
Calories: 103
Protein: trace
Fat: trace
Cholesterol: 0mg
Sodium: trace
Carbohydrates: 27g
Diabetic Exchanges: 1/2 Fruit

Next
Maple Flavored Syrup

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Aspartame: The World Agrees, It is Safe! | Fitness and Freebies

Aspartame: The World Agrees, It is Safe!

Any weight-conscious consumer will frequently encounter the sweetener aspartame as a sugar substitute. Beyond dieters, controlling sugar intake can be vital for people with or at risk for diabetes. So it's natural to consider the safety of an ingredient found in a growing array of foods and beverages, from low-calorie desserts to breakfast cereals.

Government agencies, health organizations and respected centers of science have been involved in these studies. Their conclusions are remarkably uniform – aspartame poses no health risks to the general population.

Rigorous study
The United States Food and Drug Administration (FDA) reports that it has reviewed over 100 toxicological and clinical studies on aspartame. That's a worldwide point of view. Also pronouncing aspartame safe are the European Union's Scientific Committee for Food; the United Nations' Joint Expert Committee on Food Additives; the World Health Organization; and many, many more (some are listed at end of this article.)

In all, more than 90 countries have approved aspartame.

The Massachusetts Institute of Technology's Clinical Research Center has studied whether aspartame consumption leads to any physical and psychological effects different from the effects of sugar or a placebo.

The conclusion:
Even large amounts of aspartame – much more than consumers typically take in during a day – showed no adverse impact on the health and well being of people in the study.

Experts agree that a small group of people with a rare hereditary condition called phenylketonuria (PKU) should restrict or avoid the ingestion of the amino acid phenylalanine, which is found in aspartame. This recommendation covers all sources of this common amino acid, which includes many foods that have no aspartame. The incidence of PKU is estimated at 1 in 16,000 among Americans. PKU can be detected by a blood test at birth, which is routinely administered to newborn babies in the U.S. It would be exceedingly rare for someone to have this disease and not be aware of it from birth.

Sweet Without the Sugar
When it comes to adding sweetness, just a little aspartame goes a long way A 12-ounce serving of diet Coke has less than one calorie, yet still provides a satisfying sweet taste. That's because aspartame is about 180 times sweeter than sugar. So calorie-conscious consumers can indulge their sweet tooth without disrupting their diet.

Many use aspartame to comply with a doctor's order to limit their carbohydrate intake.

The American Diabetes Association has said that it considers aspartame to be an acceptable sugar substitute and a safe part of a diabetic meal plan.

Metabolic Action
The name "aspartame" might sound a little exotic, but the main ingredients are two common dietary components known as amino acids. One is phenylalanine, mentioned above, and the other is aspartic acid. Amino acids are the building blocks of proteins and therefore play an essential role in nutrition for people of all ages. The two amino acids found in aspartame occur naturally in a number of meats, grains and dairy products. For example, eight ounces of milk will contain over 400 mg of phenylalanine, and 3 ounces of chicken will have more than 1,000 mg. In comparison, eight ounces of diet Coke will contain only 62 mg.

In recent years unfounded rumors have been spawned and spread, mainly through anonymous Internet messages, that wrongly associate aspartame with various health conditions.

If methanol is mentioned as a culprit, note that in large doses it is toxic however, the small amount present in aspartame and a number of other foods, such as tomatoes and oranges, is easily metabolized by the body without any problems. Many of the foods we safely eat all the time contain small amounts of naturally occurring substances, like methanol, that in much larger amounts would not be safe.

The real danger is in the rumors themselves. They can cause consumers needlessly to forego the health benefits and enjoyment of foods and beverages that meet their requirements for reduced sugar and calorie consumption. They also cause needless worry and confusion, and provide incorrect health information to many in the greatest need of accurate information.

Numerous health organizations have published statements supporting the safety of aspartame. Information about aspartame safety can be found on the websites of many of these organizations.

Here are just a few of those organizations:

American Heart Association

European Food Information Council

International Food Information Council

Mayo Clinic

United States Food and Drug Administration (FDA)

Next
The Diabetics Pantry

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Baking with Sugar Substitutes | Fitness and Freebies

Baking with Sugar Substitutes

Nutrition guidelines do not see sugar as unsafe for diabetics any longer however, it is counted as part of your allotment of carbohydrates. Many foods with sugar frequently are high in fat content. Those are foods you probably should use only on special occasions. Artificial sweeteners are "free foods" and therefore do not raise blood glucose levels. You can can add them to a meal plan or in your baking. Now, you can use moderate amounts of sweeteners to make many special things people with diabetes miss eating in their new diet regime.

Saccharin:
Saccharin is 200 to 700 times sweeter than table sugar. You can use saccharin to sweeten hot or cold foods. Pregnant women are cautioned not to use it. Saccharin is purchased under the brand names Sucaryl, Sugar Twin, Sweet Magic, Sweet 'n Low, and Zero-Cal.

Aspartame:
Aspartame is 160 to 220 times sweeter than table sugar. It is not appropriate for recipes that are cooked more than 20 minutes because the chemical compound will break down. Therefore, to use it, you can add it at the end of cooking recipes such as puddings. People with a rare condition called phenylketonuria (PKU) should avoid aspartame. Otherwise, it is a safe sweetener. The brand names are Equal, Sweetmate, and Spoonfuls.

Acesulfame Potassium:
This sweetener, also known as acesulfame-K, came on the market in 1988. You can use this sweetener in baking and cooking as it will not break down when heated. Acesulfame potassium is two hundred times sweeter than table sugar. When used with sugar in baking it creates a very palatable texture. The tabletop sweetener is called Sweet One.

Sucralose:
This product is made from sucrose and was approved in 1998. Sucralose is 600 times sweeter than table sugar. It can be used in recipes that require prolonged heating without loosing any sweetness. It has no reported side effects or restrictions on its use by pregnant women. You can purchase sucralose under the brand name Splenda.

Next
Cooking With Less Fat and Cholesterol

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Banana Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Banana Bread

Ingredients:
3/4 cup measurable sweetener
1/4 cup sugar
1/4 cup olive oil
1 egg
2 egg whites
1 teaspoon baking soda
2 cups flour
4 tablespoons milk
3/4 teaspoon vinegar
3 ripe bananas, mashed

Directions:
Preheat oven to 350-degrees. Spray 9 x 5-inch loaf pan with non- stick cooking spray. Blend sugar twin, sugar, and olive oil. Add egg whites and mix well. Sift flour and baking soda into bowl and stir. Mix milk and vinegar together, then add to mixture. Fold in bananas. Bake one hour or until toothpick inserted in center comes out clean. Let cool.

Recipe makes one loaf; 20 servings.

Nutritional information per serving:
Calories: 108
Fat: 3.6g
Fiber: 2g
Carbohydrate: 17g
Cholesterol: 14mg
Sodium: 63mg
Exchanges: 1 Bread, 1 Fruit, 1 Fat

Next
Almond-Apricot Bread

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Basil Chicken Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Basil Chicken Soup

Ingredients:
1 tablespoon butter or margarine
1 large onion, chopped
1 clove garlic, pressed or minced
1 tablespoon all-purpose flour
3-1/2 cups chicken broth (low-sodium)
1 large russet potato, peeled and cut into 1/2-inch cubes
1 cup diced cooked chicken
1/2 cup chopped fresh basil
1/2 cup shredded light jarlsberg cheese

Directions:
In a two to three-quart pan, combine butter, onion, and garlic. Stir occasionally over medium heat until onion is limp and slightly tinged with brown, about ten minutes. Stir in flour to coat onion. Gradually stir in broth, and bring to a boil on high heat.

Add potato; cover and simmer over low heat until potato is tender when pierced, 15 to 20 minutes. Add chicken; cover and simmer just until chicken is hot, one to two minutes. Stir in basil. Ladle into bowl and offer cheese to add to taste.

Recipe makes four servings.

Nutrition information per serving:
Calories: 237
Fat: 5.1g
Sodium: 168mg
Carbohydrate: 19g
Protein: 19g
Exchanges: 1 Starch, 2-1/2 Low-Fat Meat

Next
Green Split Pea and Barley Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Bavarian Cream Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Bavarian Cream Pie

Ingredients:
9-inch pie crust brushed with egg whites, baked and cooled

Meringue ingredients:
Two egg whites
1/4 teaspoon cream of tartar
Six packets sweetener
1/2 teaspoon vanilla

Pudding ingredients:
2-3/4 cups 1% milk
2 teaspoons vanilla
One large package (6 serving size) vanilla sugar-free instant pudding

Optional topping ingredients:
3 tablespoons whipping cream
1/2 packet sweetener
1/4 teaspoon vanilla

Meringue:
Beat egg whites until frothy. Then beat in cream of tartar until peaks form and curl over. Without over beating, blend in each packet of sweetener separately. Finally, beat in vanilla. Set meringue aside, and immediately prepare the pudding in a separate bowl.

Pudding layer:
Thoroughly beat together milk and pudding mix for one to two minutes. Gently pour the pudding over the raspberry layer, and refrigerate. Allow two hours to gel.

Topping (optional):
This dessert is plenty rich tasting as is; nevertheless, you may wish to make a little whipping cream. If so, for best results, wait until just before serving the pie to prepare the topping. Beat the whipping cream until it begins to hold its form. Then add sweetener packet and vanilla, and beat until stiff. Top each slice with a small dollop for decoration.
Or, go the easier route and use "lite" or fat free whipped topping, instead.

Recipe makes eight servings.

Next
Chocolate Raspberry Cream Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Blueberry Cornmeal Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blueberry Cornmeal Muffins

Ingredients:
1-1/2 cups apple juice concentrate, thawed
1/2 cup prune puree (recipe follows)
1/2 cup buttermilk
Three eggs
2-1/2 cups all-purpose flour
1-1/2 teaspoon baking soda
1/2 teaspoons salt
1/2 teaspoons cornmeal
2 teaspoons grated lemon peel
2 cups frozen blueberries, unthawed (divided)

Directions:
Heat oven to 375-degrees. Coat 18, 2-3/4-inch muffin tin cups with vegetable cooking spray. In mixer bowl, combine concentrate, puree, buttermilk and eggs, beat thoroughly.

Sift together flour, soda and salt; add to wet ingredients with cornmeal and lemon peel; mix just until blended. Gently stir in 1-1/2 cups of the blueberries. Spoon batter into prepared muffin tin cups, dividing equally. Top each muffin with a few of the remaining blueberries. Bake about 20 minutes or until pick inserted into centers comes out clean.

Cool on rack.

Recipe makes 18 muffins.

Prune Puree

Ingredients:
2-2/3 cups (1 pound) pitted prunes
3/4 cup hot water

Directions:
Combine prunes and water in container of food processor. Process about one minute until pureed. Puree may be covered and refrigerated up to two months.

Nutritional information per muffin:
Calories: 150
Protein: 4g
Fat: 1.5g
Fiber: 2g
Carbohydrate: 30g
Cholesterol: 40mg
Sodium: 150mg

Next
Graham Muffins

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Broccoli with Black Olives | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Broccoli with Black Olives

Enhance your meal with this broccoli side dish that is rich in vitamins A and C.

Ingredients:
1 tablespoon olive oil
Two cloves garlic , minced
One package (16 ounces) frozen broccoli flowerets , thawed, drained
One can (2-1/2 ounces) sliced pitted ripe olives , drained
1/4 cup fat free Parmesan cheese

Directions:
Heat oil in large nonstick skillet on medium-high heat. Add garlic; cook and stir 30 seconds or until tender.

Add broccoli and olives; cook and stir four minutes or until thoroughly heated. Remove from heat. Stir in grated topping. Serve immediately.

Recipe makes six servings.

Nutrition information per serving:
Calories: 80g
Total Fat: 4.5
Saturated Fat: 1.5g
Cholesterol: 4.6mg
Sodium: 240mg
Carbohydrate: 8g
Fiber: 2g
Protein: 4g
Exchanges: 1 Vegetable, 1 Fat

Next
Cheesy Baked Eggplant

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Easy BBQ Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Easy BBQ Sauce

Ingredients:
1/4 cup Splenda granular
1/2 cup minced onion
2 tablespoons cider vinegar
2 tablespoons tomato paste
1/2 cup minced green pepper
1/8 teaspoon black pepper
One can, 8-ounces, tomato sauce

Directions:
Use medium saucepan sprayed with nonstick cooking spray. Saute onion and green pepper for five minutes. Stir in tomato sauce with vinegar, Splenda Granular and pepper. Bring to a boil. Then lower heat and simmer for ten minutes.

Recipe makes four, 1/4-cup servings.

Nutrition information per serving:
Calories: 28
Fat: 0g
Protein: 1g
Carbohydrates: 7g
Cholesterol: 0mg
Sodium: 190mg
Fiber: 1g

Next
Broccoli and Bean Dip

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Mexican Bean Dip | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Mexican Bean Dip

Ingredients:
1 can of (15 ounces) red kidney beans, rinsed and drained
1 medium avocado, chopped
2 tablespoons lemon juice
2 tablespoons tomato juice
1 red chili, finely chopped (optional)
1-1/2 packets sweetener or 1 tablespoon measurable sweetener
1 green onion, sliced
1/4 cup parsley, chopped

Directions:
Process kidney beans, avocado, lemon juice, tomato paste, chili, garlic and sweetener in food processor or blender until well blended. Stir in green onion and three tablespoons parsley. Sprinkle with remaining parsley.

Nutritional information per serving:
Calories: 56
Fat: 2g
Cholesterol: 0mg
Sodium: 3mg
Carbohydrate: 9g
Protein: 3g
Diabetic Exchanges: 1-1/2 Vegetable, 1/2 Bread

divider

Salsa for the Mexican Bean Dip

Ingredients:
One pound tomatoes, peeled, seeded, chopped
2 cups coarsely chopped red or yellow onions
1 large green pepper, coarsely chopped
3 cloves of garlic, minced
1 teaspoon finely chopped jalapeno pepper
2 tablespoons red wine vinegar
1/4 teaspoon chili powder
1/2 teaspoon salt
1-3/4 teaspoons Equal for Recipes or six packets sweetener or 1/4 cup measurable sweetener
5 cups sliced cored peeled Granny Smith or other baking apples (about five)

Directions:
Heat all ingredients, except sweetener, to boiling in large saucepan; reduce heat to low and simmer uncovered, until mixture is a thick sauce consistency, about 20 minutes. Cool; stir in sweetener.

Nutritional information per serving:
Calories: 19
Fat: 11g
Carbohydrate: 4g
Sodium: 79mg
Protein: 0g
Cholesterol: 0mg
Diabetic Exchanges: Free Food

Next
Chunky Applesauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Beef Vegetable Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Beef Vegetable Soup

Ingredients:
One beef shank bone with 1 pound meat
2-1/2 quarts water
Two bay leaves
1/3 cup chopped celery leaves
1/4 cup chopped fresh parsley
1 teaspoon "Lite" salt
1/2 teaspoon freshly ground pepper
One envelope (1 ounce) onion soup mix
One can (15 ounces) stewed tomatoes with juice
One package (10 ounces) frozen mixed vegetables
1 cup peeled, diced potatoes
1 cup sliced celery

Directions:
Remove any fat from the beef.

In a large, covered soup pot, simmer the beef bone with meat in water with bay leaves, celery leaves, parsley, salt, pepper, and onion soup mix until meat is tender, about 2-12 hours.

Remove the bone, meat and bay leaves. Chill broth and remove any fat. Cut meat into bite size pieves and return to broth. Discard bone and bay leaves. Add tomatoes, frozen vegetables, potatoes, and celery.

Cover and simmer for 25 minutes. Serve hot.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 106
Fat: 2.5g
Cholesterol: 28mg
Sodium: 306mg
Protein: 12g
Carbohydrates: 8.6
Exchanges: 1 lean meat; 1/2 bread; 1 vegetable

Next
Basil Chicken Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Cool 'n Creamy Beet Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cool 'n Creamy Beet Soup

Ingredients:
2 cups thinly-sliced green cabbage
1/2 cup thinly sliced celery
1/2 cup thinly sliced carrots
One medium onion, coarsely chopped (about 1 cup)
4 cups non-fat, reduced-sodium beef or chicken broth, divided
Two cans (15 ounce each) chopped or sliced beets
2 tablespoons tomato paste
2 teaspoons red wine vinegar
2 cups reduced- or non-fat sour cream
Salt and freshly ground black pepper, to taste
1-2 teaspoons fresh lemon juice, or to taste
4 tablespoons finely-minced fresh chives, for garnish

Directions:
Put cabbage, celery, carrots and onion in a large pot. Pour in 1/2-cup broth, bring to a simmer and cook gently until vegetables soften, about five minutes.

Stir in beets and their liquid, 1-3/4-cup broth and tomato paste. Cover and simmer ten minutes. Stir in vinegar.

Remove 1-cup of the beets and set aside to cool. Add remaining broth to soup and pureй in blender or food processor until smooth.

Gradually add sour cream and blend until smooth. Add salt, pepper and lemon juice to taste. Dice cooled beets and stir into soup.

Chill soup, covered, until just barely cold. (If too cold, its subtle taste won't be appreciated.) Serve soup with chives sprinkled on top for garnish. (Soup may be stored refrigerated up to four days but should be left standing to take off chill before serving.)

Recipe makes eight servings.

Source: AICR

Nutrition information per serving:
Calories: 97
Fat: <1g
Sodium: 591mg
Carbohydrate: 18g
Protein: 5g
Exchanges: 4 Vegetable

Next
Chilled Tomato Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Beverages | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Ade Beverages

Button Coffee Latte
Button Berry Apricot Frappe
Button Lemonade
Button Blushing Hot Spiced Cider
Button Buttermilk Nectarine Blush
Button Cranberry Lime Margarita Punch
Button Hot Merry Cherry Punch
Button Root Beer Float
Button Mulled Rosy Cider
Button Fitness Shake
Button Fresh Limeade
Button Iced Orange Cappuccino
Button Orange Banana Nog
Button Raspberry Sangria
Button Russian-Style Tea
Button Spicy Berry Cider
Button Tangy Cherry Milkshake
Button Fruit Smoothie (Two Variations)
Button Instant Cocoa Mix
Button Holiday Eggnog (Two Variations)

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

Fat Busters! | Low Cost Supplements

Back
Table of Contents

To Your Health!
Fitness and Freebies


Glazed Blackberry Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Glazed Blackberry Pie

Ingredients:
Your favorite 8-9-inch pie crust brushed with egg whites, baked and cooled

Filling Ingredients:
1/2 cup water
1/3 cup cornstarch (or 2-1/2 tablespoons tapioca flour)
3/4 to 1-cup fruit-sweetened blackberry jam or syrup
Dash "lite" salt
1/2 teaspoon cinnamon
4 cups fresh, rinsed and drained blackberries

Directions:
Stir water and cornstarch until smooth. In a saucepan, mix together syrup, cornstarch mixture, salt, and cinnamon. Heat on medium high, stirring constantly. Bring to a boil for about one minute, until congealed, smooth, and slightly darker.

Fold in blackberries, and then spread evenly to fill the crust. Serve chilled or at room temperature.

Next
Bavarian Cream Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Blood Sugar | Fitness and Freebies

Blood Sugar

Each of the various nutrients affects your blood sugar in different ways. Carbohydrates raise the level of blood sugar more rapidly than protein or fat.

A diabetic need not completely avoid sugar as was once believed. It would be nearly impossible to avoid sugar, for one thing.

Sucrose is the leading food additive used in the United States. What you can - and should - do is be careful about the simple sugars you ingest. Use common sense and listen to your body. It will let you know if you overdo!

The effect of carbohydrates on your blood sugar depends on the total amount of complex and simple carbohydrates in your diet. However, the effect varies from person to person so it is a good idea to consult with your doctor about balancing the simple and complex carbohydrates in your diet.

Next
High Sugar Foods

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Blueberry Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blueberry Pie

Ingredients:
Pastry for double-crust 9-inch pie
6 cups fresh blueberries or two packages (16 ounces each) frozen unsweetened blueberries
3 tablespoons lemon juice
6 tablespoons cornstarch
1 cup plus 2-tablespoons measurable sweetener or 27 packets

Directions:
Toss blueberries and lemon juice in large bowl. Sprinkle with combined cornstarch and sweetener and toss to coat. Let stand 30 minutes.

Roll half of pastry on lightly floured surface into circle 1-inch larger than inverted 9-inch pie pan. Ease pastry into pan; trim within 1-inch of edge of pan. Roll remaining pastry to 1/8-inch thickness; cut into 10 to 12 strips, Ѕ-inch wide.

Pour blueberry mixture into pastry. Arrange pastry strips over filling and weave into lattice design. Trim ends of lattice strips; fold edge of lower crust over ends of lattice strips. Seal and flute edge.

Bake in preheated 425-degree oven until pastry is browned and filling is bubbly, about one hour. Cover edge of crust with aluminum foil if browning too quickly. Cool on wire rack; refrigerate leftovers.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 257
Total Fat: 10g
Carbohydrates: 42g
Cholesterol: 10mg
Protein: 3g
Sodium: 128mg
Fiber: <1g
Exchanges: 1 fruit, 1-1/2 bread, 2 fat

Next
Blueberry Yogurt Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Blueberry Yogurt Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blueberry Yogurt Pie

Ingredients:
Your favorite 8-9" pie crust, baked and cooled
1-1/3 cups fruit-sweetened blueberry yogurt (two, 6-ounce cartons)
2 tablespoons fruit-sweetened blueberry syrup or jam
1-3 packets sweetener, optional
1/4 cup "lite" whipping cream
2 cups fresh, rinsed and drained blueberries

Directions:
Blend blueberry syrup and sweetener (if using) into yogurt. Beat the whipping cream until stiff. Fold whipped cream into mixture, then blueberries. Spoon yogurt filling into pie crust. Place in freezer for two hours, and then keep chilled in refrigerator for 30 to 60 minutes before serving.

Next
Blueberry Lemon Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Blueberry Lemon Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blueberry Lemon Pie

Ingredients:
Your favorite 8-9" pie crust, baked and cooled

Lemon custard layer:
Two eggs
1/4 cup evaporated skimmed milk
1/2 cup (about 12) pitted dates
1 teaspoon lemon extract

Blueberry layer:
3/4 cup fruit-sweet blueberry syrup or jam
1/4 cup cornstarch
Dash "lite" salt
1/2 cup water
3 cups fresh, rinsed and drained blueberries

Lemon custard layer:
In food processor or blender, beat together dates and one egg, adding the second egg separately. Purйe for several minutes, until smooth. Stir in evaporated milk and lemon extract by hand; then beat an additional minute or two until smooth.

Spray 9" pie pan with non-stick cooking spray. Pour egg mixture into the pan. Bake at 350 degrees for 8-12 minutes, just until congealed. Remove lemon custard from the oven, and slide it onto the baked pie crust, so the entire crust is evenly covered.

Blueberry layer:
Stir water and cornstarch until smooth. In a saucepan, mix together syrup, cornstarch mixture, and salt. Heat on medium high, stirring constantly. Bring to a boil for about one minute, until congealed and smooth; it will also darken. Fold in blueberries, and then spoon over custard, and spread evenly to fill the crust. Serve chilled or at room temperature.

Next
Equal® Lemon Meringue Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Blushing Hot Spiced Cider | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Blushing Hot Spiced Cider

Ingredients:
1 quart apple cider
Six whole cloves
Six, allspice berries
1 cup low calorie cranberry juice cocktail
Three sticks of cinnamon
3 tablespoons measurable sweetener
Six orange slices, at room temperature

Directions:
In a large saucepan, combine all ingredients except the orange slices. Heat to a simmer; reduce heat and simmer 20 more minutes. Cool one hour. Remove spices. Place orange slices in serving cups. Strain cider into cups. Serve hot.

Recipe makes six to eight servings.

Nutritional information per serving:
Calories: 65
Fat: trace
Cholesterol: 0mg
Sodium: 5mg
Carbohydrate: 16g
Protein: trace
Diabetic Exchanges: 1 Fruit

Next
Buttermilk Nectarine Blush

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Buttermilk Nectarine Blush | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Buttermilk Nectarine Blush

Ingredients:
1 quart low-fat buttermilk
Four large nectarines, chilled, peeled & cut into pieces
1/4 cup brown sugar
Fresh strawberries for garnish

Directions:
Combine all ingredients in blender container, blending until the nectarines are purйed. Serve in chilled glasses, garnished with diced, fresh strawberries.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 108
Fat: 1g
Carbohydrate: 20g
Cholesterol: 4mg
Sodium: 5mg
Exchanges: 1 Fruit, 1/2 Milk

Next
Cranberry Lime Margarita Punch

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Marvelous Bran Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Marvelous Bran Muffins

Ingredients:
2 cups raisin bran cereal
1 cup skim milk
3 tablespoons vegetable oil
One egg
1-ј cups all-purpose flour
ј cup brown sugar
2-Ѕ teaspoons baking powder
1 teaspoon cinnamon
ј teaspoon salt

Directions:
Preheat oven to 425-degrees. Prepare muffin tins with non-stick spray. Mix cereals, milk, oil, and egg in large mixing bowl. Allow standing for at least five minutes. Combine remaining dry ingredients and add to cereal mixture. Stir until all ingredients are moistened. Fill muffin cups about 2/3 full. Bake for 15 to 20 minutes.

Recipe makes 12 muffins.

Serving Size: One muffin

Nutrition information per serving:
Calories: 135
Fat: 4g
Carbohydrate: 22g
Protein: 3g
Exchanges: 1 Starch/Bread, 1 Fat

Next
Cran-Orange Oat Muffins

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Branapple Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Branapple Muffins

Ingredients:
2 cups peeled, diced apples (two medium)
3/4 cup apple juice concentrate
1-1/2 tablespoons vanilla
3/4 cup unbleached white flour
2 teaspoons baking soda
3/8 teaspoon lite (or regular) salt
1-1/2 teaspoons cinnamon
1/4 teaspoon nutmeg
1 cup wheat bran
2-1/2 tablespoons olive oil
1/3-cup egg substitute
1/3 cup currants plumped (or raisins, if currants unavailable)

Directions:
Preheat oven to 350-degrees.

Combine apple juice concentrate and vanilla. Soak chopped apples in this mixture 15 minutes to overnight.

Preheat oven to 350-degrees. Meanwhile, mix together dry ingredients: flour, soda, salt, cinnamon, nutmeg, and bran.

Add oil, lightly beaten egg whites, and plumped currants to the apple mixture, and gently stir. Pour this over the dry ingredients, and mix with a fork, just until moistened.

Fill muffin cups 3/4 full, and bake at 350 degrees for 13 to 18 minutes.

Muffins are done when they spring back to the touch or a toothpick inserted comes out clean.

Let cool 10-15 minutes.

Note: If you cannot use sugar at all, you can subsitute honey, applesauce, or natural fruit.

Recipe makes 12 muffins.

Next
Blueberry Cornmeal Muffins

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Breads, Muffins and Rolls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Breads, Muffins and Rolls

Button Orange Juice Muffins
Button Marvelous Bran Muffins
Button Cran-Orange Oat Muffins
Button Pear Spice Muffins
Button Branapple Muffins
Button Blueberry Cornmeal Muffins
Button Graham Muffins
Button Banana Bread
Button Almond-Apricot Bread
Button Orange Chocolate Chip Bread
Button Succulent Zucchini Bread
Button Country-Style Semolina Loaf
Button Yummy Apple Biscuits
Button Easy Sticky Buns
Button Up and Down Biscuits
Button Black Pepper Ring Biscuits
Button Cinnamon Bread Pudding
Button Chocolate Bread Pudding

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

Fat Busters! | Low Cost Supplements

back
Main Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Break Down of the Meal Plan | Fitness and Freebies

Break Down of the Meal Plan

The meal plan in itself should be customized to meet your specific needs. Let's break down some of the things your dietitian will most likely use to devise your dietary plan.

Calories
A calorie is a way of measuring the amount of energy supplied by the food you eat. This is pretty basic, yes, but very important to you meal plan. Your dietitian will indicate the approximate number of calories your body needs each day to balance the calories you burn. Your height, weight, age, sex and level of activity determine the amount. If you and your dietitian determine you need to lose weight, the amount of calories will be reduced in order to help you burn more calories than you consume.

Carbohydrates, Protein and Fat
These are the nutrients your body uses to produce energy, build and repair body tissue and regulate body functions. Your dietitian will write the number of grams of these nutrients you need to include in your daily diet. The number of calories you need determines this. Carbohydrate and protein provide four calories per gram; fat provides nine calories per gram.

Food Groups
As many of us are already aware, there are six basic food groups into which all foods are divided. Your dietitian will provide the means for you to get sufficient amounts of each. To refresh your memory, or if you are not familiar with them, they are:

1. Milk
2. Vegetable
3. Fruit
4. Bread/Starch
5. Meat
6. Fat

Next
Using an Exchange Meal Plan

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Broccoli and Bean Dip | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Broccoli and Bean Dip

Ingredients:
Four garlic cloves, unpeeled
3 teaspoons extra virgin olive oil, divided
1/8 teaspoon dried crushed red pepper flakes or a few drops hot pepper sauce
2-1/2 cups broccoli florets
1 cup canned low-sodium cannellini beans, rinsed and drained
1 tablespoon fresh lemon juice
1 tablespoon green onion, minced
1/8 teaspoon salt
1/4 teaspoon black pepper

Directions:
Preheat oven to 350-degrees. Combine garlic, 1-teaspoon oil and crushed red pepper in small foil packet, sealing well. Bake until garlic is tender, about 35 minutes. Cool slightly; squeeze garlic out of skins.

Meanwhile, steam broccoli florets in microwave until very tender, about two minutes. Rinse with cold water to stop cooking; drain. Transfer to blender or food processor.

Add beans, lemon juice, green onion, garlic mixture and remaining oil. Puree until smooth. Season with salt, pepper and additional red pepper flakes or hot sauce, if needed or desired.

Recipe makes about 1-1/2 cup.

Nutrition information per 1/4-cup serving:
Calories: 56
Fat: 2g
Saturated Fat: <1g
Calories from fat: 36%
Protein: 3g
Carbohydrates: 7g
Cholesterol: 0mg
Sodium: 96mg
Fiber: 2g
Dietary Exchanges: 1/2 Starch, 1/2 Fat

Next
Herb and Mustard Dressing

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Broiled Steak Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Broiled Steak Salad

Ingredients:
4 ounces lean steak
2 tablespoons olive oil
1 tablespoon white vinegar
1 tablespoon chopped onion
One clove garlic, minced

Directions:
Grill or broil steak to desired doneness. Cool and cut into 1/4 – inch strips. Combine remaining ingredients thoroughly in a bowl, then add steak and mix. Correct the seasoning.

Additional vegetables (up to 2/3-cup) or salad greens (up to 1-cup) may be chopped and added to taste.

Next
Spicy Chicken Rice Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Caesar Dressing | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Caesar Dressing

Ingredients:
1/2 cup non-fat yogurt
1/4 cup fat-free or low-fat mayonnaise
One clove garlic, crushed
1/4 cup grated Parmesan cheese
1/2 teaspoon Worcestershire sauce
2 tablespoons lemon juice (to taste)
3/4 teaspoon salt (to taste)
Freshly ground pepper, to taste

Directions:
Combine all ingredients and mix well; chill.

Recipe makes 1-cup. Serving size is about 1-tablespoon.

Nutrition information per serving:
Calories: 15
Protein: 1g
Fat: 0.6g
Carbohydrates: 2g
Cholesterol: 0mg
Dietary Exchanges: 1/4 Low-fat Milk

Next
Basic Turkey Gravy

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Cakes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cake Cakes

Button Chocolate Cake

Button Chocolate Zucchini Cake

Button Raisin Cake

Button Applesauce Cake

Button Jewish Apple Cake

Button German Apple Cake

Button Peach Almond Upside Down Cake

Button Easy Carrot Cake

Button Carrot Cake

Button Lemon Chiffon Cake

Button Lemon Pound Cake with Strawberries

Button Strawberry Short Cut Cake

Button Angel Food Cake with Blueberry Yogurt Sauce

Button Hearty Corn Cakes

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Sunny Citrus Cubes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Sunny Citrus Cubes

Ingredients:
4 tablespoons unflavored gelatine
3/4 cup unsweetened grapefruit juice
2 cups unsweetened orange juice, boiling
1 teaspoon orange extract
2 tablespoons sugar
1/4 cup walnuts, chopped (optional)

Directions:
Soften gelatine in grapefruit juice. Add orange juice, orange extract and sugar. Stir until dissolved. Pour into 8-inch square pan. Chill until partially set. Sprinkle with walnuts if you wish.

Yield: 16 pieces, 2-inch x 2-inch

Nutrition information
1 serving without nuts contains 24 Calories, 1/2 fruit and vegetable choice.
1 serving with nuts contains 33 Calories, 1/2 fruit and vegetable choice, 1/2 fats.

Next
Butter Rum Candy

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Butter Rum Candy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Butter Rum Candy

Ingredients:
5 cups unsweetened puffed rice
3 tablespoons granulated frutose
Two egg whites
2 teaspoons butter rum flavoring
1 teaspoon vanilla extract

Directions:
Pour rice in blender and work to a powder. pour into a large bowl or food processor. Add remaining ingredients. work with a wooden spoon or steel blade until mixture is completely blended. (Mixture will be sticky.)

From into 20 patties. Place patties on an ungreased cookie sheet. Bake at 300-degrees for 20 minutes or until surface of patties feel dry.

Recipe makes about 20 candies.

Nutrition information per candy:
Calories: 2
Fat: 0g
Carbohydrates: 3g
Protein: 0
Cholesterol: 0mg
Sodium: 5mg
Exchange: 1/5 Bread

Next
Fruit Candy Bars

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Fruit Candy Bars | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fruit Candy Bars

Ingredients:
One envelope unflavored gelatin
1/4 cup water
1 cup dried apricots
1 cup raisins
1 cup pecans
1 tablespoon flour
2 tablespoon orange peel (grated)
1 teaspoon rum extract

Directions:
Sprinkle gelatin over water; allow to soften for five minutes. Heat and stir until gelatin is completely dissolved. Combine apricots, raisins, pecans, flour and orange peel in blender or food processor, working until finely chopped. Add to gelatin mixture. Add rum extract and stir to completely blend.

Line 8-inch square pan with plastic wrap or waxed paper. Spread fruit mixture evenly into pan, and set aside to cool completely until candy is firm. Turn out onto cutting board, cut into 24 bars and wrap individually.

Recipe makes about 24 bars.

Nutrition information per bar:
Calories: 68
Exchange: 1 Fruit, 1/2 Fat

Next
Peanut Candy

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Peanut Candy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Candy

Ingredients:
1 pound whitecote chocolate coating
1/2 cup peanut butter

Directions:
In the top of a double boiler, melt coating over hot, not boiling, water. Add peanut butter. and blend until smooth. Fill peanut molds almost full and chill in freezer until firm. Turn over and tap peanuts from molds.

Recipe makes about 75 peanuts.

Next
Peanut Clusters

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Peanut Clusters | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Clusters

Ingredients:
1/3 cup of peanut butter
1 tablespoon of honey
1/4 cup of dry roasted peanuts
1/2 cup of raisins
1 tablespoon of cocoa powder
1 package of artificial sweetener
1/4 cup of Grape Nuts cereal

Directions:
Melt peanut butter and honey.

Remove from heat and stir in remaining ingredients except cereal.

Roll rounded teaspoon of mixture into cereal to form balls. Chill and serve.

Recipe makes about 12 clusters.

Nutrition information:
Calories: 90
Exchange: 1 Fruit, 1 Fat

Next
Peanut Butter Fudge Crunchies

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Peanut Butter Fudge Crunchies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Fudge Crunchies

Ingredients:
1/4 cup honey
2 teaspoons sugar free fudge sauce
1/4 cup peanut butter
2-1/2 cups Cheerios
1/2 cup raisins
1/2 cup pretzels

Directions:
Boil and stir the honey and fudge sauce. Remove from heat and stir in peanut butter. Pour slowly over cereal, raisins and pretzels. Toss until evenly coated. Spread in 13 x 9 x 2-inch pan.

Recipe makes ten servings.

Next
Peanut Butter Crunchies

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Peanut Butter Crunchies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Crunchies

Ingredients:
3/4 cup chunky peanut butter
2 tablespoons honey
3/4 cup corn flake crumbs

Directions:
Blend peanut butter and honey.

Stir in 1/2-cup corn flake crumbs.

Form into 24 small balls and roll in remaining corn flake crumbs. Chill.

Next
Peanut Butter Candy

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Peanut Butter Candy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Candy

Ingredients:
2 tablespoon of peanut butter
2 tablespoon of milk
2 tablespoon of raisins
1 medium size graham cracker
1/2 teaspoon of liquid artificial sweetener
1 teaspoon of vanilla

Directions:
Cream peanut butter until smooth.

Blend in 1-tablespoon milk. Add raisins and mix well.

Break graham cracker into small pieces and mix with other ingredients. Add rest of milk, sweetener, and vanilla. Form into balls.

Exchange: 1 Meat Substitute; 1 Fruit; 1/2 Bread
Subtract milk from daily allowance.

Next
Fudge I

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Fudge I | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fudge I

Ingredients:
One, 14-1/2 oz. evaporated milk
3 tablespoons cocoa
1/4 cup butter or margarine
Liquid sweetener to equal 1/2-cup of sugar
1/4 teaspoon salt
1 teaspoon vanilla
2-1/2 cup graham cracker crumbs
1/4 cup nuts

Directions:
Combine milk and cocoa in saucepan. Beat well. Add oleo, sweetener, salt. Bring to boil. Remove from heat. Stir in remaining ingredients except 1/4-cup graham crackers.

Cool about 15 minutes. Divide mixture into 32 balls. Roll in remaining cracker crumbs and chill.

Recipe makes approximately 32 candies.

Next
Fudge II

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Fudge II | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fudge II

Ingredients:
One envelope gelatin
1/4 cup water
One square unsweetened chocolate
1/8 teaspoon cinnamon
3/4 teaspoon liquid food sweetener
1/4 cup water
1/2 cup evaporated milk
1/2 teaspoon vanilla
1/4 cup chopped nuts

Directions:
Soften gelatin in 1/4-cup water for five minutes. Melt chocolate with cinnamon and sweetener; add milk and water slowly. Add gelatin. Stir until dissolved. Remove from fire.

Add vanilla, cool. When mixture begins to thicken, add nuts. Turn into cold pan. When firm cut into pieces.

Recipe yields eight servings.

Next
Chocolate Dipped Creams

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Chocolate Dipped Creams | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Dipped Creams

Ingredients:
1/3 cup margarine; softened
3 tablespoons evaporated skim milk
Dash salt
1 ts vanilla extract
1/4 cup cocoa
1 cup powdered sugar replacement
Semisweet chocolate, melted for dipping

Directions:
Cream together margarine, milk, salt and vanilla until fluffy. Stir in cocoa and sugar replacement. Knead or work with hands until dough is smooth, and from dough into 60 small balls. Dip balls in chocolate, cool completely, dip again and cool.

Nutrition information:
Calories per candy: 50
Exchange (1 ball): 1/3 Bread, 1/2 Fat

Next
Double Fudge Balls

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Double Fudge Balls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Double Fudge Balls

Ingredients:
1/3 cup margarine; softened
3 tablespoons evaporated skim milk
Dash salt
1 teaspoon vanilla extract
1/4 cup cocoa
1 cup powdered sugar replacement
Semisweet chocolate, melted for dipping

Directions:
Cream together margarine, milk, salt and vanilla until fluffy. Stir in cocoa and sugar replacement. Knead or work with hands until dough is smooth, and from dough into 60 small balls. Dip balls in chocolate, cool completely, dip again and cool.

Nutrition information:
Calories per candy: 50
Exchange (1 ball): 1/3 Bread, 1/2 Fat

Next
Chocolate Chews

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Chocolate Chews | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Chews

Ingredients:
6 ounces cream cheese
4 teaspoons cream
2 teaspoons vanilla
5 teaspoons chunky peanut butter
One package sugar-free chocolate pudding
1 teaspoon lemon juice
1/2 cup chopped walnuts

Directions:
With a fork blend the first six ingredients together.

Roll into tiny balls and roll in nuts.

Store in refrigerator or freezer as these are better when cold.

Next
Pecan Fudgies

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Pecan Fudgies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pecan Fudgies

Ingredients:
Four squares of semi-sweet chocolate
1 tablespoon of butter
One egg, well beaten
3 tablespoon of heavy cream
Pinch salt
1/2 teaspoon of vanilla
1 cup of pecans
2 teaspoon of liquid sweetener

Directions:
Melt chocolate and butter over hot water. Stir and cool.

Beat eggs in a bowl; add cream, salt, vanilla, chocolate, sweetener and nuts. Stir well. Press in a buttered pan 1/2-inch deep.

Cut in squares.

Next
Melt-Away Mints

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Melt-Away Mints | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Melt-Away Mints

Ingredients:
1-1/2 pounds finely chopped milkcote chocolate coating
2/3 cup melted vegetable shortening
Three or four drops peppermint oil
Milkcote chocolate

Directions:
In the top of a double boiler, melt milkcote coating over hot, not boiling, water. Add shortening and peppermint, a little at a time, beating well after each addition. Chill chocolate mixture in the refrigerator until of a soft custard consistency. Place in a mixing bowl and beat for 30 seconds. Be careful not to overbeat. Pour into a waxed paper-lined 10 x 13-inch pan. Cover with waxed paper and tap pan to level mixture.

Place in refrigerator until firm but not hard. Cut into squares. Dip in melted and cooled milkcote coating.

Recipe makes about 100 pieces.

Back
Main Contents

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Candy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Candy

Button Sunny Citrus Cubes
Button Butter Rum Candy
Button Fruit Candy Bars
Button Peanut Candy
Button Peanut Clusters
Button Peanut Butter Fudge Crunchies
Button Peanut Butter Crunchies
Button Peanut Butter Candy
Button Fudge I
Button Fudge II
Button Chocolate Dipped Creams
Button Double Fudge Balls
Button Chocolate Chews
Button Pecan Fudgies
Button Melt-Away Mints

Button Powdered Sugar Replacement

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

Fat Busters! | Low Cost Supplements

back
Main Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Iced Orange Cappuccino | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

A coffee classic gets the cool treatment with the taste of fresh orange and a light whipped cream topping.

Iced Orange Cappuccino

Ingredients:
Zest from one medium orange, cut into 1/2-inch strips
7-1/2 cups cold water
1-1/2 cups drip grind espresso coffee
3 to 4 tablespoons measurable sweetener of choice
3 cups skim milk
Light whipped topping
Cocoa, ground nutmeg or cinnamon

Directions:
Place orange zest in bottom of coffee pot. Brew coffee, using cold water and espresso; cool to room temperature. Strain coffee and discard orange zest; stir in measurable sweetener and milk. Refrigerate until chilled.

Pour cappuccino into chilled tall glasses; spoon small dollop of whipped topping on each and sprinkle with cocoa, nutmeg or cinnamon.

Note: Cappuccino can be frozen in ice cube trays; the cubes can be used with cappuccino so it will not be diluted. Also, the ice cubes can be processed in a blender or food processor to make cappuccino slush.

Recipe makes about eight (8-ounce) servings.

Nutrition information per serving:
Calories: 45
Saturated Fat: trace
Total Fat: <1g
Carbohydrate: 7g
Cholesterol: 2mg
Sodium: 55mg
Protein: 3g
Fiber: trace Exchanges: 1/2 Skim Milk or 1/2 Starch

Next
Orange Banana Nog

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Carbohydrates | Fitness and Freebies

Carbohydrates

Simple carbohydrates are commonly called sugars, of which there are dozens of kinds. What comes to most minds first is table sugar. Others include lactose (found in milk), glucose and fructose (found in fruits and vegetables), and sucrose (also called cane or beet sugar). Sugar, under a variety of names, is found in a wide range of foods. Candy, sugar-sweetened beverages, fruit drinks and sugar-sweetened fruit drinks, milk, fruits and vegetables, sugar-coated cereals, honey, syrup, preserves and desserts of all kinds.

Complex-carbohydrates are just that - complex. They are made up of large numbers of sugar molecules (glucose) joined together in a long chain. You find complex carbohydrates in the starches that eat such as bread, pasta, rice, beans, potatoes, corn, peas, carrots, beets and broccoli. In addition, all types of fiber are complex carbohydrates. Whole grains and fruits and vegetables are good sources of fiber.

The body breaks down these carbohydrates (both simple and complex) into a simple sugar called glucose. Both sugars and starches are broken down or digested into glucose at about the same speed, so it is important to control all the different carbohydrates you eat not just the sugars. The glucose enters the bloodstream, which circulates it to the cells of your body. The cells use this glucose for energy, or store it for future use. The glucose from complex carbohydrates is absorbed into the blood at about the same rate as that from simple carbohydrates. This is why diabetics should watch how much both simple and complex carbohydrate they eat.

Carbohydrate Counting
Carbohydrate counting is now more popular since the American Diabetes Association loosened up the guidelines for people with diabetes. At that time, it was concluded that there was little scientific evidence to support efforts to restrict people with diabetes from eating sugar-containing foods. They noted that ten grams of carbohydrate would have basically the same effect on a person's blood sugar, whether its source is table sugar or potatoes. What is important is how much total carbohydrate you eat - regardless of the source. Your dietitian will determine the total number of grams of carbohydrate you should eat at a given meal or snacks, based on your medication, weight loss goals if any, and exercise patterns. It will be up to you to decide how you wish to fulfill those carbohydrate needs. It would be a good idea to purchase a carbohydrate-counting book, which can be found in many bookstores and even in supermarket checkouts.

Keep in mind, for your own good, you should not substitute sweets for healthier carbohydrates choices. No one should do this - diabetic or not. The same applies to fat. Thanks to these new guidelines, you need not feel deprived. Use them wisely, but allow yourself to enjoy the carbohydrates you choose!

Next
Protein

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Easy Carrot Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Easy Carrot Cake

Ingredients:
Baking spray with flour
1-1/2 cups unbleached all-purpose flour
3/4 cup measurable sugar substitute
1/3 cup plus 1-tablespoon nonfat dry milk powder
1 1/2 teaspoons baking soda
1 1/2 teaspoons baking powder
1 teaspoon ground cinnamon
1/2 teaspoon ground cloves
1/2 teaspoon ground nutmeg
1/2 teaspoon ground allspice
1/8 teaspoon salt (optional)
1/2 cup olive oil
3/4 cup liquid egg substitute
One large egg white
1-1/2 cups finely grated carrots
1/4 cup finely chopped pecans
1/4 cup currants
One, 6-ounce can unsweetened crushed pineapple, drained
Frozen non-fat, sugar-free whipped topping, thawed (optional)

Directions:
Preheat oven 350-degrees. Coat an 10-inch spring form pan with cooking spray. Sift the flour into a large bowl. Add the sugar substitute, dry milk, baking soda, baking powder, spices and salt. Stir to mix well.

Mix in the oil and egg substitute using a low setting on your electric mixer. Fold in the carrots, walnuts, currants and pineapple.

Spread in the prepared pan and bake until a tooth pick inserted into the center of the cake comes out clean, about 30 minutes. Cool in pan, remove the outside of the cake pan and slice.

If using, top with thawed whipped topping.

Recipe makes 16 servings.

Nutrition information per serving:
Calories: 155
Total Fat: 8g
Saturated Fat: 0.6g
Carbohydrate: 20g
Cholesterol: 0mg
Sodium: 204mg
Fiber: 1g
Protein: 4g
Calories from fat: 44%
Exchanges: 1-1/2 carbohydrate (bread/starch), 1-1/2 fat

Next
Carrot Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Carrot Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Carrot Cake

Ingredients:
Six egg whites or one-cup egg substitute
1 cup apple juice concentrate
2/3 cup canola or safflower oil
1/4 cup water
3 cups unbleached white flour
1 tablespoon baking powder
1 teaspoon baking soda
1 teaspoon light salt
2 teaspoons cinnamon
1/4 teaspoon nutmeg
2 cups raisins
2 cups carrots (4-6 medium)
Cream Cheese Frosting (recipe below)

Directions:
Preheat oven to 350-degrees.

Stir together egg, apple juice concentrate, oil, and water. Set aside. Sift together dry ingredients: flour, baking powder, baking soda, light salt, cinnamon, and nutmeg.

Gently stir wet ingredients into dry ingredients just until moistened. Drain raisins, and fold in carrots and raisins.

Pour into cake pans, and bake at 350-degrees for 25 to 30 minutes. Then reduce heat to 325-degrees for 8 to 12 more minutes.

Serve with cream cheese frosting.

Divider

Cream Cheese Frosting

Ingredients:
1-1/2 cups light cream cheese
1-1/2 tablespoons margarine, softened
16 packets sweetener
2 teaspoons vanilla
0-2 tablespoons 1% milk to thin frosting

Directions:
Beat together cream cheese and margarine. Then stir in sweetener, and milk until powder is moistened. Beat until smooth and spread on Carrot Cake or other sweet treat.

Next
Lemon Chiffon Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Cream Cheese Peanut Butter Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cream Cheese Peanut Butter Pie

Ingredients:
1-1/2 cups crushed shredded wheat crackers
1/2 cup chopped pecans
1-1/2 teaspoons heat stable artificial sweetener
3/4 cup butter, softened
1/2 (8 ounce) package light cream cheese, softened
3/4 cup peanut butter
One (8 ounce) container frozen whipped topping, thawed

Directions:
Preheat oven to 350-degrees.

In a medium-size bowl, mix together crushed crackers, pecans, and artificial sweetener. Cut in butter or margarine until mixture is crumbly. Press into a 9-inch pie pan.

Bake in preheated oven for seven minutes. Remove and cool. In a medium-size mixing bowl, combine cream cheese and peanut butter. Beat until fluffy, then fold in whipped topping. Pour mixture into cooled crust. Chill two to three hours before serving.

Recipe makes eight servings.

Next
Peanut Butter "Pie"

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Cheese Balls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cheese Balls

Ingredients:
8 ounces light or fat free cream cheese
1 cup reduced-fat cheddar cheese
1 teaspoon garlic powder
1-1/2 tsp Worcestershire sauce
1/3 cup blue cheese
1/4 cup chopped onion
Crushed Pecans (optional)
Directions:
Mix all ingredients well and form into a ball.

Optional: Roll in crushed pecans.

Refrigerate at least two hours before serving.

Next
Fresh Fruit Slush

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Cheesy Potato Skins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cheesy Potato Skins

Ingredients:
2 tablespoons grated fat-free Parmesan cheese
Three cloves garlic, finely chopped
2 teaspoons dried rosemary
1/2 teaspoon salt
1/4 teaspoon black pepper
Four baked potatoes
Two egg whites, slightly beaten or egg substitute equivalent to one egg
1/2 cup (2 ounces) shredded, reduced fat part-skim mozzarella cheese

Directions:
Preheat oven to 400-degrees. Combine Parmesan cheese and seasonings. Cut potatoes lengthwise in half. Remove pulp, leaving 1/4-inch thick shells. Cut lengthwise into wedges. Place on baking sheet. Brush with egg whites; sprinkle with cheese mixture. Bake 20 minutes. Sprinkle with mozzarella cheese; bake until cheese is melted. Serve with salsa if desired.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 90
Protein: 5g
Total Fat: 8g
Carbohydrate: 14g
Cholesterol: 5mg
Sodium: 215mg
Fiber: 2g
Exchanges: 1 Starch/Bread, 1/2 Lean Meat

Next
Crazy Carrots

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Tangy Cherry Milkshake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Tangy Cherry Milkshake

Ingredients:
3/4 cup (about 12) cherries, rinsed and halved
1/2 cup fruit-sweetened cherry yogurt
1/3 cup 1% milk
1 packet sweetener

Directions:
Fully freeze the cherries. Freeze the yogurt for an hour. Thoroughly purйe all ingredients in a blender or food-processor. Serve immediately.

Recipe makes one serving.

Next
Fruit Smoothie

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Lemon Chiffon Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Lemon Chiffon Cake

Ingredients:
1-1/2 cup cake flour
2-1/2 teaspoons baking powder
Pinch salt
1-1/4 measurable sweetener, preferably Splenda®
ј cup olive oil
Two large egg yolks
6 tablespoons buttermilk
ј cup lemon juice
Finely grated rind of one lemon
1 teaspoon vanilla extract
Six large egg whites, room temperature
2 tablespoons granulated sugar
Ѕ teaspoon cream of tartar
2 teaspoons powdered sugar (optional)

Directions:
Preheat oven to 325-degrees. Sift together cake flour, baking powder and salt in medium bowl. Stir in sweetener; set asked.

In large bowl, combine oil, egg yolks, buttermilk, lemon juice, lemon rind and vanilla; beat with electric mixer until smooth. Incorporate flour mixture on low speed. Beat on medium speed 30 seconds or until smooth.

In separate bowl, with clean beaters, beat egg whites and cream of tartar until foamy. Gradually add sugar and beat whites until they are stiff, but not dry.

Gently stir in ј of the whites to loosen batter; gently fold in remainder of whites. Spoon batter into ungreased 10-inch tube pan; spreading evenly.

Bake 30 minutes or until cake springs back when gently touched. Cool upside down by placing pan on bottle or funnel for 45 minutes. Sift powdered sugar over cake before serving, if desired.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 157
Total Fat: 7g
Saturated Fat: <1g
Carbohydrates: 20g
Cholesterol: 43mg
Protein: 4g
Sodium: 168mg
Fiber: <1g
Exchanges: 1 Starch, 1-1/2 Fat

Next
Lemon Pound Cake with Strawberries

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Beef Vegetable Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chili-Bean Soup

Ingredients:
One beef shank bone with 1lb. meat 2-1/2 quarts water Two bay leaves 1/3 cup chopped celery leaves 1/4 cup chopped fresh parsley 1 teaspoon "lite" salt 1/2 teaspoon freshly ground pepper
One envelope (1 ounce) onion soup mix
One can (15oz.) stewed tomatoes with juice
One package (10 ounces) frozen mixed vegetables
1 cup peeled, diced potatoes
1 cup sliced celery

Directions:
Remove any fat from the beef.

In a large, covered soup pot, simmer the beef bone with meat in water with bay leaves, celery leaves, parsley, salt, pepper, and onion soup mix until meat is tender, about 2-12 hours.

Remove the one, meat and bay leaves. Chill broth and remove any fat. Cut meat into bite size pieves and return to broth. Discard bone and bay leaves. Add tomatoes, frozen vegetables, potatoes, and celery.

Cover and simmer for 25 minutes. Serve hot.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 106
Fat: 2.5g
Sodium: 306mg
Carbohydrate: 9g
Protein: 12.2g
Exchanges: 1 lean meat; 1/2 bread; 1 vegetable

Next
Basil Chicken Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Chilled Tomato Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chilled Tomato Soup

Ingredients:
3/4 cup finely diced, seeded, unpeeled cucumber
1/2 cup chopped fresh basil
1/4 cup finely chopped red onion
2 tablespoons extra-virgin olive oil
3 pounds tomatoes, chopped
3 tablespoons balsamic vinegar
2 teaspoons salt
1/2 teaspoon black pepper

Directions:
Combine 1/4-cup cucumber, 2-tablespoons basil, 2-tablespoons onion and 2-teaspoons oil in a small bowl.

Working in batches, puree tomatoes, vinegar, salt, pepper and remaining cucumber, basil and onion in a food processor or blender. Serve immediately or refrigerate. Garnish with diced cucumber-onion mixture. Drizzle each serving with 1-teaspoon olive oil (optional).

Recipe makes four servings.

Nutrition information per serving:
Calories: 143
Fat: 8
Carbohydrate: 19g
Protein: 3g
Exchanges: 1-1/4 Starch, 1 Low-Fat Meat, 1 Fat

Next
Back to Main Contents

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Chicken Salad Chinois | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken Salad Chinois

Ingredients:
2 cups chicken, cooked, cut up
1/2 cup zucchini, chopped
1/2 cup radishes, chopped
1/4 cup 2% yogurt
1 tablespoon soy sauce
1/2 teaspoon artificial -sweetener
1/2 teaspoon ginger, ground
3 cups letturce, shredded

Directions:
In a bowl, combine chicken, zucchini, and radishes. In a cup, combine yogart, soy sauce, sweetner and ginger. Pour over chicken mixture to coat evenly.

Refrigerate at least two hours before serving, then toss well gently. Divide into four portions.

Serve immediately or chill before serving. Sprinkle with additional wheat germ before serving, if desired.

Recipe makes four servings (about 5-cups).

Nutrition information per ј salad:
Calories: 131
Total Fat: 7g
Carbohydrate: 2g
Protein: 15g

Next
Dried Fruit Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Chinese Chicken Corn Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chinese Chicken Corn Soup

Ingredients:
3 cups chicken broth
One, 8-1/4 ounce can creamed corn
1-cup chicken, diced, cooked and skinned
1 tablespoon cornstarch
2 tablespoons cold water
Two egg whites
2 tablespoons fresh parsley, finely minced

Directions:
Combine chicken broth, corn, and chicken pieces in a large saucepan.

Bring mixture to a boil over medium heat, stirring occasionally.

Blend cornstarch with cold water and add to soup. Continue cooking, uncovered, for three minutes.

Beat egg whites until foamy; stir into soup. Reduce heat to a simmer and cook until foamy. Ladle soup into individual bowls and garish with parsley. Serve hot.

Recipe makes six servings.

Low-sodium diets: Substitute unsalted broth.

Nutrition information per serving:
Calories: 156
Fat: 4g
Cholesterol: 14g
Sodium: 205mg
Carbohydrate: 30g
Protein: 16g
Exchanges: 2 meat, 1 starch/bread

Next
Hearty Italian-Style Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Chocolate Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Cake

Ingredients:
1 cup bran cereal
1 cup water
1/3 cup dry sugar substitute equivalent
One medium egg
1/4 cup canola oil
1 teaspoon vanilla
1 teaspoon chocolate flavoring
1 tablesoon lemon juice
1 cup all-purpose flour
1 teaspoon soda
1/4 cup cocoa, preferably Dutch-process
1/4 cup sugar
2 tablespoons instant nonfat dry milk
1/2 teaspoon cinnamon
1/2 teaspoon salt

Directions:
Place bran, water, sugar or sugar substitute, egg, canola oil, vanilla, chocolate flavoring and lemon juice in a mixer bowl. Mix lightly and let stand for 30-45 minutes.

Combine flour, soda, cocoa, sugar, dry milk, cinnamon and salt and stir to blend well.

Add flour mixture to the bran mixture and mix at medium speed about one-half minute or until well blended.

Place in a spray-coated 9-inch square cake pan and bake at 350F for about 20 minutes, or until the cake springs back when touched in the center and sides pull away from the pan. Cool to room temperature and cut into 3x4-inch squares to yield 12 squares. Use one square per serving.

Next
Chocolate Zucchini Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Chocolate Zucchini Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Zucchini Cake

A moist chocolate cake that doesn’t need frosting. Make two, one for now, and one to freeze for later. Recipe courtesy of Sugar Twin Spoonable Sugar Replacement.

Ingredients:
Vegetable cooking spray
3 cups all-purpose flour
1/2 cup Sugar Twin sweetener
1/2 cup unsweetened cocoa powder
1 tablespoon baking powder
2 teaspoons baking soda
2 teaspoons ground cinnamon
1/2 teaspoon ground cloves
1/2 teaspoon cream of tartar
1/2 teaspoon salt
12 tablespoons reduced-fat margarine, melted
1/2 cup liquid egg substitute
1/2 cup light sour cream
1 cup 2% low-fat milk
2 teaspoons vanilla extract
Six large egg whites, beaten until soft peaks form
3/4 pound zucchini, unpeeled, trimmed, and shredded

Directions:
Preheat oven to 350-degrees. Lightly coat two 8 X 8-inch metal baking pans with cooking spray.

In a medium bowl, sift together the flour, Sugar Twin®, cocoa, baking powder, baking soda, cinnamon, cloves, cream of tartar, and salt.

In a large bowl, beat together the melted margarine, egg substitute, sour cream, milk, and vanilla. Gradually stir in the sifted dry ingredients. Mix until smooth. Stir in zucchini and gently fold in beaten egg whites.

Divide the batter evenly between the prepared pans. Bake for 45 to 55 minutes, until a wooden pick inserted in center comes out clean. Completely cool in pan on a wire rack. Wrap and freeze one cake; refrigerate second cake for up to three days.

Nutrition information per serving:
Calories: 171
Total Fat: 7g
Saturated Fat: 1.9g
Carbohydrate: 23g
Cholesterol: 4mg
Sodium: 469mg
Fiber: 2g
Protein: 6g
Calories from fat: 34%
Exchanges: 1-1/2 carbohydrate (1-1/2 bread-starch), 1 fat

Next
Raisin Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Chocolate Covered Cherry Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Covered Cherry Pie

Ingredients:
9-inch pie crust brushed with egg whites, baked and cooled

Cherry ingredients:
1/4 - 1/3 cup all fruit cherry jam
Pudding ingredients:
3-1/2 cups 1% milk
Two small (4 serving size) packages chocolate sugar-free instant pudding

Topping ingredients:
1/4 cup whipping cream
One packet sweetener
1/2 teaspoon vanilla
1 teaspoon sugar-free hot chocolate mix (optional)

Cherry layer:
Evenly spread jam over the bottom and half way up the sides of the pie crust.*

Pudding layer:
Thoroughly beat together milk and pudding mix for one to two minutes. Gently pour the pudding over the raspberry layer, and refrigerate. Allow two hours to gel.

Topping:
For best results, wait until just before serving the pie to prepare the topping. Beat the whipping cream until peaks form and then droop. Add Equal® and vanilla. Beat until stiff. Spread a thin layer of topping over the entire pie. Dust topping with sugar-free hot chocolate mix.
*Or you may prefer to beat the jam into the pudding after the pudding is thoroughly mixed.

Recipe makes eight servings.

Next
Brownie Sunday Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Chocolate Bread Pudding | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Bread Pudding

Ingredients:
Nonstick spray
3/4 cup unsweetened cocoa powder
1-3/4 cup sugar
3 cups nonfat milk
1 pound day old bread with crusts removed, torn into pieces
1 tablespoon vanilla
One egg
Two egg whites
1 teaspoon cinnamon
1/2 teaspoon salt
1 teaspoon finely grated orange peel

Directions:
Preheat oven to 375-degrees. Spray a loaf pan with nonstick spray and dust with cocoa powder. Combine cocoa and 3/4-cup sugar with milk in a saucepan. Cook over medium low heat until dissolved. Cool. Pour over bread and soak until bread absorbs mixture. Combine vanilla, egg and egg whites, cinnamon, remaining sugar, salt and orange peel. Place one layer of bread in loaf pan. Pour a little of the egg mixture over. Continue placing bread and egg mixture in loaf pan until pan is filled. Pour remaining egg mixture over the top and bake for 45 minutes to one hour, or until crusty on top, puffy, and set in the middle. Let cool slightly and serve warm or cold. Some liquid will settle in bottom of pan.

Recipe makes seven servings.

Nutrition information per 4-ounce serving:
Calories: 208
Total Fat: 2g

Next
Main Contents

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Chocolate Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Sauce

This sauce is delectable as a dessert topping over ice cream, sponge cake, or fresh pears, and is excellent as the base for chocolate drinks.

Ingredients:
2 teaspoons cornstarch
1/2 cup cocoa
2 cups cold water
Artificial sweetener equivalent to 8-teaspoons sugar
2 teaspoons vanilla

Directions:
Combine cornstarch and cocoa. Whisk into cold water in a saucepan until there are no dry bits. Cook, stirring frequently, until mixture comes to a boil. Stir 1 minute until mixture thickens. Remove from heat, stir in sweetener amd vanilla, cover and allow to cool. Store in clean jar in refrigerator up to six weeks.

Variation:
Mocha Sauce:Substitute 500 ml (2 cups) strong coffee for water in the above recipe.

Recipe makes about 2-1/4-cups sauce, 12 servings.

Nutrition information per 3-tablespoon serving:
Calories: 12
Carbohydrate: 2g
Protein: 1g

Back
Main Contents

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Fat and Cholesterol | Fitness and Freebies

Fat and Cholesterol

Let us take a closer look at the effect of dietary fat on diabetes. The type and amount of fat you eat can play a major role in the development of heart disease, stroke or hardening of the arteries. To reduce an already increased risk due to diabetes, both you and your doctor will want to pay attention to the levels of fat in your bloodstream.

Whether one cares to hear this or not, the fact is, a high-fat diet is one of the main reasons people are overweight. This is the truth - like or not - and most of us do not but we must accept it. Many who advocate the low-carbohydrate diet will tell you they knew someone who was fat, watched their fat intake and still died from one of the risks of obesity. Well, the answer to this common (but sad) comparison so many like to make is that the reason they were fat and need to watch their fat, is because they ate too much fat!

Fat packs a double-punch of calories into every gram. One gram of fat contains 9 calories whereas a gram of carbohydrates or protein contains a fewer than four calories. It is important those with diabetes avoid being overweight as extra pounds put a strain on your heart and causes your body's cells to be more resistant to insulin.

One more note on fats - we have two kinds of fats, as you have probably read/heard about. The saturated vs. unsaturated debate goes on. Saturated fat comes from animal products, such as meat, eggs and dairy products. It is generally solid at room temperatures, with the exception of tropical oils (palm, coconut). Unsaturated fat comes from vegetables and usually is "liquid" at room temperatures. For example, corn, sunflower, safflower, canola and olive oils.

And then there's the dreaded trans fats...read The Dangers of Trans Fat for more information on those buggers...

Next
Cholesterol and Triglycerides

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Apple-Cherry Chutney | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Apple-Cherry Chutney

Ingredients:
1 cup chunky applesauce
1/2 cup canned tart cherries, drained
2 tablespoons brown sugar
1 teaspoon lemon juice
1/2 teaspoon ground cinnamon
1/8 teaspoon nutmeg

Directions:
Combine all ingredients in a small saucepan; bring to a boil. Reduce heat; simmer five minutes. Serve warm over pancakes, French toast, frozen yogurt - or anything else you can think of!

Recipe makes 1-1/2 cup.

Nutrition information per serving:
Calories: 13
Fat: <1g
Saturated Fat: <1g
Calories from fat: 1%
Protein: <1g
Carbohydrates: 3g
Cholesterol: 0mg
Sodium: 1mg
Fiber: <1g
Dietary Exchanges: Free Food

Next
Cranberry Cracker Spread

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Mulled Rosy Cider | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Mulled Rosy Cider

Ingredients:
4 cups cider or unfiltered apple juice
2 tablespoons grenadine (a syrup made from pomegranate juice, usually found in the liquor section of larger markets)
Four cloves
Four pods of cardamom, slightly crushed
1 cinnamon stick, cut in 2-inch pieces
Fresh lemon zest, cut in 2-inch strips
Fresh orange zest, cut in 2-inch strips

Directions:
In a medium saucepan, combine the apple cider with the grenadine, cloves, cardamom, cinnamon, lemon and orange zest. Heat the cider until small bubbles appear around the edges of the liquid. Reduce the heat, keeping the cider warm enough so that steam rises from the surface. Hold it at this point for 20 minutes. Remove the spices and zest from the pan. Pour the cider into clear punch cups or mugs and serve.

Courtesy of the American Institute for Cancer Research.

Recipe makes 16 (1/2-cup) servings.

Nutrition information per sweving:
Calories: 39
Fat: 0g
Carbohydrate: 11g
Cholesterol: 0mg
Sodium: 3mg
Exchanges: 1 Fruit

Next
Fitness Shake

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Spicy Berry Cider | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Spicy Berry Cider

Ingredients:
4 cups apple cider or apple juice
1 (18-ounce) can unsweetened pineapple juice
2 cups fresh raspberries or 2-cups frozen slightly sweetened raspberries
1 teaspoon whole allspice
1 teaspoon whole cloves
1 whole nutmeg
4 packets sweetener or 1-1/4 teaspoons measurable sweetener of choice

Directions:
In a large saucepan combine apple cider or juice, pineapple juice, berries and spices; slowly bring mixture to boiling. Reduce heat; cover and simmer 20 minutes.

Remove from heat; strain to remove seeds. Stir in sweetener . Serve in mugs. Garnish each serving with a cinnamon stick, if desired.

Recipe makes 7 (8-ounce) servings.

Nutrition information per serving (8-ounces):
Calories: 127
Total Fat: 0
Saturated Fat: 0g
Carbohydrate: 31g
Cholesterol: 0mg
Sodium: 5mg
Protein: 1g
Exchanges: 2 Fruit

Next
Tangy Cherry Milkshake

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Cinnamon Bread Pudding | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cinnamon Bread Pudding

Cinnamon Bread Pudding

Ingredients:
2 cups skim milk
4 tablespoons margarine cut into pieces
One egg
Two egg whites
ѕ cup measurable sweetener or 16 packets
1-1/2 teaspoons ground cinnamon
1/8 teaspoon ground cloves
Three dashes ground mace (optional)
ј teaspoons salt
4 cups cubed, day-old French or Italian bread (3/4-inch thick)

Directions:
Heat milk and margarine to simmering in medium saucepan; remove from heat and stir until margarine is melted. Cool ten minutes.

Beat egg and egg whites in large bowl until foamy; mix in sweetener, spices and salt. Mix milk mixture into egg mixture; mix in bread.

Spoon mixture into ungreased 1-1/2 quart casserole. Place casserole in roasting pan on oven rack; ad 1-inch hot water. Bake, uncovered, in preheated 350-degree oven until pudding is set and sharp knife inserted halfway between center and edge comes out clean, 40 to 45 minutes.

Recipe makes six servings.

Nutrition information per serving:
Calories: 202
Protein: 8g
Total Fat: 10g
Carbohydrate: 21g
Cholesterol: 37mg
Sodium: 422mg
Exchanges: Ѕ milk, 1 starch, 2 fat

Next
Chocolate Bread Pudding

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Citrus Spinach and Rice Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Citrus Spinach and Rice Salad

Looking to add whole grains to your diet? This tasty salad is made with brown rice. The spinach is rich in vitamin A and makes an excellent source of vitamin C when combined with the oranges.

Ingredients:
2 cups brown rice
One package (6 ounces) baby spinach leaves
One large orange , peeled, sectioned
1/4 cup red onion slices
1/2 cup honey Catalina reduced fat dressing

Directions:
Prepare rice as directed on package. Cool.

Toss rice, spinach, oranges and onion with dressing.

Recipe makes four servings.

Nutrition information per serving:
Calories: 280
Total Fat: 7g
Saturated Fat: 0.5g
Cholesterol: 0mg
Sodium: 440mg
Carbohydrate: 50g
Fiber: 4g
Protein: 6g
Exchanges: 2 Starch, 1 Carbohydrate, 1 Fat

Next
Winter Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Clam Chowder | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Clam Chowder

Ingredients:
One can (5 ounces) whole baby clams, do not drain
One potato, peeled, coarsely chopped
1 cup sliced celery
1/4 cup finely chopped onion
2/3 cup evaporated skim milk
Pinch ground white pepper
Pinch dried thyme leaves
3 to 4 teaspoons lemon juice
1 tablespoon reduced calorie margarine

Directions:
Drain clams; reserve juice. Add enough water to reserved juice to measure 2/3 cup. Combine clam juice mixture, potato and onion in large saucepan. Bring to a boil over high heat. Reduce heat to medium-low. Simmer eight minutes or until potato is tender. Add milk, pepper and thyme to saucepan. Increase heat to medium-high. Cook and stir two minutes. Add margarine. Cook five minutes or until soup thickens, stirring occasionally. Stir in clams. Cook five minutes or until clams are firm, stirring occasionally. Garnish with red pepper strip, thyme and greens, if desired.

Recipe makes two servings.

Nutrition information per serving:
Calories: 204
Fat: 4g
Cholesterol: 47mg
Sodium: 205mg
Carbohydrate: 30g
Fiber: 1g
Protein: 14g
Exchanges: 1 Starch/Bread, 1 Lean Meat, 1 Milk

Next
Chinese Chicken Corn Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Instant Cocoa Mix | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Instant Cocoa Mix

Ingredients:
2 cups nonfat dry milk powder
1/2 cup lower-fat powdered nondairy creamer
1/2 cup unsweetened cocoa powder
10 packets sweetener or 1 tablespoon measurable sweetener of choice
3/4 teaspoon ground cinnamon (optional)

Directions:
For cocoa mix, stir together milk powder, nondairy creamer, cocoa powder, sweetener and, if desired, cinnamon. Cover and store in an airtight container. For each serving, in a heat-proof mug add 3/4-cup boiling water to 1/3-cup cocoa mix; stir to dissolve.

Mocha Cocoa Mix:
For a delicious mocha-flavored variation of Instant Cocoa Mix, prepare as directed, except decrease the cocoa powder to 1/3-cup and add 1/4-cup instant coffee crystals.

Recipe makes 2-2/3 cups mix (enough for eight, six-ounce servings).

Nutrition information per serving (8-ounces):
Calories: 104
Fat: 2
Carbohydrate: 17g
Cholesterol: 3mg
Sodium: 93mg
Protein: 8g
Exchanges: 1 Milk

Next
Holiday Eggnog

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Table of Contents | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Table of Contents

Button Introduction
Button About
Button The Diabetic Ribbon
Button Diabetes
Button The Diabetic Diet
Button Your Diet Strategy
Button Dietary Rewards
Button Creating A Diet Plan
Button Break Down of the Meal Plan
Button Using an Exchange Meal Plan
Button Common Misunderstandings of Exchange Plan
Button Snacks
Button Diabetes Food Pyramid
Button Nutrition Facts for Diabetics
Button Carbohydrates
Button Protein
Button Fat
Button Fat and Cholesterol
Button Cholesterol and Triglycerides
Button Vitamin K and Diabetes
Button Blood Sugar
Button High Sugar Foods
Button Herbs for Your Health
Button Cooking With Alcohol
Button Personal Eating Style
Button Monitor Your Glucose
Button Oatmeal in the Diabetic Diet
Button Oatmeal Recipes
Button Sugar and Sugar Substitutes
Button Aspartame: The World Agrees It Is Safe!
Button The Diabetic Pantry
Button Baking With Sugar Substitutes
Button Cooking With Less Fat and Cholesterol
Button Diabetes And Holiday Food Temptations
Button Low-Fat Techniques for Holiday Cooking

Recipes

Button Beverages
Button Dips, Spreads and Sauces
Button Breads, Muffins and Rolls
Button Salads, Soups and Sides
Button Main Dishes
Button Snacks
Button Pies
Button Cakes
Button Desserts
Button Cookies
Button Candy

back
Introduction

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.

Disclaimer: This E-book is not meant to replace or give specific medical advice. It is meant solely to help one cope the dietary adjustments for diabetes. Specific medical problems or concerns MUST be dealt with by your doctor or other medical care professional.


Cooking With Less Fat and Cholesterol | Fitness and Freebies

Cooking With Less Fat and Cholesterol

Following are some tips to help you reduce the fat and cholesterol in your favorite recipes.

  • Avoid high-fat, high-cholesterol foods completely. These include animal based foods such as red meat, eggs, whole milk, butter or whole milk cheese. Drink skim milk or skim milk products. Use tub margarine with liquid olive or peanut oil as the primary ingredient in place of butter or sour cream.
  • Stock your refrigerator with foods that are naturally low in fat and cholesterol-free such as fresh fruits and vegetables.
  • When you cook poultry, remove the skin. Alternatively, you could cook it with the skin on, but do not eat the skin.
  • Bake, boil, broil, roast or steam foods rather than frying. Avoid fried foods and aim to eliminate them from your diet entirely.
  • Use nonstick cooking sprays which are low in calories. You could also use a small dab of margarine in a pan if necessary but always avoid lard, bacon fat and shortening.
  • When preparing the recipes, experiment by cutting the fat by one-fourth of one-third. For example, if a muffin recipe calls for 1-cup of oil, try ѕ-cup. It that works try using 2/3-cup next time and so on.
  • When a recipe calls for milk, use skim milk or 1-percent milk. If the result is too thin, try evaporated skim milk, which also can be used effectively in cream soups and can be whipped when partially frozen.
  • Remove the fat from gravy and soup using a fat separator (a small pitcher with a specially designed spout). Or refrigerate the food overnight and skim off the fat when hardened.
  • In recipes, substitute low-fat or nonfat plain yogurt for sour cream. To help separation in cooked foods, bland a small amount of flour or cornstarch (1-tablespoon) into the yogurt.
  • For half or all of the ground beef required in a recipe, substitute ground white turkey or ground white chicken meat. In addition, in many recipes you can usually cut the amount of meat in half - this works best with recipes calling for ground meat - to further reduce fat and cholesterol.
  • Eat no more than two to four eggs per week. Each large egg has about 213 milligrams of cholesterol. In recipes, use an egg white for one whole egg, or use egg substitutes.
Another way to reduce fat is to use products that contain fat substitutes or fat replacers. Most fat replacers are made of all-natural, food-based substances. They fall into three categories:
  • Carbohydrate-based, which are an excellent thickeners and stabilizers and are used in many formulated foods, such as margarine, mayonnaise and baked desserts.
  • Protein based, which are good for frozen and refrigerated products such as dairy products, cream-type products and prepared entrees such as pizza.
  • Fat based, which, after being chemically altered, have fewer calories than fat or no calories at all. These are very stable when heated and therefore, are good for cooking.

Next
Diabetes And Holiday Food Temptations

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Yummy Peanut Butter Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Yummy Peanut Butter Cookies

Ingredients:
1/3 cup flour
1/4 teaspoon baking soda
1/4 teaspoon baking powder
1/4 cup diet margarine
4 tablespoons peanut butter
1 tablespoon brown sugar replacement
1/2 cup granulated sugar replacement
One egg well beaten

Directions:
Preheat oven to 375-degrees. Grease cookie sheet lightly. Sift flour, baking soda, and baking powder. Work margarine and peanut butter with spoon until creamy; gradually add brown sugar replacement, continue working until light. Add granulated sugar replacement and egg; beat well. Mix in dry ingredients thoroughly. Drop by teaspoonfuls onto cookie sheet; flatten with tines of fork in a criss-cross pattern. Bake until done, 8-10 minutes.

Recipe makes 18 cookies.

Nutritional information per cookie:
Calories: 45 Exchange: 1/4 Bread, 1/2 Fat, 1/4 Lean Meat

Next
Peanut Butter Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Peanut Butter Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Cookies

Ingredients:
1/4 cup margarine
1/4 cup creamy peanut butter
2 tablespoons granulated sugar replacement
2 tablespoons granulated brown sugar replacement
One egg
1/4 cup water
1 teaspoon vanilla extract
1-1/2 cup flour
1 teaspoonbaking soda
1/2 teaspoon baking powder

Directions:
Cream together margarine, peanut butter and sugar replacements. add egg, water and vanilla, beating until fluffy. Combine flour, baking soda and baking powder in sifter and sift dry ingredients into creamed mixture. Stir to blend completely. Chill thoroughly, at least two hours or overnight.

Drop by teaspoonfuls onto lightly greased cookie sheets, 2 to 3-inches apart. Press flat with a floured bottom of a small glass. Bake at 375-degrees for 12 to 15 minutes.

Next
Peanut Butter Balls

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Peanut Butter Balls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Balls

Ingredients:
1 cup margarine
2 tablespoons granulated artificial sweetener
1 teaspoon vanilla extract
2 tablespoons water
2 cups all-purpose flour
One egg white
1/2 cup chopped peanuts

Directions:
Preheat oven to 350-degrees.

Beat margarine and sugar till fluffy. Add vanilla, water, and flour, mixing well. Refrigerate one hour.

Form into 1-inch balls, dip into beaten egg white and roll into peanuts. Place on ungreased cookie sheets. Bake 10 to 12 minutes. Store in an airtight container.

Next
Oatmeal Peanut Butter Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Oatmeal Peanut Butter Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Peanut Butter Cookies

Ingredients:
2/3 cup oatmeal
2 cups flour
1 teaspoon Lite salt
1/4 teaspoon soda
2 teapoons baking powder
1/3 cup corn oil
2/3 cup salt-free peanut butter
1/4 cup egg substitute
One egg
3 tablespoons skim milk
4 tablespoons liquid sweetener
2 tablespoons sugar substitute

Directions:
Preheat oven to 350-degrees.

Sift flour, salt, soda, and baking powder. Cream next six ingredients together add oatmeal, beat. Add flour mixture, stir until it forms a ball; roll into 1-inch balls. Place on ungreased cookie sheet. Press down with glass.

Bake at 375 degrees for ten minutes.

Recipe makes four servings.

Calories per cookie: 35

Next
Chocolate Chip Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Chocolate Chip Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Chip Cookies

Ingredients:
One stick Crisco butter flavor shortening*
One egg
1 teaspoon vanilla
2 packets granular sugar substitute
1/2 teaspoon baking soda
1 cup flour
1/2 cup semi-sweet chocolate chips
1/2 cup pecans, crushed

*You can use any type of butter if desired; Criso just makes them crisper.

Directions:
Preheat oven to 375-degrees. Soften Crisco butter-flavor in a large bowl. Add egg, vanilla, granular sugar substitute and baking soda. Mix well. Stir in flour then add chocolate chips and pecans. Drop by teaspoon onto ungreased cookie sheet.

Bake eight to ten minutes or until golden brown.

Note:
These cookies are not completely sugar-free, as semi-sweet chocolate chips do contain sugar.

Recipe makes six to eight servings.

Next
Chocolate Chip Cookies II

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Chocolate Chip Cookies II | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Chip Cookies II

Ingredients:
1 cup margarine at room temperature
1/4 cup sugar
3/4 cup brown sugar substitute
Three large egg whites, room temperature
1 tablespoons vanilla
2 cups flour
1 teaspoon baking soda
1/4 teaspoon salt
1/4 cup water, room temperature
1/2 cup mini semisweet chocolate chips

Directions:
Cream together margarine, sugar and sugar substitute at medium speed until light and fluffy. add egg white and vanilla to creamed mixture and beat at medium speed for one minute. Stir together flour,, soda and salt to blend well.

Add 1/4-cup water to creamed mixture along with the flour mixture and mix at medium speed for one minute or until smooth. Add chocolate chips to dough and mix lightly. drop by tablespoonsful onto cookie sheets that have been lined with alumium foil or sprayed with nonstick cooking spray. Press down lightly with fingers dipped in cold water to form a circle about 2-inches across.

Bake at 375-degrees for about 12 minutes or until browned (the cookies won't be crisp unless they are browned). Remove cookies from hot cookie sheets to wire racks to cool to room temperate.

Variation:
Chocolate Chip Bars: Instead of dropping dough onto cookie sheets, spread dough evenly in a jelly roll pan that has been sprayed with nonstick spray, or greased with margarine. Bake at 375-degrees for 20-25 minutes, or until lightly browned and the bars pull away from the sides of the pan.Cool to room temperature and cut to yield 36 bars.

Recipe yields 24 servings.

Next
Chocolate Chip Cookies III

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Chocolate Chip Cookies III | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Chip Cookies III

Ingredients:
1 cup flour
1/4 teaspoon salt
1/2 teaspoon baking soda
1/2 cup diet margarine
3/4 cup sugar substitute
1/2 teaspoon vanilla
One egg
1/2 cup semisweet chocolate chips, shaved fine
1/2 cup nuts, optional

Directions:
Preheat oven to 375-degrees.

Cream softened margarine, add sweetener, vanilla and egg; blend well. Add flour, salt and baking soda. Beat well.

Stir in chocolate chips and nuts. Drop by level spoonfuls on lightly greased pan. Bake about ten minutes.

Recipe makes 3-dozen cookies.

Calories per serving: 40 without nuts, 50 with nuts.

Exchanges per cookie: One cookie equals 1/4 bread, 1/2 fat (without nuts) 1 fat with nuts.

Next
Chocolate Chocolate Chip Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Chocolate-Chocolate Chip Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate-Chocolate Chip Cookies

Ingredients:
1/2 cup butter or margarine, softened
1/4 cup granulated sugar substitute to equal 1/2-cup sugar
One large egg
1 teaspoon vanilla extract
1 cup all-purpose flour
3 tablespoons cocoa or European style cocoa
1/2 teaspoon baking soda
1/8 teaspoon salt
2 tablespoons skim milk
1/3 cup mini chips semi-sweet chocolate

Directions:
Preheat oven to 375-degrees.

Heat oven to 375-degrees. In medium bowl, beat butter, sugar and sugar substitute until well blended. Add egg and vanilla; beat well. Stir together flour, cocoa, baking soda and salt; add alternately with milk to butter mixture, beating until well blended. Stir in small chocolate chips. Drop by teaspoonfuls onto ungreased cookie sheet.

Bake seven to nine minutes or just until set. Remove from cookie sheet to wire rack. Cool completely.

Recipe makes 3-dozen cookies.

Nutrition information per cookie:
Calories: 50
Protein: 1g
Fat: 3g
Carbohydrate: 5g
Cholesterol: 5mg
Sodium: 50mg
Exchange: 1 vegetable, 1/2 fat

Next
Mocha Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Mocha Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Mocha Cookies

Ingredients:
1/2 cup margarine, room temperature
2 tablespoons sugar
2 teaspoons vanilla
1/3 cup liquid sugar substitute
1-1/4 cup flour
3 tablespoons cocoa
2 teaspoons instant coffee granules
1 teaspoon baking powder
1/4 cup raisins
1/4 cup chopped nuts
Two large egg whites, room temperature

Directions:
Preheat oven to 375-degrees.

Cream together margarine and sugar until light and fluffy. add vanilla and sugar substitute to creamed mixture and mix lightly. Stir together flour, cocoa, coffee and baking powder to blend. Add to creamed mixture and mix at meidum speed one to two minutes or until blended. Add raisins and nuts to dough and mix lightly. Add egg whites to dough and mix until egg white are absorbed into the dough. Drop dough by tablespoonsful onto a cookie sheet lined with alumium foil or sprayed with nonstick cooking spray.

Using your fingers dipping in cold water, shape dough into round cookies about 1/4-thick. Spread the dough carefully because the finsihed cookie will be the shpae of the dough after it is baked.

Bake at 375-degrees for about 12 minutes, or until the dough springs back when touched. Transfer from the cookie sheet onto a wire rack and cool to room temperature. Serve one cookie per serving.

Recipe makes 18 cookies.

Next
Deep Chocolate Coconut Balls

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Deep Chocolate Coconut Balls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Deep Chocolate Coconut Balls

Plan ahead...needs to chill at least two hours.

Ingredients:
1/2 cup vegetable shortening
3 ounces unsweetened baking chocolate
1-1/2 cup granulated sugar replacement (Splenda)
1/2 cup granulated fructose
Four eggs
2 teaspoons vanilla
2 cups flour
2 teaspoons baking soda
1/4 teaspoon salt
1/3 cup unsweetened flaked coconut

Directions:
In a double boiler or microwave, melt shortening and baking chocolate. Pour into a mixing bowl. Beat in sugar replacement and fructose. (Mixture will look curdled.) Add eggs, one at a time, beating well after each addition. Beat in vanilla. Stir in flour, baking soda, and salt. fold in coconut. Cover and chill at least 2 hours. Shape dough into balls, and place on lightly greased cookie sheets. Bake at 350-F for 8-9 minutes. Move to cooling racks.

Yield: 84 balls

Nutrition information per ball:
Calories: 33
Carbohydrate: 3gm
Exchange per ball: 1/4 bread, 1/4 fat

Next
Double-Chocolate Oatmeal Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Double-Chocolate Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Double-Chocolate Oatmeal Cookies

Ingredients:
1 cup granulated sugar substitute
1 cup margarine
One large egg
1/4 cup water
1 teaspoon vanilla
1-1/4 cup all-purpose flour
1/2 cup whole-wheat flour
1/4 cup cocoa
2 cup rolled oats
1/2 teaspoon baking soda
1/2 cup semisweet chocolate chips

Directions:
Cream sugar and margarine together at medium speed until light and fluffy. Add egg, water, and vanilla, and mix at medium speed for 30 seconds, scraping down the bowl before and after adding egg, water and vanilla. Stir flours, cocoa, oatmeal, baking soda and baking powder together to blend ; add to egg mixture. Mix to medium speed to blend and then add chocolate chips. Drop dough by 1-1/2 tablespoonfuls onto cookie sheets that have been sprayed with nonstick cooking spray or lined with aluminum foil.

Bake at 350-degrees for 12 to 14 minutes, or until cookies are not quite firm; do not over bake, or cookies will be too hard. Remove them to a wire rack and cool to room temperature.

Yield: 36 cookies

Nutrition information per cookie:
Calories: 120
Cholesterol: 8g
Fat: 6g
Protein: 2g
Exchange per ball: 1 Bread, 1 Fat

Next
Spiced Oatmeal Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Spiced Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Spiced Oatmeal Cookies

Ingredients:
1 cup water
2 cups raisins
4 tablespoons measurable sweetener
1/2 cup butter
1/2 teaspoon salt
1/4 teaspoon allspice
1/2 teaspoon cinnamon
1/8 teaspoon nutmeg
2-1/2 cups oatmeal
1/2 cup chopped nuts
1 teaspoon soda

Directions:
Add sweetener, butter, salt,allspice, cinnamon, nutmeg, oatmeal, chopped nuts and soda. Form into balls and bake on lightly greased cookie sheet for 15 minutes at 325-degrees.

Yield: Four servings.

Next
Lemon Oatmeal Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Lemon Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Lemon Oatmeal Cookies

Ingredients:
2/3 cup vegetable oil
2/3 cup brown sugar
1/2 cup egg whites
2 tablespoons lemon juice
2 tablespoons grated fresh, or finely chopped, dried lemon rind
1 teaspoon lemon flavoring
1 cup all-purpose flour
1 cup rolled oats
1/2 teaspoon baking powder
1/2 teaspoon baking soda
1-1/2 cup crispy rice cereal

Directions:
Place oil and brown sugar in a mixer bowl in a mixer bowl and mix at medium speed until creamy.

Add egg whites, lemon juice, rind and flavoring, and mix at medium speed until well blended.

Stir flour, oatmeal, baking powder, and baking soda together to blend well; add to creamy mixture while beating at medium speed. Stir in cereal.

Drop by the tablespoonful onto cookie sheets left ungreased, or lined with aluminum foil.

Bake at 350-degrees for eight to ten minutes, or until cookies are lightly browned. Remove cookies to a wire rack and cool.

Nutrition information per serving:
Calories: 87
Protein: 1g
Fat: 4g
Carbohydrates: 11g
Exchanges: 2/3 Bread, 1 Fat

Next
Oatmeal Raisin Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Oatmeal Raisin Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Raisin Cookies

Ingredients:
1/4 cup margarine, softened
2 tablespoons fructose sweetener
Two egg whites
3/4 cup applesauce
1/4 cup unsweetened apple juice concentrate, thawed
1 teaspoon vanilla extract
1 cup all-purpose flour
1 teaspoon baking soda
1/2 teaspoon ground cinnamon
1/4 teaspoon salt (optional)
1-1/2 cups rolled oats
1/3 cup chopped raisins

Directions:
Preheat oven to 350-degrees. Grease cookie sheets.

In a large bowl, cream together the margarine, fructose and egg whites until smooth. Stir in the applesauce, apple juice concentrate and vanilla. Combine the flour, baking soda, cinnamon and, if desired, salt; stir into the applesauce mixture. Finally, mix in the oats and chopped raisins. Drop by rounded spoonfuls onto the prepared cookie sheets.

Bake for 15 to 17 minutes in the preheated oven, until cookies are firm to the touch and lightly browned. Cool one minute on the cookie sheets before removing to wire racks to cool completely. When cool, store in an airtight container.

Next
Raisin Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Raisin Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Raisin Cookies

Ingredients:
1-1/2 cups raisins
1/2 cup peeled, cored and chopped apple
1 cup water
1/2 cup butter
1 cup all-purpose flour
1 teaspoon baking soda
1 teaspoon vanilla extract
1 cup quick cooking oats
Two eggs, beaten
3/4 cup chopped walnuts

Directions:
Preheat oven to 350-degrees. Grease cookie sheets.

In a medium saucepan, combine the raisins, apples and water. Bring to a boil and cook for three minutes. Remove from heat and stir in the butter. Set aside to cool.

In a medium bowl, stir together the flour and baking soda. Stir in the vanilla, eggs and the apple mixture until well blended. Fold in the oats and nuts. Cover dough and chill eight hours or overnight.

Preheat oven to 350-degrees. Grease cookie sheets. Drop by rounded spoonfuls onto the prepared cookie sheet.

Bake for eight to ten minutes in the preheated oven. Allow cookies to cool on baking sheet for five minutes before removing to a wire rack to cool completely.

Next
Applesauce-Raisin Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Applesauce-Raisin Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Applesauce-Raisin Cookies

Ingredients:
1/4 cup vegetable oil
1/4 cup sugar
One egg
1 teaspoon vanilla
1/2 cup unsweetened applesauce
1/2 cup whole wheat flour
1/2 cup unbleached flour
2 teaspoon baking powder
1/2 teaspoon baking soda
1 teaspoon cinnamon
1/8 teaspoon cloves
1/2 cup rolled oats
1/2 cup raisins - dark or golden

Directions:
Cream the oil and sugar together. Add the egg and beat until light. Blend the vanilla and applesauce. Stir the flours, baking powder, baking soda, cinnamon, cloves, oats, and raisins into the creamed mixture. Blend well. Drop by teaspoonfuls onto lightly oiled baking sheets. Bake at 375-degrees for ten minutes, cool on a wire rack.

Nutrition information per cookie:
Calories: 56
Cholesterol: 10g
Protein: 1g
Fat: 2g
Exchange: 1/2 Fruit, 1/2 Fat

Next
Applesauce Raisin Drops

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Applesauce Raisin Drops | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Applesauce Raisin Drops

Ingredients:
1 cup unbleached all-purpose flour
1-1/2 teaspoons baking powder
1/2 teaspoon baking soda
3/4 teaspoon ground cinnamon
1/4 teaspoon ground nutmeg
1/8 teaspoon ground cloves
1/8 teaspoon cream of tartar
8 tablespoons stick margarine, softened
1/3 cup Brown Sugar Twin
1/4 cup liquid egg substitute
1-1/3 cup unsweetened applesauce
1-1/2 teaspoon vanilla extract
1-3/4 cups quick-cooking oats cereal
1 cup seedless raisins

Directions:
Preheat oven to 375-degrees. Spray cookie sheets with no stick baking spray. Into small bowl, sift together first seven ingredients; set aside. In large bowl, cream margarine until fluffy. Blend in Brown Sugar Twin and egg. Alternately add sifted dry ingredients and applesauce; blend well. Stir in vanilla, oats, and raisins.

Drop by tablespoon onto prepared cookie sheets then flatten. Bake for 12 to 15 minutes, until firm.

Recipe makes about 2-1/2-dozen cookies.

Nutrition information per cookie:
Calories: 82
Cholesterol: 7g
Protein: 2g
Fat: 4g
Carbohydrate: 12g
Sodium: 80mg
Exchange: 1 carbohydrate (1/2 bread/starch, 1/2 fruit), 1 fat

Next
Raisin Sesame Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Raisin Sesame Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Raisin Sesame Cookies

Ingredients:
3/4 cup water
1/2 cup raisins
1/2 cup sesame seeds
1 cup brown rice flour
1-1/4 cups rolled oats
1/4 teaspoon salt
1-1/8 cups unsweetened apple juice
2 tablespoons vegetable oil
1 teaspoon vanilla extract

Directions:
Preheat oven to 350-degrees.

Bring 3/4-cup of water to boil and add the raisins. When the water returns to a boil turn off the heat. Let the raisins plump for at least ten minutes. Drain the raisins well, then chop them coarsely.

Toast the sesame seeds by stirring them with a wooden spoon in a heavy sautй pan over medium heat. Sautй until the seeds begin to crackle, pop and smell toasted; about ten minutes.

Combine rice flour, oats, salt and toasted sesame seeds. Stir apple juice, oil and vanilla into the flour mixture.

Form the dough into eight large balls. Place each ball on greased cookie sheets or parchment paper. Moisten your fingers and flatten each ball until it is 1/2-inch thick.

Bake 25 minutes or until golden brown. Let cool on pans before removing.

Next
French Sponge Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


French Sponge Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

French Sponge Cookies

Ingredients:
1/2 cup sifted cake flour
3/4 teaspoon baking powder
1/4 teaspoon salt
Three eggs, separated
1/2 teaspoon almond extract
1/4 teaspoon vanilla extract
6 tablespoons sugar

Directions:
Sift together flour, baking powder, and salt.

Beat egg yolks in a small bowl, rapidly, until very thick and lemon colored, adding almond and vanilla flavorings during the beating. With clean beaters, beat the egg whites until stiff and shiny; begin to add sugar, not more than 1-tablespoon at a time, and beat constantly. Continue to beat rapidly until whites are very stiff and glossy. Gently fold in the beaten egg yolks. In the same manner fold in the dry ingredients until well mixed. Using a small spatula and a measuring tablespoon, measure and drop onto ungreased baking sheets, spacing 2-inches apart.

Bake for ten minutes until light and golden brown. Remove at once from sheet to cool.

Recipe makes ten servings, four cookies per serving.

Nutrition information per serving:
Calories: 67
Fat: 2g
Cholesterol: 11g
Protein: 2g
Exchange: 1 Bread

Next
Shortbread Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Shortbread Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Shortbread Cookies

Ingredients:
3/4 cup all-purpose flour
1/2 teaspoon double-acting baking powder
1/4 cup reduced-calorie margarine
2 teaspoon butter flavor
6 tablespoons fructose, or sugar substitute

Directions:
Preheat oven to 375-degrees.

In a small bowl, combine flour and baking powder.

Add remaining ingredients and blend well with a fork to form a dough. Work dough into a ball with your hands. Divide into 24 pieces and roll each into a ball. Place on a nonstick cookie sheet. Flatten each cookie, using the bottom of a glass.

Bake for ten minutes until bottoms are lightly browned. Remove to a rack to cool.

Nutrition information per serving:
Calories: 141
Fat: 6g
Cholesterol: 0g
Carbohydrate: 18g
Protein: 3g
Sodium: 191mg
Exchange: 1 bread, 1-1/2 fat
**Add 24 calories if sugar or fructose is used as sweetner.

Next
Orange Sunbeams

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Orange Sunbeams | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Orange Sunbeams

Ingredients:
1-1/2 cup flour
1 teaspoon baking powder
1/4 teaspoon salt
1/2 cup shortening
1/2 cup raisins
One egg
2 tablespoons orange juice
2 tablespoons grated orange rind
1-1/2 teaspoon Sucaryl

Directions:
Sift together flour, baking powder and salt. Cut in shortening until crumbly.

Add all at once; raisins, eggs, orange juice, orange rind and sucaryl.

Mix well. Make into small balls; flatten on cookie sheet. Bake 12 to 15 minutes at 375-degrees.

Recipe makes 12 servings.

Next
Cotton Candy Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Cotton Candy Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cotton Candy Cookies

Ingredients:
Three egg whites; beaten stiff
2 tablespoons granulated sugar replacement or granulated fructose
2 teaspoons orange oil
1 teaspoons orange rind

Directions:
Beat sugar replacement, orange oil and rind into the stiff egg whites.

Drop onto lightly greased cookie sheets. Bake at 325-degrees for eight to ten minutes.

Remove from pan immediately.

Recipe makes 36 servings.

Exchanges for six cookies with sugar replacement: 1/5 Fruit

Next
Orange Cranberry Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Orange Cranberry Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Orange Cranberry Cookies

Ingredients:
1/4 cup margarine
One egg
3 tablespoons frozen orange juice concentrate
3/4 cup all-purpose flour, sifted
1/4 cup rolled oats
Sweetener equal to 2-1/2 teaspoons sugar
1/4 cup teaspoon baking soda
1/8 teaspoon cream of tarter
Dash salt
1 teaspoon orange peel
1/2 cup dried cranberries
1/2 cup chopped walnuts (optional)

Directions:
Cream margarine in a medium bowl. Beat in egg and frozen orange juice concentrate. Combine flour, rolled oats, sweetener, baking soda, cream of tarter, salt and orange peel in a seperate bowl. Add dry ingredients into the creamed mixture and mix well. Stir in dried cranberries and chopped walnuts. Drop by teaspoons onto a lightly sprayed non-stick cookie sheet. Bake at 375-degrees for nine to ten minutes until bottoms are lightly browned. Cool on wire racks.

Recipe yields 24 cookies.

Nutrition information per cookie:
Calories: 66
Protein: 1g
Fat: 4g
Carbohydrate: 7g
Cholesterol: 9mg
Sodium: 38mg
Exchange: 1/2 Bread, 1/2 Fat

Next
Cinnamon Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Cinnamon Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cinnamon Cookies

Ingredients:
Two eggs
2 tablespoon water
5 teaspoon granulated sugar replacement
1 teaspoon cinnamon
1-1/2 cup flour
1/2 teaspoon baking soda
1/4 teaspoon salt

Directions:
Beat eggs and water until light and fluffy. Beat in sugar replacement and cinnamon. Combine flour, baking soda and salt in sifter; sift half of the dry ingredients over egg mixture. Fold to completely blend. Repeat with remaining dry ingredients. Drop by teaspoonfuls onto greased cookie sheets, two to three-inches apart. Bake at 375-degrees for 10 to 12 minutes.

Recipe yields 20 cookies.

Nutrition information per cookie:
Calories: 41
Exchange: 1/2 Bread

Next
Cinnamon Nut Balls

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Cinnamon Nut Balls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cinnamon Nut Balls

Ingredients:
1-1/4 cups all-purpose flour
1 teaspoon baking powder
1/8 teaspoon salt
1/2 cup margarine
3 tablespoons granulated artificial sweetener
One egg
1 teaspoon vanilla extract
2 teaspoons ground cinnamon
1/2 cup chopped walnuts

Directions:
Preheat oven to 375-degrees.

Sift dry ingredients, set aside. Beat margarine, sugar, egg, and vanilla. Add the flour mixture. Refigerate dough for one hour.

Powder hands lightly with flour and make ball about the size of a small egg, by using 1-tablespoon dough. Mix cinnamon and nuts together and roll balls in the spice mixture. Place on greased cookie sheet, 2 inches apart. Bake 12 to 15 minutes. Remove from pan soon as they come from oven.

Next
Healthy Banana Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Healthy Banana Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Healthy Banana Cookies

Ingredients:
3 ripe bananas 1 cup dates, pitted and chopped 2 cups rolled oats 1/3 cup vegetable oil 1 teaspoon vanilla extract

Directions:
Preheat oven to 350-degrees.

In a large bowl, mash the bananas. Stir in oats, dates, oil, and vanilla. Mix well, and allow to sit for 15 minutes. Drop by teaspoonfuls onto an ungreased cookie sheet.

Bake for 20 minutes in the preheated oven, or until light brown.

Next
Peanut Butter 'n Banana Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Peanut Butter 'n Banana Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter 'n Banana Cookies

Traditional peanut butter cookies made moister and more flavourful with mashed banana - two favourite flavours for one great cookie.

Ingredients:
1/2 cup peanut butter (at room temperature)
1/4 cup margarine, softened
1/3 cup mashed ripe banana
One egg
1/2 teaspoon vanilla
1 cup all-purpose flour
1/2 cup Splenda Granular
1/2 teaspoon baking soda
1/2 teaspoon salt

Directions:
Cream peanut butter, margarine, banana, egg and vanilla until light and fluffy. Mix remaining ingredients separately. Blend into peanut butter mixture until smooth.

Form into 1-inch balls. Place on baking sheets. Flatten with fork to desired thickness. Bake at 350-degrees for 10 to 12 minutes or until golden brown on bottoms. Cool on rack.

Recipe makes 3 dozen cookies.

Nutrition information per two cookies:
Calories: 50
Fat: 3.1g
Carbohydrate: 4.3g
Protein: 1.5g

Next
Corny Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Corny Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Corny Cookies

These cookies contain uncooked cornstarch, which is absorbed slowly by the body. They can help prevent nighttime hypoglycemia.

Ingredients:
12 tablespoons peanut butter (3/4-cup)
3 tablespoons honey
1/4 cup cornstarch
2 cups cornflakes

Directions:
Stir together peanut butter, honey and cornstarch.

Form into balls, about 1-tablespoon in size, and roll in cruched cornflakes. Flatten balls with a tumbler and chill.

Recipe makes 12 cookies.

Nutrition information per two cookies:
Calories: 280
Fat: 16g
Carbohydrate: 26g
Protein: 8g
Exchange: 2 Carbs, 1 Meat and 3 Fat

Next
Cream Cheese and Jelly Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Cream Cheese and Jelly Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cream Cheese and Jelly Cookies

Ingredients:
3/4 cup margarine, softened
One package (8 ounces) reduced-fat cream cheese, softened
1/3 cup measurable sweetener, or eight packets
2 cups all-purpose flour
1/4 teaspoon salt
1/4 cup black cherry or seedless raspberry spreadable fruit

Directions:
Beat margarine, cream cheese and sweetener in medium bowl until fluffy; mix in flour and salt to form a soft dough. Cover and refrigerate until dough is firm, about three hours.

Roll dough on lightly floured surface into circle 1/8 thick; cut into rounds with 3-inch cutter.

Place rounded 1/4-teaspoon spreadable fruit in center of each round; fold rounds in halves and crimp edges firmly with tines of fork. Pierce tops of cookies with tip of sharp knife.

Bake cookies on greased cookie sheets in preheated 350-degree oven until lightly browned, about ten minutes. Cool on wire racks.

Recipe makes about 3-dozen cookies.

Nutrition information per cookie:
Calories: 80
Fat: 5g
Carbohydrate: 7g
Protein: 1g
Exchange: 1/2 Bread, 1 Fat

Next
Jam Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Jam Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Jam Cookies

Ingredients:
1/3-cup pecan pieces
3 cups biscuit mix
1 cup pitted dates
Two egg whites
1 cup of warm water
2 teaspoons vanilla
2/3 cup unsweetened peanut butter
Fruit-sweetened jam

Directions:
Preheat oven to 350-degrees.

Using a blender or food processor, chop pecan pieces until finely ground. Sift the biscuit mix, stir into the pecans, and set aside.

Place rounded 1/4-teaspoon spreadable fruit in center of each round; fold rounds in halves and crimp edges firmly with tines of fork. Pierce tops of cookies with tip of sharp knife.

Use blender or food processor to purйe dates, gradually adding egg whites. Beat several minutes until creamy. Melt peanut butter, and then stir it into the blender along with the water and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended.

Press dough into 1/4-inch thickness and about 2-inches diameter cookies on an ungreased cookie sheet. Then press a slight thumb print into the middle of each. Decorate each cookie with 1/4-teaspoon of jam.

Bake at 350-degrees for 8-12 minutes until you see touches of light brown. Recipe makes three-dozen cookies.

Next
Pudding Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Pudding Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pudding Cookies

Ingredients:
Sugar free instant pudding (any flavor)
1 cup Bisquick
1/4 cup olive oil
One egg

Directions:
Preheat oven to 350-degrees.

Mix dry ingredients together, then add wet. Shape into balls and place on un-greased cookie sheet. Push your thumb into each cookie to flatten a little.

Bake at 350-degrees for about five to eight minutes.

Next
Maple Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Maple Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Maple Cookies

Ingredients:
Ѕ cup reduced fat margarine, softened
Ѕ cup sour cream
1 cup shredded peeled tart apple
Two eggs
1 teaspoon maple flavoring
Ѕ teaspoon vanilla extract
2 cups all purpose flour
Artificial brown sugar sweetener equal to 1/3-cup brown sugar
Ѕ teaspoon baking soda
Ѕ teaspoon baking powder

Directions:
In a mixing bowl, combine margarine, sour cream, apple, eggs, maple flavoring and vanilla. Combine flour, sweetener, baking soda and baking powder; add to apple mixture and mix well. Drop by heaping tablespoonfuls onto baking sheets coated with nonstick cooking spray. Bake at 375-degrees for nine to ten minutes or until lightly browned. Cool on wire racks. Store in an airtight container.

Recipe yields 42 cookies.

Nutrition information per cookie:
Calories 44
Sodium 51mg
Cholesterol 11mg
Carbohydrate 5gm
Protein 1gm
Fat 2gm
Diabetic exchanges: Ѕ Starch, Ѕ Fat

Next
Butter Pecan Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Butter Pecan Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Butter Pecan Cookies

Ingredients:
3 cups biscuit mix
1/3 cup pecan pieces
1 cup pitted dates
Two egg whites
1/3 cup warm water
2 teaspoons vanilla
1/2 cup butter
Fruit-sweetened jam
Pecan halves (optional)

Directions:
Preheat oven to 350-degrees.

Use a blender or food processor to chop pecan pieces until finely ground. Sift biscuit mix, and stir in the pecans. Set aside.

Use blender or food processor to purйe dates, gradually adding egg whites and warm water. Beat several minutes until creamy. Melt butter, and then stir in date cream and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended.

On an ungreased cookie sheet, form dough into cookies 1/4-inch thickness by 2-inch diameter. Press a thumb print into the middle of each. Decorate each cookie with 1/4-teaspoon of jam and/or a pecan half.

Bake at 350 degrees for seven to ten minutes until touches of light brown can be seen.

Recipe makes 3 dozen cookies.

Next
Kaiser Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Kaiser Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Kaiser Cookies

Ingredients:
3 tablespoons margarine
1 teaspoon artificial sweetener
1 teaspoon vanilla extract
One egg
1 cup all-purpose flour
2/3 cup water

Directions:
Beat margerine until fluffy. Add the sugar replacement, egg, and vanilla. Mix for one minute.

Now add the flour and water to get a thin batter. Heat iron griddle and pour one tablespoon batter for each cookie. Cook till golden brown and turn, repeat when brown and remove to rack.

Eat the crunchy cookie now or pour fresh fruit mixture over top and serve with sugar free ice cream.

NOTE:
You can use the waffle iron sometimes also - but be careful not to burn them.

Next
Kaiser Cookies

Cookies

To Your Health!
Fitness and Freebies

space Yummy Peanut Butter Cookies | Peanut Butter Cookies | Peanut Butter Balls | Oatmeal Peanut Butter Cookies | Chocolate Chip Cookies | Chocolate Chip Cookies II | Chocolate Chip Cookies III | Chocolate Chocolate Chip Cookies | Mocha Cookies | Deep Chocolate Coconut Balls | Double-Chocolate Oatmeal Cookies | Spiced Oatmeal Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Lemon Oatmeal Cookies | Oatmeal Raisin Cookies | Raisin Cookies | Applesauce-Raisin Cookies | Applesauce Raisin Drops | Raisin Sesame Cookies | French Sponge Cookies | Shortbread Cookies | Orange Sunbeams | Cotton Candy Cookies | Orange Cranberry Cookies | Cinnamon Cookies | Cinnamon Nut Balls | Healthy Banana Cookies | Peanut Butter 'n Banana Cookies | Corny Cookies | Cream Cheese and Jelly Cookies | Jam Cookies | Pudding Cookies | Maple Cookies | Butter Pecan Cookies | Kaiser Cookies | space


Diabetic Cookie Recipes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cookie Cookies

Button Yummy Peanut Butter Cookies

Button Peanut Butter Cookies

Button Peanut Butter Balls

Button Oatmeal Peanut Butter Cookies

Button Chocolate Chip Cookies

Button Chocolate Chip Cookies II

Button Chocolate Chip Cookies III

Button Chocolate-Chocolate Chip Cookies

Button Mocha Cookies

Button Deep Chocolate Coconut Balls

Button Double-Chocolate Oatmeal Cookies

Button Spiced Oatmeal Cookies

Button Lemon Oatmeal Cookies

Button Oatmeal Raisin Cookies

Button Raisin Cookies

Button Applesauce Raisin Cookies

Button Applesauce Raisin Drops

Button Raisin Sesame Cookies

Button French Sponge Cookies

Button Shortbread Cookies

Button Orange Sunbeams

Button Cotton Candy Cookies

Button Orange Cranberry Cookies

Button Cinnamon Cookies

Button Cinnamon Nut Balls

Button Healthy Banana Cookies

Button Peanut Butter 'n Banana Cookies

Button Corny Cookies

Button Cream Cheese and Jelly Cookies

Button Jam Cookies

Button Pudding Cookies

Button Maple Cookies

Button Butter Pecan Cookies

Button Kaiser Cookies

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Hearty Corn Cakes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Hearty Corn Cakes

Ingredients:
1-1/4 cup flour
ј cup plus 3-tablespoons measurable sweetener (preferably Splenda®)
ѕ cup stone ground yellow corn meal
2 teaspoons baking powder
Ѕ teaspoon salt
1 cup fat free (skim) milk
1 tablespoon honey
ј cup olive oil
Two egg whites

Directions:
Heat oven to 400-degrees. Grease muffin cups with nonstick cooking spray butter flavor. In large bowl, mix milk, honey, oil and egg whites. Add liquid ingredients to dry ingredients and stir just until combined. Pour ј-cup batter into greased cups. Lightly spray (one spray) tops of batter with nonstick cooking spray. Bake until wooden pick comes out clean, about 15 to 20 minutes.

Recipe makes 12 servings.

Nutrition information per serving:
Calories: 113
Calories from fat: 37%
Total Fat: 5g
Saturated Fat: 4g
Carbohydrates: 15g
Cholesterol: <1mg
Protein: 10g
Sodium: 199mg
Fiber: <1g
Exchanges: 1 Starch, 1 Fat

Back
Main Contents

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Cranberry Cracker Spread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cranberry Cracker Spread

Ingredients:
1 (8 ounce) package of fat free cream cheese, softened slightly
1 cup cranberry chutney, fruit juice sweetened (or your favorite flavor chutney)

Directions:
In center of serving platter, mound cream cheese into ball with top slattened slightly. Pour chutney on top of cream cheese.

Serve with water crackers.

Yield: 48 snacks (1 serving=1/4 oz cheese/chutney)

Nutrition information per serving:
Calories: 13
Protein: 1g
Carbohydrates: 2g
Cholesterol: 1mg
Sodium: 28mg
Dietary Exchanges: 1 Free Food

Next
Sweet & Sassy Cherry Sauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Cranberry Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cranberry Salad

Ingredients:
2 cups cranberries
1 cup water
1 cup measurable sweetener
1 small package cranberry or cherry sugar-free gelatin
1 cup diced celery
1 can of (7-1/4 ounces) crushed pineapple, in juice
1/2 cup chopped walnuts

Directions:
Bring cranberries and water to a boil. Remove from heat when cranberries have popped open. Add Equal or sweetener of choice and stir. Set aside to cool. Dissolve gelatin with one cup boiling water. Add cranberry sauce; mix thoroughly. Add celery, pineapple and walnuts. Pour into a mold or bowl. Place in refrigerator until set.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 92
Protein: 1g
Total Fat: 5g
Carbohydrate: 9g
Cholesterol: 0mg
Sodium: 43mg
Exchanges: 1-1/2 Fruit, 1 Fat

Next
Chicken Waldorf Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Cran-Orange Oat Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cran-Orange Oat Muffins

Ingredients:
1-1/4 cups unbleached flour
1-1/4 teaspoons baking powder
3/4 teaspoon baking soda
1/4 teaspoon lite (or regular) salt
2 tablespoons dried ground orange rind
2/3 cup fruit-sweetened whole cranberry sauce
1/4 cup orange or tangerine juice concentrate
3/4 cup apple juice concentrate
1/3 cup all fruit orange marmalade
Two egg whites
2-1/2 to 3-tablespoons olive or safflower oil
1/4 cup water
1-1/2 cups thin-rolled (quick) oats

Directions:
Preheat oven to 350-degrees.

Sift together flour, baking powder, baking soda, and salt. Stir in orange rind, and set aside. In a separate bowl, lightly beat egg whites, and stir in all liquid ingredients. Pour liquid mixture over dry ingredients, and mix with a fork, just until moistened. Then gently fold in oats.

Fill muffin cups 3/4 full, and bake at 350-degrees for 18 to 23 minutes.

Muffins are done when a toothpick inserted comes out clean.

Let cool 10-15 minutes for non-stick removal of paper muffin cups. Serve warm or at room temperature, not refrigerated.

Recipe makes 12 muffins.

Serving Size: One muffin

Nutrition information per serving:
Calories: 167
Fat: 3.5g
Carbohydrate: 26g
Protein: 2g
Exchanges: 1 Starch/Bread, 1 Fat

Next
Pear Spice Muffins

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Crazy Carrots | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Crazy Carrots

Crazy Carrots

Ingredients:
2 pounds sliced carrots or small carrots
One can of (10-3/4 ounces) tomato soup
1-cup measurable sweetener or 24 packets
One medium onion, chopped
One green pepper, chopped
ѕ cup wine vinegar
Ѕ cup olive oil
1 teaspoon Worcestershire sauce
1 teaspoon salt
1 teaspoon pepper
1 teaspoon Dijon mustard

Directions:
Boil carrots until tender, drain.

Combine remaining ingredients and pour over carrots. Mix well.

Refrigerate in a covered container at least 12 hours.

Recipe makes 12 servings.

Nutrition information per serving:
Calories: 151
Protein: 2g
Total Fat: 10g
Carbohydrate: 16g
Cholesterol: 0mg
Sodium: 399mg
Fiber: 2g
Exchanges: 3 vegetable, 2 fat

Next
Stuffed Bell Peppers

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Creating A Diet Plan | Fitness and Freebies

Creating A Diet Plan

First and most important: Do NOT think of this as a "diet". Your goal is to develop a healthy and lifelong eating plan to help you take control of your diabetes, thereby contributing to your optimum health.

When first developing your dietary plan, consult with a registered dietitian. The two of you will consider a number of factors in determining a personal eating plan you can live with - happily. Other factors that should be addressed and taken into consideration in developing your meal plan are:
  • Lifestyle. Your work/school schedule and exercise habits - or lack of them!
  • Medication. Your dietitian will need to know what medications you are taking, the dosage and when the action of it reaches its peak.
  • Weight goals. Yes, the dreaded weight issue. Whether or not you need to lose weight, gain weight or maintain weight will be factored into your personal plan.
  • Medical condition. Any other medical conditions you may have need to be taken into consideration in determining what you should/can or should/cannot not eat.
  • Food preferences. You will be asked what kind of foods you enjoy and if you follow any specific diet such as vegetarian, low carbohydrate, etc.

Next
Break Down of the Meal Plan

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Apple Crisp with Honey | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Apple Crisp with Honey

Ingredients:
4 cups peeled and sliced apples
1 tablespoon lemon juice
1/3 cup flour
1 cup oats
1/2 cup honey
1/2 teaspoon salt
1 teaspoon cinnamon
1/4 cup margarine

Directions:
Spray pie pan with vegetable spray. Put apples in the pan. Sprinkle juice over apples. Mix all other ingredients together. Pour over apples.

In a small bowl stir together melted margarine, Worcestershire sauce, and curry powder. Drizzle margarine mixture over cereal mixture. Toss until coated.

Bake at 375-degrees for 30 minutes or until golden brown.

Recipe makes ten servings.

Next
Ants on a Log

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Curried Chicken Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Curried Chicken Salad

Source: "The New American Heart Association Cookbook"

Dressing Ingredients:
1/2 cup fat-free, cholesterol-free or light, reduced-calorie mayonnaise dressing
1 tablespoon fresh lemon juice
2 teaspoon rice vinegar or white vinegar
1/2 teaspoon curry powder
1/4 teaspoon salt
1/8 teaspoon pepper
1/8 teaspoon cayenne

Chicken Salad Ingredients:
Four ribs celery, chopped (2 cups)
Eight thin strips green bell pepper (optional)
4 cups cubed, cooked chicken, white meat only, skin and all visible fat removed (about 1-1/2 pounds boneless, skinless breasts)

Directions:
In a large bowl, whisk together dressing ingredients.

Stir in chicken and celery. Cover and refrigerate for at least 30 minutes.

To serve, garnish with bell pepper.

Recipe makes four servings.

Nutrition information per serving:
Calories: 202
Total Fat: 7g
Carbohydrate: 5g
Protein: 27g
Cholesterol: 83mg
Sodium: 342mg
Fiber: 1g
Exchanges: 1 Vegetable; 3 Low-Fat Meat

Next
Chicken Dijon Pasta Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Curried Snack Mix | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Curried Snack Mix

Curry and Worcestershire sauce spice up rice cakes, pretzels, and corn cereal in this low-fat snack mix.

Ingredients:
Three plain rice cakes, broken into bite-size pieces
1 cup bite-size square corn cereal or oyster crackers
3/4 cup pretzel sticks, halved (1 ounce)
1 tablespoon margarine, melted
1 teaspoon Worcestershire sauce
1/2 to 3/4 teaspoon curry powder

Directions:
In a 13x9x2-inch baking pan stir together broken rice cakes, corn cereal or oyster crackers, and pretzels.

In a small bowl stir together melted margarine, Worcestershire sauce, and curry powder. Drizzle margarine mixture over cereal mixture. Toss until coated.

Bake in a 300-degree oven for 20 minutes, stirring twice. Cool about 30 minutes before serving. If desired, store cooled mixture in a tightly covered container up to three days.

Recipe makes six (1/2-cup) servings.

Nutrition information per serving:
Calories: 72
Total Fat: 2g
Saturated Fat: .5g
Carbohydrate: 12g
Cholesterol: 0
Sodium: 144mg
Fiber: 1g
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1 Starch

Next
Apple Crisp with Honey

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Cinnamon Bread Pudding | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cinnamon Bread Pudding

Ingredients:
2 cups skim milk
4 tablespoons margarine cut into pieces
One egg
Two egg whites
3/4 cup measurable sweetener or 16 packets
1-1/2 teaspoons ground cinnamon
1/8 teaspoon ground cloves
Three dashes ground mace (optional)
1/4 teaspoons salt
4 cups cubed, day-old French or Italian bread (3/4-inch thick)

Directions:
Heat milk and margarine to simmering in medium saucepan; remove from heat and stir until margarine is melted. Cool ten minutes.

Beat egg and egg whites in large bowl until foamy; mix in sweetener, spices and salt. Mix milk mixture into egg mixture; mix in bread.

Spoon mixture into ungreased 1-1/2 quart casserole. Place casserole in roasting pan on oven rack; ad 1-inch hot water. Bake, uncovered, in preheated 350-degree oven until pudding is set and sharp knife inserted halfway between center and edge comes out clean, 40 to 45 minutes.

Recipe makes six servings.

Nutrition information per serving:
Calories: 202
Protein: 8g
Total Fat: 10g
Carbohydrate: 21g
Cholesterol: 37mg
Sodium: 422mg
Exchanges: Ѕ milk, 1 starch, 2 fat

Next
Chocolate Bread Pudding

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Diabetic Desserts | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Desserts Diabetic Desserts

Button Fruit Chiffon in a Chocolate Cookie Crust

Button Chocolate Silk Mousse

Button Pineapple Dessert

Button Chocolate Pineapple Dessert

Button Sour Cream Apple Dessert

Button Sugar Free Rugelach

Button Cheesecake Dainties

Button Pineapple Squares

Button Peanut-Butter Squares

Button Pears with Creamy Chocolate Sauce

Button Blueberry Grunt

Button Country Peach Tart

Button Bittersweet Chocolate Torte

Button Pumpkin Cheesecake

Button Pumpkin Cheesecake II

Button Chocolate Swirl Cheesecake

Button New York Cheesecake

Button No Bake Cheesecake

Button Best Pineapple Cheesecake

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Diabetes | Fitness and Freebies

Diabetes

History of Diabetes:
Diabetes is not new, in fact, it can be dated back to at least 1500 BC. Writings from ancient cultures in China and the Middle East describe the classic signs of diabetes, such as passing large quantities of urine through the body.

The ancient Greeks gave us the name diabetes, which means, "to flow through". Later, the Latin word mellitus, "Sweetened or honey-like" was added to form the present medical name of diabetes mellitus. Treatment pretty much consisted only of exercise, weight control and a special diet. Insulin did not come into the picture until 1921. The discovery of insulin was a major breakthrough in modern medicine as it literally saved millions of lives.

Today, diabetics have more choices and much better chances at living a long, normal and healthy life if they are willing to take charge of their diabetes. Medical science has made many advances to aid you, but you must take your condition very seriously and deal with it accordingly. Discuss treatments and diet with your doctor and learn how to apply the wonderful advances science has made for you to treat your diabetes.

Unfortunately, there is no cure for diabetes. You must deal with the condition for the rest of your life. Yes, this can seem daunting at first and unfair; however, with the right attitude and approach, you can live a long, healthy, prosperous life and avoid the complications of diabetes. One of the essential needs of diabetes is keeping blood sugar levels under control. This largely involves learning proper nutrition needs for your condition. It is the goal of this book to help you do just that.

Today, diabetics have more choices and much better chances at living a long, normal and healthy life if they are willing to take charge of their diabetes. Medical science has made many advances to aid you, but you must take your condition very seriously and deal with it accordingly. Discuss treatments and diet with your doctor and learn how to apply the wonderful advances science has made for you to treat your diabetes.

To your health!

Next
The Diabetic Diet

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Diabetic Diet | Fitness and Freebies

The Diabetic Diet

Did you know there's no such thing as a "diabetes diet" anymore? What's important is how food, especially the foods you like, impact your blood glucose levels. The more you know about nutrition, the more options you'll realize you have. When you make healthy choices, your body will feel its best and your blood glucose is more likely to be in control. So check out a food label, understand the Food Pyramid, and learn to carbohydrate count, so you can live a life without limits.

When you have diabetes, your body has trouble getting energy from the foods you eat. Therefore, it is important for you to know something about the nutritional value of food. You then use this knowledge to devise a meal plan that will provide proper nutritional value as well as keep your blood sugar in control.

Everyone should care about their nutritional needs and try to maintain a healthy diet. For starters, the U.S. Department of Health and Human Services for all people issued the following dietary guidelines:
  • *Eat a variety of foods.
  • *Maintain desirable weight.
  • *Avoid too much overall fat in your diet, particularly saturated fat and cholesterol.
  • *Eat foods with adequate starch and fiber.
  • *Avoid eating too much sugar.
  • *Avoid too much sodium (found in table salt). Avoid processed and "Fast Foods" with high salt content.
  • *If you drink alcoholic beverages, do so in moderation.
The diabetic needs to follow one more important guideline in addition to the above guidelines:

*Be extra careful about the foods you eat to keep your blood sugar in a normal range.

Next
Your Diet Strategy

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Chicken Dijon Pasta Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken Dijon Pasta Salad

Ingredients:
4 ounces rotini, uncooked
8 ounces plain low fat yogurt
1/3 cup wheat germ
3 tablespoons white wine vinegar
1 tablespoon Dijon mustard
1/8 teaspoon Black pepper
1 cup Chicken breast, cooked and diced
3/4 cup broccoli flowerets, diced
1/2 cup tomato, chopped and seeded
1/3 cup red onion, chopped

Directions:
Cook pasta according to package directions. In medium bowl, combine yogurt, wheat germ, vinegar, mustard and pepper; mix well.

Add pasta and remaining ingredients: toss to coat.

Serve immediately or chill before serving. Sprinkle with additional wheat germ before serving, if desired.

Recipe makes four servings.

Nutrition information per ј salad:
Calories: 260
Total Fat: 7g
Carbohydrate: 34g
Protein: 22g
Cholesterol: 35mg
Sodium: 342mg
Fiber: 1g
Exchanges: 1 lean-meat, 1 vegetable, 1 starch

Next
Chicken Salad Chinois

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Dips, Spreads and Sauces | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Jams and Jars Dips, Spreads and Sauces

Button Strawberry Jam
Button Strawberry Jiffy Jam
Button Fresh Tomato Ketchup
Button Mexican Bean Dip With Salsa
Button Chunky Applesauce
Button Maple Flavored Syrup
Button Linguine with Red Pepper Sauce
Button Easy BBQ Sauce
Button Broccoli and Bean Dip
Button Herb and Mustard Dressing
Button Low-Fat Ranch Dressing
Button Mustard Mushroom Vinaigrette
Button Apple-Cherry Chutney
Button Cranberry Cracker Spread
Button Sweet & Sassy Cherry Sauce
Button Roasted Red Pepper Dip
Button Chile Cheese Log
Button Creamy Garlic Dressing
Button Caesar Dressing
Button Basic Turkey Gravy
Button Low Fat Gravy
Button Fat Free Gravy
Button Chocolate Frosting
Button Chocolate Cream Cheese Frosting
Button Diabetic Frosting
Button Sugar Free Frosting
Button Chocolate Sauce

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

Fat Busters! | Low Cost Supplements

Back
Table of Contents


Dried Fruit Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Dried Fruit Salad

Ingredients:
Eight prunes pitted prunes
1/4 cup dried apricots
1 cup apple juice
1 cinnamon stick
1/2 teaspoon whole cloves
One banana, peeled and sliced
One large orange, peeled, sectioned, and cut bite-size
One apple, cored and chopped
1/2 cup orange juice
3 tablespoons of sugarfree orange marmalade (or eliminate if no sugar free available)
1/4 cup chopped pecans

Directions:
Combine prunes, apricots, apple juice, cinnamon stick, and cloves in saucepan. Bring to a boil, remove from heat and let soak overnight in refrigerator.

Remove the dried fruit and divide the prunes, apricots, banana, orange and apple among 4 dishes. Strain apple juice and add orange juice and orange marmalade. Mix together and pour over fruit. Top with chopped pecans.

Next
Green Beans and Fennel

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Dutch Apple Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Dutch Apple Pie

Ingredients:
1/4 cup fruit sweetener**
1/4 cup apple butter or unsweetened applesauce
One egg
2/3 cup flour
1/2 teaspoon baking powder
1/4 teaspoon salt
1 cup diced apples
1/2 cup chopped nuts

Directions:
Cream fruit sweetener and apple butter. Beat in egg.

Combine flour, baking powder, and salt. Blend into creamed mixture. Fold in apples and nuts.

Pour into an 8x8-inch pan which has been coated with cooking spray.

Bake for 15-20 minutes at 325-degrees.

**You can find commercial fruit sweeteners, ordinarily a combination of concentrated peach & pear juices and unsweetened pineapple syrup, in health food stores, gourmet food stores and large grocery outlets. It tastes 1-1/2 to 2 times sweeter than refined sugar.
You can also make your own fruit sweetener. For example, if a recipe calls for 1/2-cup fruit sweetener, you can substitute 1/4-cup concentrated apple juice and 1/4-cup granulated fructose.

Next
Apple Cranberry Streusel Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Personal Eating Style | Fitness and Freebies

Personal Eating Style

What, where, when and why you eat is really a very personal issue. We acquire our eating habits over many years and they can be very difficult to change - even when needed due to diabetes. You are not alone if you feel this way and this is understandable.

The key to your success is examining your current eating habits and making the necessary changes without compromising too much. Keep a food diary for one or two weeks - just do as you usually do. Record the four "'W's" you ate:

  1. What
  2. When
  3. Where
  4. Why

Take note of the times you find you ate more than you needed to, or ate "just because" etc. Ask yourself if you were really hungry or simply wanted to eat something because that is your habit? Say, watching TV or at a movie, etc. Ask your loved ones and friends to support and encourage you - maybe they already are! That is so very important.

Check with your dietitian about new ways to prepare foods that you enjoy. In addition, use home blood glucose monitoring results to learn how to incorporate foods you previously thought you could not eat.

Above all, take your time in making your dietary changes - baby steps I like to call it. You didn't develop your eating habits overnight and you cannot be expected to change them overnight. Be kind to yourself and do not place difficult demands on your back. After all, you have the rest of your life to put your new diet into practice! With proper medications and self-care, you can live a very long, normal life.

Next
Monitoring Your Glucose

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Holiday Eggnog | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Holiday Eggnog

Ingredients:
2 cups skim milk
2 tablespoons cornstarch
12 packets sweetener or 1/2-cup measurable sweetener of choice
2 eggs, beaten
2 teaspoons vanilla
1/4 teaspoon ground cinnamon
2 cups skim milk, chilled
1/8 teaspoon ground nutmeg

Directions:
Mix 2-cups milk, cornstarch and sweetener in small saucepan; heat to boiling. Boil one minute, stirring constantly.

Mix about half of milk mixture into eggs; return egg mixture to remaining milk in saucepan. Cook over low heat until slightly thickened, stirring constantly.

Remove from heat; stir in vanilla and cinnamon. Cool to room temperature; refrigerate until chilled.

Stir 2-cups chilled milk into custard mixture; serve in small glasses. Sprinkle with nutmeg.

Variation: Stir 1 to 1-1/2 teaspoons rum or brandy extract into eggnog, if desired.

Recipe makes eight servings.

Nutrition information per serving (4-ounces):
Calories: 79
Fat: 1g
Carbohydrate: 10g
Cholesterol: 55mg
Sodium: 79mg
Protein: 6g
Exchanges: 1 Milk

divider

Sugar Free Holiday Nog

Ingredients:
One package (.9 ounces) sugar-free instant vanilla pudding mix
7 cups skim milk, divided
1-1/2 teaspoon vanilla extract -or rum flavoring
Two to four packets sugar substitute
1 cup evaporated skim milk

Directions:
Combine pudding mix, 2-cups of milk, vanilla and sugar substitute in a bowl; mix according to pudding directions.

Pour into a half-gallon container with a tight-fitting lid.

Add 3-cups milk; shake well.

Add evaporated milk and shake.

Add remaining milk; shake well. Chill.

Recipe makes eight servings.

Back
Back to Main Contents

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Creamy and Cool Root Beer Drink | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Cheesy Baked Eggplant | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cheesy Baked Eggplant

A serving of this Cheesy Baked Eggplant provides an excellent source of calcium from the mozzarella cheese and a good source of vitamins A and C from the tomatoes. It is also low in cholesterol.

Ingredients:
One large eggplant , peeled and cut into 1/4-inch thick slices
1/2 cup Italian fat free dressing
Two tomatoes, thinly sliced
1-1/2 cups shredded reduced fat Mozzarella cheese
1 cup marinara sauce

Directions:
Coat eggplant slices with dressing. Arrange in single layer on cookie sheet. Broil four to six inches from heat eight minutes on each side or until lightly browned on both sides. Place eggplant slices in single layer in 13 x 9-inch baking dish. Cover with tomatoes; sprinkle with cheese. Top with sauce.

Bake at 350-degrees for 30 minutes until thoroughly heated.

Recipe makes four servings.

Nutrition information per serving:
Calories: 150
Total Fat: 6g
Saturated Fat: 3.5g
Cholesterol: 15mg
Sodium: 810mg
Carbohydrate: 15g
Fiber: 3g
Protein: 11g
Exchanges: 2 Vegetable, 1/2 Carbohydrate, 1 Meat

Next
Citrus Spinach & Rice Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Using an Exchange Meal Plan | Fitness and Freebies

Using an Exchange Meal Plan

Exchange meal plans have a lot of flexibility. In the Food Choice List, you can see the items listed are an indication of the variety of foods you may choose from for any given meal. For example, if your meal plan calls for one vegetable choice, you can exchange Ѕ-cup of broccoli for 1-cup of green beans. Note the portion value assigned to each item of the Food Choice List. These values have been calculated so that each item will provide you with equal amounts of calories and nutrients and will affect your blood sugar in a similar way. For that reason, you can interchange items within a food choice.

The meal plan works so well because it offers both flexibility and sameness. You have a wide range of food items for every choice. By sticking to the number of choices on your meal plan, you actually will be eating about the same amount of carbohydrate, protein and fat at each meal every day. This is extremely important in managing your diabetes. If you were to eat more than your meal plan allows, you will have too much sugar in your bloodstream for the insulin to handle which, of course, raises your blood sugar. If you do not eat enough, you will have too much insulin and your blood sugar will drop. To keep your blood sugar in normal range, it is imperative you keep your food intake nearly the same from one day to the next. There is one exception to this: Those who follow an intensive diabetes therapy program in which the medication is adjusted on a daily basis in response to blood sugar testing results.

It is very important you eat your meals at the same time everyday (unless you are using intensive diabetes therapy, you then may have more flexibility in the timing of your meals). This may take some adjustment on your part depending on your eating habits prior to discovering you have diabetes. When you did not have diabetes, your pancreas maintained your blood sugar for you - now you have to. You no longer have a precise, automatic system to handle the sugar in your blood. If you are taking insulin, the dose prescribed by your doctor usually consists of a combination of various types. Each type has these features:
  • Onset - the period of time insulin takes to begin working.
  • Peak activity - when insulin is most effective.
  • Duration - the length of time of insulin's activity, including its tapering off time.

Next
Some Common Misunderstandings of the Exchange Meal Plan

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Fat | Fitness and Freebies

Fat

The third nutrient your body needs is fat.

And your body does need fat! Fat, in over-indulgence, especially in the "bad" fats IS bad, but we do require fat for overall good health.

Fat is an oily, greasy material. Fat is found in either solid or liquid form. It is prevalent in marbled meat, dairy products such as whole milk, butter and cheese, margarine and vegetable oils such as corn, sunflower and olive oil.

The body in a number of ways uses fat.

Fat is important for maintaining healthy skin and hair. Fat also serves as a "vehicle" to carry fat-soluble vitamins throughout your body.

In addition, the body changes fats into fatty acids - an important source of energy for the muscles and heart.

Fat is also used to store energy. Any extra calories produced from the carbohydrates, protein or fat that your body does not use immediately are stored in the body as body fat (adipose tissue).

Next
Fat and Cholesterol

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Diabetes Food Pyramid | Fitness and Freebies

Diabetes Food Pyramid

The Diabetes Food Pyramid has six sections for food groups. They vary in size. The largest group -- grains, beans, and starchy vegetables -- is on the bottom. This means that you should eat more servings of grains, beans, and starchy vegetables than of any of the other foods. The smallest group -- fats, sweets, and alcohol -- is at the top of the pyramid. This tells you to eat very few servings from these food groups.

On average Americans eat around 40 to 45 percent of our calories as carbohydrate. This is a moderate amount of carbohydrate, not high. A few new diet books encourage a low carbohydrate, high protein and moderate fat intake. These diets are not in synch with the American Diabetes Association nutrition recommendations, which are based on years of research and clinical experience. In addition, these trendy diets are hard to follow year after year.

Vegetables:
For people with diabetes, it’s "the more the merrier" when it comes to vegetables. Eat at least three servings a day. Vegetables are healthy, chock full of vitamins and minerals, and some give you much needed fiber. The best part: Vegetables are naturally low in calories -- if you are careful not to top them with butter, sour cream, cream soups, or cheese sauces. Remember, non-starchy vegetables (those in this food group) do contain a small amount of carbohydrate -- 5 grams per serving. Don’t get too carried away, you can even overeat vegetables.

Fruit:
Eat some fruit each day for vitamins and minerals. Be honest with yourself about your serving sizes. It is easy to drink a few extra ounces of fruit juice or to call a huge piece of fruit 1 serving when it is at least 2. The steps to take to track your response to fruit are: Check the serving size, eat your fruit, and check your blood glucose level about 1&1/2 to 2 hours later. Use blood glucose monitoring to answer your questions about how fruit works in your body.

Milk and Diabetes
People with diabetes are at the same risk for osteoporosis as the general public. Fat-free (skim) and low-fat (1%) milk and yogurt will provide the calcium you need without saturated fat and cholesterol. A serving of milk or yogurt can be used as a snack or part of a snack -- milk and crackers or yogurt and fruit. Also, you might find that fat-free milk or yogurt makes a good food to treat low blood glucose reactions. They both provide as much carbohydrate as a serving of starch or fruit.

Meat, Poultry, Seafood, Cheese, Eggs, Etc. and Diabetes
People with diabetes have no less or more need for protein than the general public. The American Diabetes Association nutrition guidelines suggest eating between 10 and 20% of your calories as protein. The Recommended Daily Allowance (RDA) for protein is 0.8 grams per kilogram of body weight. People with diabetes have a greater risk of heart disease earlier in life. One of the most important nutrition guidelines to follow is "eat less saturated fat". A quick way to do that is to cut down on animal protein foods -- meats, whole milk dairy foods, and high-fat cheeses (such as cheddar, brie, or American). If you cut down on animal protein, you can be pretty sure you will automatically be cutting down on saturated fat, and cholesterol as well.

Protein
A way to make small servings of protein appear larger is to incorporate them into an entree such as low-fat ground beef or turkey sausage in a tomato sauce served over pasta. For ideas, take lessons from cultures that have long practiced making a small amount of protein feed many mouths -- Chinese stir-fry, Mexican burritos, or Japanese sukiyaki. This accomplishes several pyramid goals -- less meat, less fat, more starches and more vegetables. From time to time, take these recipes one step further and eliminate meat all together.

Fat and Diabetes
Fat ought to make up about 30% of your calories. One of the most important diabetes nutrition guidelines is to hold saturated fat to 10% of calories. Why? Because saturated fat raises blood cholesterol. High blood cholesterol is a risk factor for heart disease. People with diabetes have more frequent heart disease. Limiting saturated fat could lower your risk for this diabetes complication. Also, some people with abnormal blood lipids (fat) and a high triglyceride might benefit from increasing the amount of monounsaturated fats they eat. As for cholesterol, keep it to 300mg or less each day. Some foods high in cholesterol are egg yolks and organ meats (liver or kidney).

Sugar and Diabetes
Research studies show that, gram for gram, sugars, like table sugar, do not raise blood glucose any more quickly than do other carbohydrates, like potatoes, rice or pasta. This research holds true for people with both types of diabetes. A variety of factors influence how quickly food is digested. A meal with a large amount of fat or fiber, lots of raw foods that take more time to digest, and eating slowly will help keep your blood glucose level on track. The blood glucose level at the time you eat and how much diabetes medication is in your body has a major impact, too. If and when you choose to eat sweets, according to your individual diabetes and nutrition goals, substitute these foods for other carbohydrates in your meal plan. Recall the nutrition message for all Americans, it is the same for people with diabetes
-- "Choose a diet moderate in sugars".

Summary:
Eat servings from all the food groups other than the fats, sweets, and alcohol, every day. Eat the recommended number of servings on the pyramid within each food group. The exact number of servings you need depends on your diabetes goals, calorie and nutrition needs, your lifestyle, and the foods you like to eat. Divide the number of servings you should eat among the meals and snacks you’re going to eat that day. The Diabetes Food Pyramid makes it easier to remember what to eat. For a healthy meal plan that is based on your individual needs, you should work with a registered dietitian (RD) with expertise in diabetes management.

Next
Nutrition Facts for Diabetics

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Fitness Shake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fitness Shake

Ingredients:
2 cups skim milk
2 medium-size ripe bananas, cut into l-inch pieces
1/2 cup fat-free plain or banana yogurt
1/2 cup nonfat dry milk powder
1/3 cup wheat germ
1 teaspoon vanilla
8 packets sweetener or 1/3-cup measurable sweetener of choice
Ground cinnamon (optional)

Directions:
Process all ingredients, except cinnamon, in blender or food processor until smooth. Pour into glasses and sprinkle with cinnamon, if desired.

Recipe makes four (8-ounce) servings.

Nutrition information per serving:
Calories: 190
Fat: 2g
Carbohydrate: 33g
Cholesterol: 4mg
Sodium: 134mg
Protein: 12g
Exchanges: 1-1/2 Milk, 1 Fruit, 1/2 Fat

Next
Fresh Limeade

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Berry Apricot Frappe | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Berry Apricot Frappe

Ingredients:
2 cups orange juice
1 cup ice
Ѕ cup frozen strawberries or raspberries
Ѕ cup canned apricots, drained
Ѕ cup fat-free plain yogurt
2 tablespoons wheat germ
Four packets artificial sweetener of choice

Directions:
In a blender, mix all ingredients for a refreshing treat that everyone will love. Recipe makes two servings.

Nutrition information per serving:
Calories: 200
Protein: 7g
Carbohydrate: 43g
Fat: 1g
Cholesterol: 1mg
Sodium: 47mg
Food exchanges: 1 milk, 2 fruit

Next
Lemonade

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Chocolate Frosting | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Frosting

Ingredients:
1 envelope Dream whip
1/2 teaspoon vanilla
1/2 cup milk
1 package Sugarfree chocolate pudding (2 ounces)

Directions:
Blend together skim milk, vanilla, and dream whip (or sugarfree whipped topping mix). Beat til stiff. Add pudding mix and continue to beat til light and fluffy. Add more milk if too thick.

Exchange: 1/2 Fat

Next
Chocolate Cream Cheese Frosting

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Chocolate Cream Cheese Frosting | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Cream Cheese Frosting

Ingredients:
Two packages (8 ounces each) fat-free cream cheese, at room temperature
24 packets sweetener or 1-cup measurable sweetener
2 to 3 tablespoons skim milk
1/2 cup European or Dutch-process cocoa
1 teaspoon vanilla

Directions:
Beat cream cheese, sweetener and 1-tablespoon milk in small bowl until fluffy. Beat in cocoa, vanilla and enough remaining milk to make spreading consistency.

Makes about 2 cups (enough to frost 2-layer cake).

Nutrition information per serving (2-1/2 tablespoons):
Calories: 51
Protein: 6g
Carbohydrate: 5g
Fat: 0g
Cholesterol: 7mg
Sodium: 229mg
Food Exchanges: 1/2 Milk

Next
Diabetic Frosting

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Diabetic Frosting | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Diabetic Frosting

Ingredients:
1-1/2 cup light or fat free cream cheese
1-1/2 tablespoons soft butter or margarine
16 packets sweetener
2 teaspoons vanilla

Directions:
Beat all ingredients together until smooth; thin with 1 to 2-tablespoons of 1% milk if needed.

Frosts two, 9-inch round cake layers or two-dozen cup cakes.

Next
Sugar Free Frosting

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Sugar Free Frosting | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Sugar Free Frosting

Ingredients:
1 (1.4 ounce) package sugar-free instant pudding mix
1-3/4 cups milk
1 (8 ounce) package fat free cream cheese
1 (8 ounce) container lite or fat free frozen whipped topping, thawed

Directions:
In a medium bowl, combine pudding mix and milk. Mix well and let stand until thickened.

In a large bowl, beat cream cheese until smooth. Add pudding and mix well. Finally, fold in whipped topping.

Next
Chocolate sauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Frozen Fruit Cups | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Frozen Fruit Cups

Ingredients:
1 cup sliced fresh strawberries
Two slices juice-packed canned pineapple, chopped
One medium banana, peeled and chopped
Three 8-ounce cans sugar-free orange soda

Directions:
In a small bowl, combine the strawberries, pineapple, and banana. Spoon an equal amount into each of six 6-ounce paper cups.

Pour 1/2-cup of the soda over the fruit in each cup and freeze until firm. Let stand at room temperature for a few minutes before serving to partially thaw. Eat with a spoon.

Recipe makes six servings.

Nutrition information per serving:
Calories: 36
Total Fat: trace
Saturated Fat: 0g
Carbohydrate: 9g
Cholesterol: 0mg
Sodium: 17mg
Fiber: 1g
Protein: trace
Calories from fat: 5%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1/2 carbohydrate (1/2 fruit)

Next
Popcorn Treat

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Creamy Garlic Dressing | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Creamy Garlic Dressing

Ingredients:
1/2 cup evaporated skim milk
2 tablespoons fresh lemon juice
2 large garlic cloves, minced
1/4 teaspoon salt
1 teaspoon dried dill weed
1 teaspoon frozen apple juice concentrate
1/4 teaspoon paprika
1/4 teaspoon white pepper
Two dashes sesame oil
Dash red (cayenne) pepper

Directions:
Place all ingredients in a blender and process until smooth. Chill before serving. Makes about 3/4-cup.

Recipe makes 12 (1 tablespoon) servings.

Nutrition information per serving:
Calories: 11
Protein: 1g
Carbohydrates: .2g
Cholesterol: 0mg
Sodium: 50mg
Dietary Exchanges: Free Food

Next
Caesar Dressing

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Graham Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Graham Muffins

Ingredients:
1-1/3 cups finely crushed low fat graham crackers
1-1/4 cups all-purpose flour
1/2 cup sugar
1 teaspoon baking powder
3/4 teaspoon baking soda
One egg, beaten
1 cup milk
1/3 cup cooking oil
1/2 cup chopped pecans
Pecan pieces

Directions:
Grease 16 muffin cups or line with paper bake cups; set aside.

In a medium mixing bowl combine graham crackers, flour, sugar, baking powder, and baking soda. Make a well in the center of the dry ingredients.

Bake these muffins immediately or store batter in refrigerator up to 24 hours. In a bowl combine egg, milk, and oil. Add all at once to dry ingredients. Stir just until moistened. Stir in chopped nuts.

Fill muffin cups 2/3 full. Place a pecan piece atop each. Bake in a 375-degree oven for 15 to 18 minutes or until golden. Remove from cups.

Make-Ahead Tip: Store batter tightly covered in the refrigerator for up to 24 hours. Stir batter; fill muffin cups as above. Bake muffins about 20 minutes.

Recipe makes 16 muffins.

Nutritional information per muffin:
Calories: 171
Protein: 3g
Fat: 9g
Fiber: 2g
Carbohydrate: 20g
Cholesterol: 18mg
Sodium: 130mg

Next
Banana Bread

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Peanut Butter Granola | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter Granola

Ingredients:
3 cups rolled oats
1/2 cup wheat germ
1/2 cup creamy peanut butter
1-1/2 tablespoons light brown sugar
1/3 cup dark raisins

Directions:
Preheat oven to 300-degrees.

In a medium bowl, combine oats and wheat germ.

Place peanut butter and brown sugar in a microwave-safe dish. Mix well. Microwave on high for 20 seconds, until warm. Stir again.

Pour peanut butter mixture over the cereal and toss to evenly coat. Stir in raisins. Spread evenly in a baking pan and bake for 20 minutes, stirring once.

Cool before serving to eat out of hand. Store any leftover granola in self-sealing plastic bags with eat within two days.

Recipe makes six servings.

Nutrition information per serving:
Calories: 345
Total Fat: 14g
Saturated Fat: 2.9g
Carbohydrate: 46g
Cholesterol: 0mg
Sodium: 104mg
Fiber: 7g
Protein: 14g
Calories from fat: 34%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1 medium fat protein, 3 carbohydrate (2-1/2 bread/starch, 1/2 fruit), 1 fat

Next
Snacking Granola

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Snacking Granola | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Snacking Granola

Ingredients:
Refrigerated butter-flavored cooking spray
4 cups rolled oats
1 cup wheat germ
1/2 cup unsweetened coconut
2 tablespoons dry-roasted sunflower seeds
3 tablespoons reduced-fat margarine
2 tablespoons light brown sugar
1 1/2 teaspoons ground cinnamon
1/4 cup slivered almonds, toasted
3/4 cup diced dried mixed fruit

Directions:
Preheat oven to 300-degrees. Lightly coat a large baking pan with cooking spray. Combine oats, wheat germ, coconut, and sunflower seeds.

Melt margarine in a small saucepan and stir in brown sugar and cinnamon. Stir until sugar dissolves. Pour over oat mixture and stir in almonds. Spread mixture over the bottom of the prepared pan and bake, stirring frequently, for 20 to 25 minutes, until golden brown.

Remove from oven and let cool. Stir in dried fruit and store in jar with tight-fitting lid until ready to serve.

Recipe makes 24, 1/3-cup servings.

Nutrition information per serving:
Calories: 113
Total Fat: 2g
Saturated Fat: 0.4g
Carbohydrate: 17g
Cholesterol: 0mg
Sodium: 23mg
Fiber: 2g
Protein: 4g
Calories from fat: 23%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1 carbohydrate (bread/starch)

Next
Pizza Pockets

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Basic Turkey Gravy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Basic Turkey Gravy

Ingredients:
One package neck, heart, gizzard from turkey giblets
1 medium carrot thickly sliced
One medium onion thickly sliced
One medium celery rib thickly sliced
1/2 teaspoon salt
One turkey liver
3 tablespoons fat from poultry drippings
3 tablespoons all-purpose flour
1/2 Teaspoon salt

Directions:
In a 3-quart saucepan, over high heat, place neck, heart, gizzard, vegetables, and salt in enough water to cover. Heat to boiling. Reduce heat to low; cover and simmer 45 minutes.

Add liver and cook 15 minutes longer. Strain both into a large bowl; cover and reserve broth in the refrigerator.

To make gravy, remove the cooked turkey and roasting rack from the roasting pan. Pour poultry drippings through a sieve into a 4-cup measuring cup.

Add 1-cup giblet broth to the roasting pan and stir until the crusty brown bits are loosened; pour the deglazed liquid/broth into the 4-cup measure. Let the mixture stand a few minutes, until the fat rises to the top.

Over medium heat, spoon 3-tablespoons fat from the poultry drippings into a 2-quart saucepan. Whisk flour and salt into the heated fat and continue to cook and stir until the flour turns golden.

Meanwhile, skim and discard any fat that remains on top of the poultry drippings. Add remaining broth and enough water to the poultry drippings to equal 3-1/2 cups. Gradually whisk in warm poultry drippings/broth mixture. Cook and stir, until gravy boils and is slighty thick.

Recipe provides 14 servings at 1/4-cup per serving.

Nutrition information per serving:
Calories: 47
Protein: 1g
Sodium: 193
Fat: 3g
Carbohydrates: 4g
Cholesterol: 4mg

Next
Low Fat Gravy

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Low Fat Gravy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Low Fat Gravy

Ingredients:
1/2 cup finely chopped onion
1/2 cup finely chopped fresh mushrooms
2 tablespoons chopped fresh parsley
2 cups reduced-sodium fat-free beef OR chicken broth, divided
2 tablespoons cornstarch
Pinch pepper

Directions:
In a saucepan, saute onion, mushrooms and parsley in 1/4-cup broth until vegetables are tender. Combine cornstarch, pepper, and 1/2-cup of broth; stir until smooth. Add to pan with the remaining broth. Bring to a boil, stirring occasionally; boil for two minutes.

Nutrition information per 1/4-cup serving:
Calories: 19
Sodium: 28mg
Cholesterol: 2g
Carbohydrate: 3g
Protein: 1g
Fat: 1g

Next
Fat-Free Gravy

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Fat-Free Gravy | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fat-Free Gravy

Ingredients:
1 cup fat free chicken broth or your own de-fatted drippings
2 tablespoons flour
1 teaspoon cornstarch
1 teaspoon ketchup
Pinch salt
Pinch pepper
Pinch basil or sage

Directions:
Combine broth, flour and cornstarch in a screw-top jar, cover and shake until well combined or use a blender for a larger batch. Pour into saucepan, stir in ketchup, salt, pepper and basil for beef (or sage for turkey, or other herb of your choice). Stir-cook over medium heat until gravy thickens.

Serve over meat or potatoes.

Recipe makes about 1-cup gravy.

Nutrition information per 1/4-cup serving:
Calories: 16
Carbohydrate: 3g
Protein: 1g

Next
Chocolate Frosting

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Green Beans and Fennel | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Green Beans and Fennel

Chopped, fresh fennel offers the delightful crunch of celery, but with a subtle licorice flavor. To crush fennel seeds, place them on a cutting board, then roll over them with a rolling pin.

> Ingredients:
2 tablespoons butter (no substitutes), softened
1-1/2 teaspoons fennel seeds, crushed
1-1/2 teaspoons finely shredded lemon peel
3/4 teaspoon ground black pepper
1/4 teaspoon salt
3 fennel bulbs (3 pounds)
1-3/4 pounds fresh green beans, trimmed if desired

Directions:
Stir together butter, fennel seeds, lemon peel, pepper, and salt.

Cut off and discard upper stalks of fennel bulbs. Remove any wilted outer layers; cut off a thin slice from the fennel base. Wash fennel; cut into quarters. Remove cores. Cut fennel lengthwise into 1/4-inch-wide strips.

Place beans in a 4-quart Dutch oven. Cook beans, covered, in a small amount of boiling salted water 4 to 5 minutes. Add fennel strips to beans. Cook 6 to 10 minutes more or until vegetables are crisp-tender. Drain. Toss fennel and beans in the bowl with the seasoned butter. Transfer to a serving dish.

Recipe makes 10 to 12 servings.

Nutrition information per serving:
Calories: 67
Total Fat: 3g
Saturated Fat: 2g
Cholesterol: 7mg
Sodium: 124mg
Carbohydrate: 10g
Fiber: 5g
Protein: 2g
Exchanges: 2 Vegetables, .5 Fat

Next
Nutty Apple Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Hearty Italian-Style Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Hearty Italian-Style Soup

Ingredients:
Two, 14-1/2-ounce cans reduced-sodium chicken broth or beef broth
Dash garlic powder
1/4 teaspoon pepper
One, 15- or 19-ounce can white kidney beans, rinsed and drained
1-1/2 cups chopped cooked lean chicken or beef (8 ounces)
2 cups shredded cabbage
One, 14-1/2-ounce no salt added diced tomatoes, not drained
Two medium potatoes, (peeled, if desired), cubed
1/2 cup chopped carrot
1/2 cup sliced celery
1/2 cup chopped onion
1/4 cup snipped fresh parsley
1 teaspoon dried Italian seasoning, crushed

Directions:
In a large saucepan or Dutch oven combine broth, cabbage, undrained tomatoes, potatoes, carrot, celery, onion, parsley, Italian seasoning, pepper, and garlic powder. Bring to boiling; reduce heat. Simmer, covered, about 20 minutes or until vegetables are tender.

Stir in the beans and beef or chicken. Cook and stir for two to three minutes or until heated through.

Serve immediately or divide among six airtight containers or freezer containers. Store up to three days in the refrigerator or one-month in freezer. Heat to boiling before serving.

Beat egg whites until foamy; stir into soup. Reduce heat to a simmer and cook until foamy. Ladle soup into individual bowls and garish with parsley. Serve hot.

Recipe makes six servings.

To tote for a hearty and healthy lunch:
Transfer hot soup to a preheated insulated vacuum bottle. (To preheat the bottle, fill with hot tap water. Cover with lid; let stand about five minutes. Pour out water and immediately fill with the hot soup.) If using chilled soup, transfer to a small saucepan. Heat just to boiling, stirring often. Reduce heat. Simmer, covered, for three minutes. Transfer to preheated bottle.

Nutrition information per serving:
Calories: 173
Fat: 2g
Cholesterol: 30g
Sodium: 539mg
Carbohydrate: 25g
Protein: 19g
Fiber: 6g
Exchanges: 1-1/2 Starch, 2 Lean Meat, 1 Vegetable

Next
Chili-Bean Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Herb and Mustard Dressing | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Herb and Mustard Dressing

Ingredients:
1/4 cup water
3 tablespoons balsamic or cider vinegar
1-1/2 tablespoons Dijon mustard
1 tablespoon olive oil
1 teaspoon dried basil leaves
1 teaspoon dried thyme leaves
1 teaspoon dried rosemary
One small clove garlic, minced

Directions:
In small jar with tight-fitting lid, combine all ingredients; shake well. Refrigerate until ready to use; shake before serving.

Meanwhile, steam broccoli florets in microwave until very tender, about two minutes. Rinse with cold water to stop cooking; drain. Transfer to blender or food processor.

Recipe makes about 2/3-cup.

Nutrition information per 1/4-cup serving:
Calories: 45
Fat: 3g
Saturated Fat: <1g
Calories from fat: 62%
Protein: <1g
Carbohydrates: 4g
Cholesterol: <1mg
Sodium: 28mg
Fiber: <1g
Dietary Exchanges: Free Food

Next
Low-Fat Ranch Dressing

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Herbs for Your Health | Fitness and Freebies

Herbs for Your Health

Perhaps you've heard of the benefits of using herbs to flavor foods instead of adding salt, sugar or fat. I am a big advocate of this because I do it and it works!

Herbs will not add calories to your meal and will not increase your risk for diseases like cancer, hypertension or heart disease. In fact, using herbs may even provide a health benefit, especially for those with diabetes. Herbs such as rosemary, parsley, tarragon, basil, thyme and dill are plants that contain phytochemicals and are currently being studied for cancer-fighting potential similar to ingredients found in fruits, vegetables and whole grains.

In addition, some herbs may contain antioxidants. Antioxidants help prevent damage to cells caused by free radicals. Free radicals are compounds produced by the body as a result of illness, excessive exposure to sunlight and certain chemicals. Free radicals are involved in the aging process, inflammation and rheumatoid arthritis. Oregano and rosemary are herbs that are high in antioxidants. Rosemary has also been used as a natural food preservative to help keep fats, oils and meat products from going rancid. Other herbs with antioxidant properties include basil, marjoram, sage, thyme, spearmint and peppermint.

Here are some easy ways to add those healthful herbs to the foods you eat:
  • Sprinkle pizza with oregano, basil, marjoram, thyme or parsley
  • Add a mixture of herbs (oregano, basil and marjoram) to marinara sauce
  • Steam fresh vegetables with rosemary
  • Add chopped mint to fresh fruit
  • Mix herbs into a favorite casserole or salad for extra flavor
  • Make herbal teas using spearmint or peppermint
  • Top seafood with dill and parsley

Remember to add herbs to your diet! They may offer a lot more than flavor!

Next
Alcohol and Diabetes

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Dedicated to the Diabetic Diet eBook | Fitness and Freebies

Dedicated to the

Diabetic Diet

Enter Gate

Table of Contents

To Your Health!
Fitness and Freebies

Disclaimer: This E-book is not meant to replace or give specific medical advice. It is meant solely to help one cope the dietary adjustments for diabetes. Specific medical problems or concerns MUST be dealt with by your doctor or other medical care professional.


Strawberry Jam | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Strawberry Jam

Ingredients:
4 cups strawberries, halved
1/2 cup concentrated white grape juice (simmered down from 1-1/2 cups)
2-1/2 tablespoons lemon juice
1/4 ts grated lemon rind
1-1/2 tablespoon unflavored gelatin (1-1/2 envelops)

Directions:
Place berries juices and lemon rind in saucepan. mash berries slightly to release juice. heat to boiling. Sprinkle with unflavored gelatin. Remove from heat, skim and pack into hot jars with hot lids. cool to room temperature before freezing. Because this is stored in the freezer, you may use any airtight, leakproof freezer container for storage, even plastic containers.

Tastes better if allowed to sit for a week and freezes beautifully for up to six months.

Next
Strawberry Jiffy Jam

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Strawberry Jiffy Jam | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Strawberry Jiffy Jam

Ingredients:
2 cups strawberries
1 cup cold water
1 (3 ounce) package strawberry flavored gelatin, sugar free

Directions:
In a large saucepan crush strawberries. Add water and gelatin, mixing well. Over medium heat bring mixture to boiling, stirring constantly.

Reduce heat to low and simmer for two minutes. Pour into jars, allow to cool and then cover.

Can be stored in refrigerator for one week, or frozen for several weeks.

Next
Fresh Tomato Ketchup

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Fresh Tomato Ketchup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

This spicy ketchup is easy to make -- and you control the salt.

Fresh Tomato Ketchup

Ingredients:
4 pounds very ripe tomatoes, peeled, seeded, and coarsely chopped
One large onion, 8 ounces, chopped
Two large cloves garlic, minced
2/3 cup dark cider vinegar
2 tablespoons dark brown sugar
1/2 teaspoon crushed dried red pepper flakes
1 large bay leaf, broken in half
1 1/2 teaspoons salt (optional)
1 teaspoon ground cinnamon
1 teaspoon paprika
3/4 teaspoon ground mustard
1/2 teaspoon ground coriander
1/4 teaspoon ground allspice
Dash ground cloves
Dash cayenne pepper
Freshly ground pepper to taste

Directions:
Place all ingredients in a large nonreactive pot. Stir and bring to a boil over medium high heat. Lower heat to simmer and continue to cook, partially covered, for one hour, stirring often. Remove and discard the bay leaf halves.

Working in batches, transfer the tomato mixture to a food processor or blender. Process until smooth. Return to the pot and continue to simmer, uncovered, until thickened, about 15 to 20 minutes. Stir frequently to prevent scorching on the bottom.

Ladle the mixture into three half-point sterilized canning jars. Wipe the rims and set the kids, screwing on the bands loosely. Let cool at room temperature until lids are sealed (compressed). Tighten the bands and refrigerate for up to six months.

Recipe makes about 1-1/2 pints.

Nutrition information per 1/4-cup serving:
Calories: 49
Calories from fat: 10%
Protein: 2g
Total Fat: 1g
Saturated Fat: 0.1g
Carbohydrate: 11g
Fiber: 2g
Cholesterol: 0
Sodium: 17mg
Exchanges: 2 vegetable

Next
Mexican Bean Dip

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Key Lime Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Key Lime Pie

Ingredients:
1 cup honey
1/4 cup flour
3 tablespoons corn starch
2 cups water
Three large eggs, seperated
1 tablespoons margarine
1/4 cup fresh lime juice grated rind of one lime
1 9-inch pie shell, baked

Directions:
Combine honey, flour, and cornstarch in saucepan and gradually stir in water.

Cook stirring constantly until thickened. Gradually stir mixture into beaten egg yolks, return to low heat and cook, stirring, two mintutes. Stir in margarine, lime juice, and lime rind and cool. Pour into pie shell.

Recipe makes eight servings.

Next
Nectarine and Berry Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Kiwi Yogurt | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Kiwi Yogurt

Ingredients:
3 cups vanilla nonfat yogurt
Two kiwi fruits, peeled
1/4 cup fresh lime juice

Directions:
Divide the yogurt between eight dessert dishes.

Quarter the kiwi fruits, then slice crosswise. Toss with the lime juice.

Place four to five kiwi pieces atop each serving. Serve at once.

Next
Yogurt Popsicles

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Coffee Latte | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Coffee Latte

Ingredients:
1-1/4 cup regular grind espresso or other dark coffee roast
One cinnamon stick, broken into pieces
6 cups water
1/3 cup measurable sweetener or eight packets
2-1/2 cup skim milk
Ground cinnamon or nutmeg

Directions:
Place espresso and cinnamon stick in filter basket of drip coffee pot; brew coffee with water. Stir in sweetener, pour into eight mugs or cups.

Heat milk in saucepan until steaming. Process half the milk in blender at high speed until foamy, about 15 seconds; pour milk into four mugs, spooning foam on top. Repeat with remaining milk and coffee. Sprinkle with cinnamon or nutmeg before serving.

Recipe makes eight servings.

Nutrition information per 8-ounce serving:
Calories: 31
Protein: 3g
Carbohydrates: 5g
Fat: 0
Cholesterol: 1mg
Sodium: 46
Food exchange: Ѕ milk

Next
Berry Apricot Frappe

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Lemonade | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Lemonade

Lemonade

Ingredients:
7.5 ounces 100% pure lemon juice from concentrate* or fresh-squeezed lemons
3/4 cup measurable sweetener or 18 packets
4 cups cold water
Ice cubes

Directions:
*Such as Minute Maid Premium Lemon juice (frozen), 100% Pure Lemon Juice from Concentrate

Mix lemon juice and sweetener in a large pitcher; stir to dissolve sweetener. Add water; blend well.

Serve over ice.

Recipe makes six servings.

Nutrition information per serving:
Calories: 20
Protein: 0g
Carbohydrate: 6g
Fat: 0g
Cholesterol: 0mg
Sodium: 6mg
Food exchanges: 1/2 fruit

Next
Blushing Hot Spiced Cider

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Easy Lemon Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Easy Lemon Pie

Ingredients:
One large package of sugar free vanilla pudding
2-1/2 cups of skim milk
1 tub of Crystal Light lemonade
One large container of fat-free whipped topping
Two reduced fat graham cracker crusts

Directions:
Make pudding with 2-1/2 cups milk. Add Crystal Light and whipped topping; divide evenly between pie shells.

Recipe makes 16 servings (eight per pie).

Next
Dutch Apple Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Equal Lemon Meringue Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Equal Lemon Meringue Pie

Ingredients:
Reduced-Fat Pie Pastry or favorite pastry for 9-inch pie
2-1/4 cups water
1/2 cup lemon juice
10-3/4 teaspoons Equal for Recipes or 36 packets Equal Sweetener*
1/3 cup plus 2-tablespoons cornstarch
Two eggs
Two egg whites
1 teaspoon finely grated lemon peel (optional)
2 tablespoons margarine
1 to 2 drops yellow food color (optional)
Baked 9-inch pie shell
Three egg whites
1/4 teaspoon cream of tartar
3-1/2 teaspoons Equal for Recipes or 12 packets Equal® Sweetener

* Equal Spoonful cannot be used in meringue recipes.

Directions:
Mix water, lemon juice, 10-3/4-teaspoons Equal for Recipes and cornstarch in medium saucepan. Heat to boiling over medium-high heat, stirring constantly; boil and stir one minute. Beat eggs and two egg whites in small bowl; stir in about 1/2 the hot cornstarch mixture. Stir this egg mixture into remaining cornstarch mixture in saucepan; cook and stir over low heat one minute. Remove from heat; add margarine, stirring until melted. Stir in food color. Pour mixture into baked pie shell.

Beat three egg whites in medium bowl until foamy; add cream of tartar and beat to soft peaks. Gradually beat in 3-1/2-teaspoons Equal® Measure, beating to stiff peaks. Spread meringue over hot lemon filling, carefully sealing to edge of crust to prevent shrinking or weeping. Bake pie in preheated 425-degree oven until meringue is browned, about five minutes. Cool completely on wire rack before cutting.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 223
Total Fat: 10g
Carbohydrates: 29g
Cholesterol: 53mg
Protein: 6g
Sodium: 223mg
Exchanges: 2 Bread, 2 Fat

Next
Easy Lemon Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Lemon Meringue Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Lemon Meringue Pie

Ingredients:
Your favorite 8-9-inch pie crust brushed with egg whites, baked and cooled

Lemon filling ingredients:
1-2/3 cups sugar-free or fruit-sweetened lemon yogurt
Two packets sweetener
One small package (4 serving size) sugar-free lemon gelatin
3/4 cup boiling water
Two ice cubes
1/2 cup ice cold fruit-sweetened lemonade concentrate
Mint sprig or orange slice to decorate each slice (optional)

Meringue ingredients:
Two egg whites
1/4 teaspoon cream of tartar
Six packets sweetener
1/2 teaspoon vanilla

Optional topping ingredients:
3 tablespoons whipping cream
1/2 packet sweetener
1/4 teaspoon vanilla

Directions:

Lemon filling:
Mix sweetener into yogurt, and set aside. Stir boiling water into gelatin powder until dissolved. Add ice cubes until melted; then stir in lemonade concentrate. Using a wire whip, whisk yogurt into gelatin mixture until smooth. Pour liquid into the pie crust.

Refrigerate 2-1/2 to 3 hours, or hasten the gelling process by putting the pie in the freezer for not more than 30 minutes and then into the refrigerator until ready. In the meantime, make the meringue, which will need time to cool.

Meringue:
Beat egg whites until frothy. Then beat in cream of tartar until peaks form and curl over. Without over beating, blend in each packet of sweetener separately. Beat in vanilla.

To bake the meringue, use an oven-safe round dish larger than your pie pan edges, and spray it liberally with nonstick cooking spray. Spread the meringue slightly larger than the size you will need for your pie, and sculpt as desired. Bake at 325-degrees 8 to 12 minutes, until only tips are light brown.

When the lemon filling has gelled and the meringue has cooled, slide meringue on top of the lemon pie. To add a festive touch, garnish each plate with a mint sprig and orange slice.

Recipe makes eight servings.

Next
Easy Lemon Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Fresh Limeade | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Make tall glasses of fresh, delicious limeade fast with this easy recipe.

Fresh Limeade

Ingredients:
1-1/2 cups freshly squeezed lime juice (about six limes)
4 cups cold water
1-1/2 cups measurable sweetener of choice
Ice cubes
Six lime slice twists
Six mint sprigs

Directions:
Mix lime juice, water and sweetener; refrigerate until chilled. Serve over ice in tall glasses; garnish with lime slice twists and mint.

Note: Limeade can be frozen in ice cube trays; the cubes can be used with the limeade so it will not be diluted. Also, the ice cubes can be processed in a blender or food processor to make a delicious lime slush.

Recipe makes six (8-ounce) servings.

Nutrition information per serving:
Calories: 45
Saturated Fat: 0g
Total Fat: 0g
Carbohydrate: 12g
Cholesterol: 0mg
Sodium: 5mg
Protein: <1g
Fiber: Trace Exchanges: 1 Fruit

Next
Iced Orange Cappuccino

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Linguine with Red Pepper Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Linguine with Red Pepper Sauce

Ingredients:
Cooking spray
1 teaspoon olive oil
1 1/2 cups chopped sweet red pepper
1 clove garlic, crushed
2 tablespoons chopped fresh basil
2 tablespoons balsamic vinegar
1/8 teaspoon salt
1/8 teaspoon black pepper
6 ounces linguine, uncooked
Fresh basil sprigs (optional)

Directions:
Coat a nonstick skillet with cooking spray; add oil. Place over medium heat until hot. Add sweet red pepper and garlic; cook, uncovered, 30 minutes, stirring occasionally. Set aside, and cool slightly.

Place pepper mixture in container of an electric blender or food processor; add chopped basil and next three ingredients. Cover and process until smooth, stopping once to scrape down sides.

Cook pasta according to package directions, omitting salt and fat.

To serve, top pasta with pepper sauce. Garnish with basil sprigs, if desired.

Nutrition information per serving:
Calories: 117
Fat: 1.5g
Saturated Fat: 0.2g
Protein: 3.7g
Cholesterol: 0mg
Sodium: 51mg
Carbohydrates: 22.2g
Fiber: 1.7g
Diabetic Exchanges: 1 Starch, 1 Vegetable

Next
Easy BBQ Sauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Chile Cheese Log | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chile Cheese Log

Ingredients:
1 cup shredded reduced fat cheddar cheese (4 ounces)
1/2 cup part-skim ricotta cheese
1 tablespoon finely chopped parsley
1 tablespoon chopped green chile
1-1/2 teaspoon dried minced onion
One clove garlic, minced
2-3 drops liquid hot pepper seasoning
2 tablespoons finely chopped pecans
20 Triscuit® wafers

Directions:
In electric blender or food processor, blend cheddar and ricotta cheese until just combined.

Spoon mixture into a bowl; stir in parsley, chiles, onion, garlic and hot pepper seasoning.

Shape into 5-inch log; wrap in waxed paper or plastic wrap and chill at least two hours.

To serve, roll log in pecans; cut log into 1/4-inch slices. Place slices on wafers.

Recipe makes one, 10-ounce log.

Nutrition information per serving:
Calories: 52
Fat: 3g
Carbohydrates: .4g
Cholesterol: 6mg
Sodium: 78mg
Dietary Exchanges: .2 Starch/Bread; .3 Meats; .2 Fat

Next
Creamy Garlic Dressing

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Breakfast Tortilla Wrap | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Breakfast Tortilla Wrap

This zingy bacon and egg burrito is ready to "wrap" in about ten minutes.

Ingredients:
One strip turkey bacon, chopped
2 tablespoons chopped green sweet pepper
1/8 teaspoon ground cumin
1/8 teaspoon salt (optional)
1/8 teaspoon crushed red pepper (optional)
2 egg whites, slightly beaten, or 1/4-cup refrigerated egg product
2 tablespoons chopped tomato
Few dashes bottled hot pepper sauce (optional)
One warmed 8-inch fat-free flour tortilla

Directions:
In a medium nonstick skillet cook bacon until crisp. Add green pepper, cumin, and salt and crushed red pepper, if desired. Cook for three minutes. Add egg whites or egg product; cook for two minutes. Stir in tomato and hot pepper sauce, if desired. Spoon onto tortilla and roll up.

Recipe makes one serving.

Nutrition information per serving:
Calories: 185
Total Fat: 3g
Saturated Fat: 1g
Protein: 11g
Carbohydrate: 27g
Cholesterol: 10mg
Sodium: 643mg
Fiber: 2g
Exchanges: 1.5 Starch/Bread, .5 Vegetable, 1 Very Lean Meat, .5 Fat

Next
Tex Mex Breakfast Pizza

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Tex Mex Breakfast Pizza | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Tex Mex Breakfast Pizza

Tex Mex Breakfast Pizza

Ingredients:
Nonstick cooking spray
1-1/2 cups frozen loose-pack diced hash brown potatoes, thawed
Two green onions, sliced
One to two canned jalapeno peppers or canned whole green chili peppers, drained, seeded, and chopped
1/4 teaspoon ground cumin
One clove garlic, minced
1 cup refrigerated or frozen egg product, thawed
1/4 cup fat-free milk
1 tablespoon snipped fresh cilantro
One 16-ounce Italian bread shell (such as Boboli)
1/2 cup shredded reduced-fat Monterey Jack cheese (2 ounces)
One small tomato, seeded and chopped

Directions:
Lightly coat a large skillet with cooking spray. Preheat over medium heat. Add the potatoes, green onions, peppers, cumin, and garlic. Cook and stir about 3 minutes or until the vegetables are tender.

In a small bowl stir together egg product, milk, and cilantro; add to skillet. Cook, without stirring, until mixture begins to set on the bottom and around the edge. Using a spatula, lift and fold the partially cooked mixture so uncooked portion flows underneath. Continue cooking and folding until egg product is cooked through, but is still glossy and moist. Remove from heat.

To assemble pizza, place the bread shell on a large baking sheet or a 12-inch pizza pan. Sprinkle half of the cheese over the shell. Top with the egg mixture, tomato, and the remaining cheese.

Bake in a 375-degree oven for eight to ten minutes or until cheese is melted. Cut into wedges to serve.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 235
Total Fat: 6g
Saturated Fat: 1g
Protein: 14g
Carbohydrate: 33g
Cholesterol: 8mg
Sodium: 424mg
Fiber: 2g
Exchanges: 2 Starch/Bread, 1 Lean Meat

Next
Meatless Sloppy Joe's

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Meatless Sloppy Joe's | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Meatless Sloppy Joe's

Ingredients:
2 cups thinly sliced onions
2 cups chopped green peppers
2 cloves garlic, finely chopped
2 tablespoons ketchup
1 tablespoon mustard
1 can of (about 15 ounces) kidney beans, mashed
1 can (8 ounces) tomato sauce
1 teaspoon chili powder
Cider vinegar
Two sandwich rolls, halved

Directions:
Spray skillet with cooking spray. Add onions, peppers and garlic. Cook and stir five minutes over medium heat. Stir in ketchup and mustard. Add beans, sauce and chili powder. Cook five minutes, stirring frequently. Add 1/3-cup vinegar if dry. Serve on halves.

Recipe makes four servings.

Nutrition information per serving:
Calories: 242
Total Fat: 2g
Protein: 10g
Carbohydrate: 48g
Cholesterol: 0mg
Sodium: 425mg
Exchanges: 2 Starch/Bread, 3 Vegetable, 1/2 Fat

Next
Turkey Burgers

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Turkey Burgers | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Turkey Burgers

Ingredients:
1 pound ground turkey breast
1-cup whole wheat bread crumbs
One egg white
1/2 teaspoon dried sage leaves
1/2 teaspoon dried marjoram leaves
1/4 teaspoon salt
1/4 teaspoon ground black pepper
1 teaspoon olive oil
4 whole grain sandwich rolls, split in half
1/4 cup barbecue sauce

Directions:
Combine turkey, bread crumbs, egg white, sage, marjoram, salt and pepper in large bowl until well blended. Shape into four patties. Heat oil in a large nonstick skillet over medium-high heat until hot. Add patties. Cook ten minutes or until patties are no longer pink in center, turning once. Place one patty on the bottom half of each roll. Spoon one tablespoon barbecue sauce over top of each burger. Place tops of rolls over burgers. Serve with lettuce and tomato and garnish with carrot slices, if desired.

Recipe makes four burgers.

Nutrition information per serving:
Calories: 319
Total Fat: 6g
Cholesterol: 41mg
Sodium: 669mg
Protein: 26g
Carbohydrate: 40g
Exchanges: 2 Starch/Bread, 3 Lean Meat

Next
Saucy Pork Chops

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Stuffed Sole Filets | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Saucy Pork Chops | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Saucy Pork Chops

Ingredients:
Six lean pork chops
1 cup unsweetened applesauce
1/4 cup light soy sauce
1/8 teaspoon onion powder

Directions:
Brown pork chops on both sides. Place in shallow casserole.

Combine remaining ingredients and spoon evenly over chops.

Cover and bake at 350-degrees for 45 minutes. Remove cover and continue baking 15 minutes longer or until chops are tender.

Recipe makes six burgers.

Nutrition information per serving:
Calories: 187
Total Fat: 7g
Sodium: 483mg
Protein: 25g
Carbohydrate: 5g
Fiber: 1g
Exchanges: 3-1/2 Ounces Very Lean Meat, 1/2 Fruit

Next
Key West Grilled Salmon

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Stuffed Sole Filets | Key West Grilled Salmon | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Key West Grilled Salmon | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Key West Grilled Salmon

Ingredients:
1/3 cup lime juice (two limes)
2 tablespoons olive oil
1/2 teaspoon salt
1/2 teaspoon celery seeds
1/8 teaspoon black pepper
Few drops hot-pepper sauce
Four salmon steaks (1-1/2 pounds total), each 3/4-inch thick
1/4 cup chopped green onion
1 tablespoon water
1/4 teaspoon honey

Directions:
Combine lime juice, oil, salt, celery seeds, black pepper and hot-pepper sauce in a small bowl.

Place salmon in a shallow dish. Pour 1/4-cup lime juice mixture over fish; turn to coat.

Refrigerate ten minutes, turning once. Reserve remaining mixture for sauce.

Prepare a charcoal grill with hot coals, or heat a gas grill to high, or heat broiler.

Stir green onion, water and honey into reserved lime juice mixture.

Grease grill rack or rack of a shallow roasting pan. Place salmon on rack. Drizzle with half of lime juice mixture from marinade dish.

Grill over hot coals on covered grill two minutes per side or until cooked through, or broil four minutes per side.

Serve salmon with green onion sauce.

Recipe makes four servings.

Nutrition information per serving:
Calories: 269
Fat: 16g
Carbohydrates: 2g
Protein: 28g
Sodium: 330
Cholesterol: 78mg
Exchanges: 4 Medium-Fat Meat

Next
Stuffed Sole Fillets

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Stuffed Sole Fillets | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Stuffed Sole Fillets

Ingredients:
3 teaspoons olive oil
1/4 cup diced celery
Two large shallots or one medium onion, finely chopped
Two cloves garlic, finely chopped
1/4 cup dry plain bread crumbs
1/2 cup medium-hot salsa
1/4 teaspoon salt
1/8 teaspoon black pepper
Four sole fillets (two pounds)
1/2 cup chicken broth
2 tablespoons dry white wine
Chopped fresh parsley for garnish

Directions:
Heat oven to 400-degrees. Heat 1-teaspoon oil in a small non-stick skillet.

Add celery, shallots and garlic; sautй five minutes or until glazed. Stir in bread crumbs; heat, stirring occasionally, just to toast crumbs, about three minutes. Remove from heat. Stir in salsa, salt and pepper.

Place two fillets side by side in a small shallow baking dish. Spread salsa mixture evenly over each. Cover fish with waxed paper.

Bake in heated 400-degree oven 12 to 15 minutes or until fish just begins to flake when pierced with a fork.

Cut each fillet stack crosswise in half. Pour pan liquid over fish. Garnish with parsley.

Recipe makes four servings.

Nutrition information per serving:
Calories: 204
Fat: 6g
Carbohydrates: 11g
Protein: 25g
Sodium: 744
Cholesterol: 67mg
Exchanges: 3 lean meat, 1 Vegetable, 1 Fat

Next
Chicken and Broccoli Skillet

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Chicken and Broccoli Skillet | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken and Broccoli Skillet

Ingredients:
2 cups broccoli, cut ѕ-inch pieces
1/2 cup onion, chopped
1/4 teaspoon lemon pepper
1/4 teaspoon thyme, dried and crushed
1/4 teaspoon cooking oil
One clove garlic, minced
Four chicken breast halves, boned and skinless (1 pound)
1 cup halved cherry tomatoes

Directions:
Spray a cold large skillet with nonstick coating.

Preheat skillet over medium heat.

Add broccoli, onion, lemon pepper, and thyme to skillet.

Cook and stir for three to four minutes or till vegetables are crisp-tender.

Remove vegetable are crisp-tender.

Remove vegetable mixture from the skillet; keep warm.

Add oil and garlic to hot skillet.

Rinse chicken; pat dry. Add to skillet. Cook chicken over medium-high heat about ten minutes or until chicken is tender and not longer pink, turning once.

Add cherry tomatoes. Cover and cook one to two minute or till heated through.

Recipe makes four servings.

Exchanges: 3 lean meat, 1 Vegetable, 1 Fat

Next
Chicken Dijon

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Chicken Dijon | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken Dijon

Ingredients:
8 ounces plain, unsweetened low-fat yogurt
1/4 cup Dijon mustard
Eight chicken breast halves (3 ounces) skinned
1/2 cup soft breadcrumbs
Vegetable cooking spray

Directions:
Combine yogurt and mustard, stirring until well blended. Brush breast halves evenly with yogurt mixture, and dredge breadcrumbs.

Arrange chicken in a 12 x 8 x 2-inch baking dish coated with cooking spray.

Cover and bake at 400-degrees of 30 minutes.

Increase temperature to 450-degrees. Bake, uncovered, for 15 minutes or until chicken is done and coating is browned.

Recipe makes eight servings.

Exchanges: 3 lean meat, 1 Vegetable, 1 Fat

Next
Chicken and Dumplings

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Chicken and Dumplings | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken and Dumplings

Ingredients:
One small chicken (1-Ѕ pounds)
1-1/2 cup water
1/4 teaspoon salt
1/2 stalk celery
1/4 cup onion

Dumplings:
1 cup flour
1 teaspoon baking powder
1/2 teaspoon salt
1 tablespoon shortening
1/2 cup skim milk

Directions:
Disjoint chicken and remove skin; place in large pan. Add water, salt, celery, and onion; simmer one to two hours or until meat is tender.

Remove chicken from bone; return chicken to chicken stock. Bring chicken and stock to a boil; add rolled dumplings. Cover and boil gently eight to ten minutes.

Directions for making rolled dumplings:
Combine flour, baking powder, and salt. Cut in shortening. Add milk to make a stiff dough. Roll dough out to about 1/8-inch thickness and cut into 1-inch strips, squares or diamonds.

Pot Pie Variation:
To make a chicken pot pie, put mixture in a deep dish, cover with a rolled pastry dough to fit, making several slashes in the top. The top crust would add calories to the total. You may add peas, carrots, mushrooms if you like. (Those ingredients are not in the original recipe).

Recipe makes six, 3/4-cup servings.

Exchanges: 2 Medium Fat Meat, 1 starch

Next
Stewed Chicken

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Stewed Chicken | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Stewed Chicken

Ingredients:
Four boneless chicken breast halves
16 ounce can Italian stewed tomatoes, cut in bite sized pieces
4 ounce can sliced salt-free mushrooms
One medium onion, sliced in rings
2 teaspoons Italian seasoning
2 teaspoons garlic, chopped
Salt to taste
Pepper to taste
Shredded fat-free mozzarella cheese

Directions:
Place chicken in baking dish. Top with tomatoes and their juice, mushrooms, onions and seasonings. Cover tightly with foil and bake at 350-degrees for one hour or until chicken is done.

Remove from oven and sprinkle with mozzarella. Cover with foil until cheese melts.

Recipe makes four servings.

Exchanges: 2 Medium Fat Meat, 1 starch

Next
Grilled Tuna with Rosemary

Main Dishes

To Your Health!
Fitness and Freebies

space Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Grilled Tuna with Rosemary | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Grilled Tuna with Rosemary

Firm-fleshed fish grills nicely without falling apart.

Ingredients:
1 pound fresh or frozen tuna, halibut, or salmon steaks
2 teaspoons olive oil
2 teaspoons lemon juice
1/8 teaspoon salt
1/8 teaspoon pepper
Two cloves garlic, minced
2 teaspoons snipped fresh rosemary or tarragon or 1-teaspoon dried herb, crushed
1 tablespoon drained capers, slightly crushed
Fresh rosemary sprigs (optional)

Directions:
Thaw fish, if frozen. Rinse and pat dry with paper towels. Measure thickness. Cut into four serving-size portions. Brush both sides with olive oil and lemon juice; sprinkle with salt and pepper. Rub garlic and rosemary or tarragon onto fish. Grill or broil.

Cook by Direct Grill Method:
Place fish steaks on a greased grill rack or in a grill basket. Grill on an uncovered grill directly over medium-hot coals until fish flakes easily when tested with a fork (allow four to six minutes per 1/2-inch of thickness). If the fish is more than 1-inch thick, gently turn it halfway through grilling.

To Broil:
Place fish on the greased rack of a broiler pan. Broil 4 inches from the heat for 4 to 6 minutes per 1/2-inch of thickness. If fish is more than 1-inch thick, gently turn it halfway through broiling.

To serve, top fish with capers. If desired, garnish with fresh rosemary.

Recipe makes four servings.

Nutrition information per serving:
Calories: 145
Total Fat: 3g
Saturated Fat: 1g
Cholesterol: 51mg
Sodium: 179mg
Protein: 27g
Carbohydrate: 1g
Fiber: 0g
Exchanges: 4 Very lean meat

Next
Roast Pork with Cabbage and Carrots

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Roast Pork with Cabbage and Carrots | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Roast Pork with Cabbage and Carrots

Crisp-tender cabbage and carrots, accented with dillseed, make a flavorful accompaniment to pork.

Ingredients:
One 12-ounce pork tenderloin, trimmed of separable fat
6 cups shredded cabbage
One large onion, sliced
2/3 cup shredded carrots
1/3 cup water
2 tablespoons vinegar
1 teaspoon dillseed, crushed
1/4 teaspoon salt
1/4 teaspoon pepper

Directions:
Place pork tenderloin on a rack in a shallow roasting pan. Insert a meat thermometer. Roast in a 425-degree oven for 25 to 35 minutes or until thermometer registers 160-degrees.

Meanwhile, in a large saucepan combine cabbage, onion, carrots, water, vinegar, dillseed, salt, and pepper. Bring to boiling; reduce heat. Cover and simmer for eight to ten minutes or until vegetables are just tender. 3. Slice pork and serve with vegetables.

Recipe makes four servings.

Nutrition information per serving:
Calories: 156
Total Fat: 2g
Saturated Fat: 1g
Cholesterol: 50mg
Sodium: 207mg
Protein: 23g
Carbohydrate: 12g
Fiber: 4g
Exchanges: 2.5 Very lean meat, 2.5 Vegetables

Next
Herbed Beef Tenderloin

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Herbed Beef Tenderloin | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Herbed Beef Tenderloin

Whether you grill or roast this tenderloin, the meat will be tender and juicy.

Ingredients:
1/4 cup finely snipped fresh parsley
2 tablespoons Dijon-style mustard
1 tablespoon snipped fresh rosemary
2 teaspoons snipped fresh thyme
Two cloves garlic, minced
1 teaspoon olive oil or cooking oil
1/2 teaspoon coarsely ground black pepper
One, 2-pound beef tenderloin roast, trimmed of separable fat
1/2 cup light dairy sour cream
2 teaspoons Dijon-style mustard

Directions:
In small mixing bowl stir together parsley, the 2-tablespoons mustard, the rosemary, thyme, garlic, oil, and pepper. Rub over top and sides of meat.

In a covered grill arrange hot coals around a drip pan. Test for medium heat above the drip pan.* Place roast on grill rack over drip pan, but not over coals. Insert a meat thermometer in center of roast. Lower the grill hood. Grill about 45 minutes or until thermometer registers 140-degrees. (Or, place meat on a rack in a shallow roasting pan. Insert a meat thermometer into center of meat. Roast, uncovered, in a 325-degree oven for 30 to 45 minutes or until thermometer registers 140-degrees.) Cover meat with foil and let stand for 15 minutes (the temperature of the meat will rise five degrees during standing).

Meanwhile, stir together sour cream and the 2-teaspoons mustard. Thinly slice meat. Serve with sour cream mixture. If desired, sprinkle with additional black pepper.

*Note:
To check for medium heat, hold your hand, palm side down, over the grill where the meat will cook and at about the same height of the meat. The heat is right when you can hold you hand there for only three seconds.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 207
Total Fat: 10g
Saturated Fat: 4g
Cholesterol: 74mg
Sodium: 92mg
Protein: 25g
Carbohydrate: 2g
Fiber: 0g
Exchanges: 1 Protein

Next
Spinach Lasagna

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Spinach Lasagna | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Spinach Lasagna

Ingredients:
One container (16 ounces) lowfat cottage cheese
One package (10 ounces) frozen chopped spinach , thawed, well drained
3 cups 2% shredded reduced fat Mozzarella cheese , divided
3/4 cup fat free grated Parmesan cheese , divided
Egg substitute equal to two eggs
One jar (28 ounces) spaghetti sauce , divided
Nine lasagna noodles , cooked, drained

Directions:
Layer 1-cup of the spaghetti sauce, three lasagna noodles and 1/2 of the cottage cheese mixture in 13x9-inch baking dish. Repeat layers. Top with remaining three noodles, 1-cup sauce, 1-cup mozzarella cheese and 1/4 cup Parmesan cheese. Bake at 350-degrees for 45 minutes. Let stand ten minutes before serving.

Meanwhile, stir together sour cream and the 2-teaspoons mustard. Thinly slice meat. Serve with sour cream mixture. If desired, sprinkle with additional black pepper.

Nutrition Bonus:
This traditional family favorite is rich in both calcium from the cheese and vitamin A from the spinach.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 268
Total Fat: 5.8g
Sodium: 1050mg
Protein: 25g
Carbohydrate: 27g
Fiber: 22g
Exchanges: 1-1/2 Starch, 1 Vegetable, 2 Meat (MF)

Next
Grilled Fish Over Linguine With Roasted Pepper Sauce

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Grilled Fish Over Linguine With Roasted Pepper Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Grilled Fish Over Linguine With Roasted Pepper Sauce

Ingredients:
Two red peppers
Four firm-textured fish fillets or steaks, such as halibut (about 1-1/4 pound)
1 teaspoon lemon pepper seasoning
1/4 pound (4 ounces) Velveeta Light Cheese Product, cut up
8 ounces hot cooked spinach linguine

Directions:
Place red peppers on grill over hot coals or on rack of broiler pan three to four inches from heat. Grill or broil eight to ten minutes or until skin is blackened, turning several times. Place in paper bag; close top. Cool. Remove peels and seeds from peppers; discard.

Mix prepared cheese product and pureed red peppers in saucepan; cook on low heat until prepared cheese product is melted, stirring occasionally. Place combined pasta on serving platter; top with fish. Pour red pepper mixture over fish.

Nutrition Bonus
Grilled fish tastes even better when served with this flavorful sauce. The red peppers add an excellent source of vitamins A and C.

Recipe makes four servings.

Nutrition information per serving:
Calories: 310
Total Fat: 7g
Saturated Fat: 2.5g
Sodium: 610mg
Protein: 38g
Carbohydrate: 23g
Fiber: 1g
Exchanges: 1 1/2 Starch, 1 Vegetable, 5 Meat (VL)

Next
Grilled Pork Tenderloin with Corn-Pepper Relish

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Grilled Pork Tenderloin with Corn-Pepper Relish | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Grilled Pork Tenderloin with Corn-Pepper Relish

Ingredients:
Two pork tenderloins (10 to 12 ounces each)
1 cup prepared Italian Salad Dressing for Fat Free Dressing , divided
One can (15 ounces) black beans , drained, rinsed
One can (10 ounces) whole kernel corn , drained
One red pepper , chopped

Directions:
Place pork on greased grill over hot coals. Grill 12 to 15 minutes or until cooked through, turning every four minutes and brushing with 1/2-cup of the dressing. Cut into 1/2-inch slices.

Mix beans, corn, red pepper and remaining 1/2-cup dressing. Serve with pork.

Nutrition Bonus
This low fat main dish serves up a good source of vitamins A & C along with the corn and red peppers.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 140
Total Fat: 2g
Saturated Fat: 0.5g
Cholesterol: 45g
Sodium: 530mg
Protein: 18g
Carbohydrate: 13g
Fiber: 2g
Exchanges: 1 Starch, 2 Meat (VL)

Next
Garlicky Chicken Breasts

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Garlicky Chicken Breasts | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Garlicky Chicken Breasts | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Garlicky Chicken Breasts

Ingredients:
1/2 cup grated fat free Parmesan cheese
One envelope roasted garlic salad dressing mix
Six boneless skinless chicken breast halves (about 2 pounds)

Directions:
Mix cheese and salad dressing mix.

Mix beans, corn, red pepper and remaining 1/2-cup dressing. Serve with pork.

Moisten chicken with water; coat with cheese mixture. Place in shallow baking dish. Bake at 400-degrees for 20 to 25 minutes or until cooked through.

Recipe makes six servings.

Nutrition information per serving:
Calories: 220
Total Fat: 5g
Saturated Fat: 2.5g
Cholesterol: 100g
Sodium: 700mg
Protein: 39g
Carbohydrate: 3g
Exchanges: 5 Meat (VL), 1 Fat

Next
Black Bean Lasagna Rolls

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Garlicky Chicken Breasts | Black Bean Lasagna Rolls | Chocolate Bread Pudding | space


Black Bean Lasagna Rolls | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Black Bean Lasagna Rolls

A spicy Southwestern-inspired twist on a classic dish. Lasagna noodles are rolled up with ricotta cheese and black beans, and served with a spooning of salsa.

Ingredients:
Eight lasagna noodles, uncooked
1 cup shredded reduced-fat Monterey Jack cheese
One (15 ounce) container part-skim ricotta cheese
One (4.5 ounce) can chopped green chiles, drained
1/2 teaspoon chili powder
1/8 teaspoon salt
2 cups drained canned no-salt-added black beans
Cooking spray
One (15.5 ounce) jar no-salt-added salsa
Fresh cilantro sprigs (optional)

Directions:
Cook lasagna noodles according to package directions, omitting salt and fat; drain well.

Combine cheeses and next three ingredients, stirring well. Spread cheese mixture over one side of each noodle. Spoon black beans evenly over cheese mixture. Roll up noodles, jellyroll fashion, beginning at narrow ends.

Place lasagna rolls, seam sides down, in an 11- x 7- x 11/2-inch baking dish coated with cooking spray. Cover and bake at 350-degrees for 25 minutes or until thoroughly heated.

To serve, spoon salsa evenly over rolls, and garnish with cilantro sprigs, if desired.

Recipe makes six servings.

Nutrition information per serving:
Calories: 295
Total Fat: 7.8g
Saturated Fat: 4.3g
Cholesterol: 26g
Sodium: 387mg
Protein: 19g
Carbohydrate: 38g
Fiber: 2.8g
Exchanges: 2 Starch, 1 Vegetable, 2 Lean Meat

Next
Poached Salmon with Lemon Pepper Butter

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Garlicky Chicken Breasts | Black Bean Lasagna Rolls | Poached Salmon with Lemon Pepper Butter | space


Poached Salmon with Lemon Pepper Butter | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Poached Salmon with Lemon Pepper Butter

Ingredients:
2 Cups Court Boullion (see below)
8 ounces salmon fillet, skin on
2 tablespoons Lemon Pepper Butter (see below)

Directions:
Make Court Bouillon and Lemon Pepper Butter and keep warm. In a covered sautй pan large enough to hold the fish in one layer, heat Court Boullion to about 165-degrees. Place salmon in it, cover, and simmer gently for 10-12 minutes, or until fully cooked. Remove fish from poaching liquid and drain. Divide fish, place on two warm plates, and cover with Lemon Pepper Butter.

Yield: Two servings.

Per serving: 2.7gm Cholesterol, 4.1g Protein

Preparing Court Bouillon:
2-Ѕ quarts water
Ѕ cup vinegar
1 tablespoon salt
Ѕ pound onions, peeled and sliced
Pinch dried thyme leaves
1 Ѕ bay leaves
Ѕ bunch parsley stems
ј tsp black peppercorns

Combine all ingredients except peppercorns in a large saucepan. Simmer for 50 minutes. Add peppercorns and simmer for an additional ten minutes. Strain, cool, and store in airtight container in refrigerator.
Yield: Eight servings, 1 cup each
Per serving: 2.5gm Cholesterol, .5 Protein

Preparing Lemon Butter:
Ѕ cup butter, softened 2 tablespoons lemon juice 1/8 teaspoon salt 1/8 teaspoon white pepper Lemon pepper seasoning, to taste

In a food processor, combine all ingredients until smooth. Roll butter into a 1 – inch- diameter cylinder. Do so by placing on parchment paper or on plastic wrap. Roll butter in the paper or wrap until you have a 1 inch diameter cylinder. Refrigerate until needed. Slice into ј inch pieces to use (3 slices = 1 tablespoon).

Recipe makes four, 2-tablespoon servings.
Per Serving: Cholesterol, 0.7gm, Protein .5

Next
Beef Roulades

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Garlicky Chicken Breasts | Black Bean Lasagna Rolls | Poached Salmon with Lemon Pepper Butter | Beef Roulades | space


Beef Roulades | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Beef Roulades

In this tempting dish, sweet pepper strips are rolled up inside seasoned beef. Try a combination of red, yellow, orange, and green sweet peppers for a colorful stuffing.

Ingredients:
1 pound boneless beef round steak, cut 1/2 inch thick and trimmed of separable fat
1 tablespoon Dijon-style mustard
Eight, 4-inch green pepper strips or eight green onions, cut into 4-inch lengths
One medium onion, chopped (1/2-cup)
1-1/2 cups beef broth
1 tablespoon all-purpose flour
2 cups chopped carrots
Nonstick cooking spray

Directions:
Spread one side of each beef piece with one-fourth of the mustard. Place two green pepper strips or two green onions at a short end of each beef piece and roll up. Secure with wooden toothpicks.

Lightly coat a cold large skillet with cooking spray. Heat skillet over medium heat. Add beef rolls; brown on all sides. Remove rolls from skillet. Add chopped onion to skillet and cook for 3 minutes or until onion is nearly tender.

In a small mixing bowl stir together beef broth and flour. Pour mixture into the skillet. Cook and stir until thickened and bubbly. Add beef rolls; cover and simmer 40 minutes. Add carrots; cover and simmer about 20 minutes more until beef and carrots are tender.

Recipe makes four servings.

Nutritional information per serving:
Calories: 192
Total Fat: 3g
Saturated Fat: 1g
Cholesterol: 49mg
Sodium: 405mg
Carbohydrate: 12g
Fiber: 3g
Protein: 29g
Exchanges: 2.5 Vegetables, 3 Very Lean Meat, .5 Fat

Back
Main Contents

Main Dishes

To Your Health!
Fitness and Freebies

space Breakfast Tortilla Wrap | Tex Mex Breakfast Pizza | Meatless Sloppy Joe's | Turkey Burgers | Saucy Pork Chops | Key West Grilled Salmon | Stuffed Sole Fillets | Chicken and Broccoli Skillet | Chicken Dijon | Chicken and Dumplings | Stewed Chicken | Grilled Tuna with Rosemary | Roast Pork with Cabbage and Carrots | Herbed Beef Tenderloin | Spinach Lasagna | Grilled Fish Over Linguine With Roasted Pepper Sauce | Grilled Pork Tenderloin with Corn-Pepper Relish | Garlicky Chicken Breasts | Black Bean Lasagna Rolls | Poached Salmon with Lemon Pepper Butter | Beef Roulades | space


Diabetic Main Dishes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Diabetic Main Dishes

Button Breakfast Tortilla Wrap

Button Tex Mex Breakfast Pizza

Button Meatless Sloppy Joe's

Button Turkey Burgers

Button Saucy Pork Chops

Button Key West Grilled Salmon

Button Stuffed Sole Fillets

Button Chicken and Broccoli Skillet

Button Chicken Dijon

Button Chicken and Dumplings

Button Stewed Chicken

Button Grilled Tuna with Rosemary

Button Roast Pork with Cabbage and Carrots

Button Herbed Beef Tenderloin

Button Spinach Lasagna

Button Grilled Fish Over Linguine With Roasted Pepper Sauce

Button Grilled Pork Tenderloin with Corn-Pepper Relish

Button Garlicky Chicken Breasts

Button Black Bean Lasagna Rolls

Button Poached Salmon with Lemon Pepper Butter

Button Beef Roulades

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Maple Flavored Syrup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Maple Flavored Syrup

Ingredients:
1 cup apple juice 1/4-cup measurable sugar substitute
1 tablespoon margarine
1 teaspoon maple extract
1 teaspoon vanilla

Directions:
Mix apple juice, cornstarch and Equal or sugar substitute in a small saucepan; heat to boiling. Boil, stirring constantly, until thickened, about one minute. Remove from heat; add margarine, maple extract and vanilla, stirring until margarine is melted. Recipe makes four servings.

Nutrition information per serving:
Calories: 228
Fat: 8g
Cholesterol: 0mg
Sodium: 41mg
Carbohydrates: 40g
Diabetic Exchanges: 1 fruit, 1-1/2 starch, 1-1/2 fat

Next
Linguine with Red Pepper Sauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Garlic Mashed Potatoes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Garlic Mashed Potatoes

Enjoy this excellent source of vitamin C!

Ingredients:
2 pounds red or Idaho potatoes, quartered, not peeled
1/2 cup milk
1/2 cup Miracle Whip lite dressing
3/4 teaspoon garlic powder
Salt and pepper
*Or substitute two to three cloves garlic, minced, for garlic powder

Directions:
Cover potatoes with water in large saucepan. Bring to boil; reduce heat to medium. Cook 20 minutes or until potatoes are tender. Drain.

Mash potatoes. Add milk, dressing and garlic powder; beat until fluffy. Season to taste with salt and pepper.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 140
Total Fat: 3.5g
Saturated Fat: .5g
Cholesterol: 5mg
Sodium: 140mg
Carbohydrate: 26g
Fiber: 2g
Protein: 3g
Exchanges: 1-1/2 Starch, 1/2 Fat

Next
Nutty Wild Rice Salad with Kiwifruit and Red Grapes

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Quick Minestrone | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Quick Minestrone

Ingredients:
1/4 pound lean ham, cut into small pieces
1 can (10-3/4 ounces) condensed onion soup
2 cups canned tomatoes (with juice), cut into pieces
1/2 cup each: diced carrot and celery
One medium zucchini, diced
One large clove garlic, minced
1/3 cup minced fresh parsley
One bay leaf
1/4 teaspoon each: dried thyme leaves, marjoram, basil and pepper
5 cups water
1 cup broken uncooked spaghetti
One can (15 ounces) cannellini, navy or other white beans, undrained
1/4 cup grated Parmesan cheese

Directions:
In a large soup pot, combine ham, soup, tomatoes, carrot, celery, zucchini, garlic, parsley, bay leaf, thyme, marjoram, basil, pepper and water. Simmer, covered, for 1 hour.

Add spaghetti and beans with liquid and cook 30 minutes longer. Remove bay leaf. Sprinkle each serving with Parmesan cheese.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 122
Fat: 2.4
Sodium: 871mg
Carbohydrate: 17g
Protein: 8.9g
Cholesterol: 6mg
Exchanges: 1 Lean Meat, 1 Bread/Starch

Next
Cool 'n Creamy Beet Soup

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Some Common Misunderstandings of the Exchange Meal Plan | Fitness and Freebies

Some Common Misunderstandings of the Exchange Meal Plan

Many diabetics may feel they could omit some of the choices for a particular meal in order to use them in a subsequent meal. This is not a good idea unless you are doing your own insulin adjustments in the intensified program. All food choices are scheduled throughout the day to help maintain normal levels of blood sugar.

A question diabetic often asked is,

"Can I use all my choices in a single food group on one item of food? Example: If breakfast lists two bread/starch choices, can they both be used for English muffins rather than for two different items".

You may, if you wish. However, different foods contain different nutrients so it is better to have as much variety in your food choices as possible.

Substitutions Between Food Groups
Can you substitute a bread/starch choice for a fruit choice? Yes, but the following suggestions should be heeded:
  • Replace one fruit choice with one bread/starch choice. Try to limit this substitution to no more than once a day. Otherwise, you eliminate the vitamins A and C present in fruit.
  • Replace one bread/starch choice with three vegetable choices. Use this substitution to provide yourself with more fibers and "bulk" when you are feeling especially hungry.
  • Replace one skim or one, 1-% low fat milk choice with one bread/starch choice and one low-fat meat choice. You should only make this substitution occasionally or you will eliminate much needed calcium from your diet.

Next
Snacks

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Monitoring Your Glucose | Fitness and Freebies

Monitoring Your Glucose

Activity, medications, stress and eating all affect your blood glucose levels. How can you tell how much? You could start monitoring your glucose and keeping track of the results on a regular schedule. The way to do this is up to you, but these tips may make it easier:
  • Keep a journal, informally jotting down daily notes.
  • Ask if your diabetes health care provider or local diabetes association has ready-made forms.
  • If you are computer-savvy, check out software packages available through online health care companies. Look for programs that can download glucose results from your meter.

Here is how to use the information you collect:
  • Look for patterns, like times of the day when your glucose tends to be too high or too low.
  • Identify factors causing your glucose levels to be outside of your acceptable range.
  • Most importantly, share your records with your diabetes health care tema so that changes can be made in your treatment regimen to fine-tune control of your glucose.

Next
Oatmeal in the Diabetic Diet

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Frozen Bananas | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Frozen Bananas

Ingredients:
Three medium ripe bananas
One 4-ounce carton fat free vanilla yogurt
1/2 cup Grape Nuts cereal

Directions:
Peel bananas and cut in half crosswise. Insert a wooden stick into the flat end of each banana half.

Using a small spatula, spread some of the yogurt onto the sides of each banana half and immediately roll in the Grape Nuts. Place on a waxed-paper lined baking sheet and freeze firm.

Once frozen, wrap each banana in plastic wrap and insert into a self-sealing plastic bag. Eat frozen.

Recipe makes six servings.

Nutrition information per serving:
Calories: 106
Total Fat: trace
Saturated Fat: 0.1g
Carbohydrate: 25g
Cholesterol: 1mg
Sodium: 75mg
Fiber: 2g
Protein: 3g
Calories from fat: 3%
Exchanges: 1-1/2 carbohydrate (1/2 bread/starch, 1 fruit)

Next
Maple Banana Blast

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Maple Banana Blast | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Maple Banana Blast

Ingredients:
Four bananas, slightly brown speckled 1/3 cup measurable sweetener 1/4 cup maple syrup, sugar free 1/4 cup skim milk 1/3 cup yogurt, plain, non fat 1/2 teaspoon vanilla extract, pure 2 cups small ice cubes

Equipment: 5-6 cup blender

Directions:
Break bananas in half and freeze for 20 minutes or until frozen. Add all ingredients to blender. Blender will be full. Mix on low speed for 10 seconds. Remove lid, stir with wooden spoon. Mix on medium speed for 15 seconds, remove lid and stir again. Mix on high speed for 15-20 seconds or until smooth. Pour into glasses. Serve immediately.

Using a small spatula, spread some of the yogurt onto the sides of each banana half and immediately roll in the Grape Nuts. Place on a waxed-paper lined baking sheet and freeze firm.

Note:
Mixing times will vary depending on frozen state of fruit. Servings can slightly vary depending on size of bananas.

Recipe makes four servings.

Nutrition information per serving:
Calories: 120
Total Fat: 1/2g
Saturated Fat: 0g
Carbohydrate: 28g
Cholesterol: 0mg
Sodium: 45mg
Fiber: 0g
Protein: 2g
Calories from fat: 3%
Exchanges: 1-1/2 carbohydrate (1/2 bread/starch, 1 fruit)

Next
Banana Fingers

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Banana Fingers | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Banana Fingers

Ingredients:
1/2 of a ripe 9-inch banana
1 tablespoon fresh orange juice
1/4 teaspoon ground cinnamon
One slice whole wheat or oatmeal bread, toasted

Directions:
Preheat broiler. With a fork, mash banana with orange juice and cinnamon. Spread on one side of tasted bread.

Place under the broiler until bubbling and lightly browned. Cut into small fingers and serve.

Recipe makes one serving.

Nutrition information per serving:
Calories: 132
Total Fat: 2g
Saturated Fat: 0.4g
Carbohydrate: 29g
Cholesterol: 0mg
Sodium: 149mg
Fiber: 4g
Protein: 4g
Calories from fat: 10%
Exchanges: 2 carbohydrate (1 bread/starch, 1 fruit)

Next
Main Contents

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Banana Cream Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Banana Cream Pie

Ingredients:
9" pie crust, brushed with egg whites, baked and cooled

Banana ingredients:
Two medium-sized bananas

Pudding ingredients:
2-3/4 cups 1% milk One large package (6 serving size) banana sugar-free instant pudding
24 packets sweetener or 1 cup measurable sweetener

Topping ingredients:
1/4 cup whipping cream
One packet sweetener
1/2 teaspoon vanilla

Banana layer:
Cut bananas into thick slices, about 1/4 inch each. Evenly cover the bottom and the lower edges of the pie crust with banana slices.
Pudding layer:
Beat together milk and pudding mix for one to two minutes. Gently pour pudding over the banana layer, and refrigerate. Allow one hour to gel.

Topping layer:
A little whipping cream makes this pie rich and creamy. Those watching calories or fat will find the pie quite delicious without topping.

**For best results, wait until just before serving the pie to prepare the topping. Beat the whipping cream until peaks form and then droop. Add sweetner and vanilla. Beat until stiff. Top each slice with a small dollop, or spread a thin layer over the entire pie.

Next
Banana Yogurt Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Banana Yogurt Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Banana Yogurt Pie

Ingredients:
2 cups rolled oats
1 cup pitted dates
1 teaspoon vanilla extract
2 tablespoons orange juice
1/4 cup boiling water
1 teaspoon unflavored gelatin
2 frozen bananas, peeled and chopped
1 cup evaporated low-fat milk, chilled
1/2 teaspoon vanilla extract
1 cup low-fat plain yogurt
1 banana, finely sliced
1/4 cup lemon juice
1 teaspoon ground nutmeg

Directions:
Combine the rolled oats, dates, vanilla extract and orange juice in a blender and blend for three minutes until mixture sticks together. Press the mixture thinly around the sides and base of a 9-inch pie dish and refrigerate.
Pour boiling water over gelatine, stir to dissolve, and set to cool.
Place frozen bananas in food processor or blender and blend until smooth.

Add milk and blend for three to four minutes. Add extra vanilla and yogurt and mix well.

Add dissolved gelatine and water. Pour mixture into the base of the pie dish and refrigerate until firm.

Soak the extra banana in the lemon juice, slice and place on top of pie. Sprinkle with nutmeg and serve.

Next
Glazed Blackberry Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Nectarine and Berry Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Nectarine and Berry Pie

Nectarine Berry Pie

Ingredients:
Pastry for a single crust 9-inch pie
5 cups sliced nectarines (about five)
1 cup of raspberries or sliced strawberries
1 cup fresh or frozen blueberries, partially thawed
2 teaspoons lemon juice
3 tablespoons cornstarch
1 cup measurable sweetener or 24 packets
1 teaspoon grated lemon rind
ј teaspoon ground allspice

Directions:
Preheat oven to 425-degrees.

Roll pastry on floured surface into 12-inch circle; transfer to ungreased cookie sheet.

Toss nectarines and berries with lemon juice in large bowl; sprinkle fruit with combined cornstarch, sweetener, lemon rind and allspice and toss to coat. Arrange fruit on pastry, leaving 2-inch border around the edge. Bring edges of pastry to center, overlapping as necessary.

Bake pie in preheated oven until pastry is golden and fruit is tender, 35 to 40 minutes.

Cool on a wire rack.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 172
Total Fat: 6g
Carbohydrates: 31g
Cholesterol: 5mg
Protein: 2g
Sodium: 64mg
Exchanges: 1 fruit, 1 starch, 1 fat

Back
Main Contents

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Orange Banana Nog | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Orange Banana Nog

Ingredients:
1 cup orange juice
1/2 cup skim milk
1/2 cup no-cholesterol real egg product
1 small banana, sliced
3 to 4-1/2 packets sweetener or 2 to 3-tablespoons measurable sweetener of choice
Ground nutmeg

Directions:
Place orange zest in bottom of coffee pot. Brew coffee, using cold water and espresso; cool to room temperature. Strain coffee and discard orange zest; stir in measurable sweetener and milk. Refrigerate until chilled.

Process all ingredients, except nutmeg, in blender or food processor until smooth; pour into glasses. Sprinkle lightly with nutmeg.

Nutrition information per serving (about 2/3-cup):
Calories: 83
Total Fat: 0g
Carbohydrate: 16g
Cholesterol: 1mg
Sodium: 67mg
Protein: 9g
Exchanges: 1 fruit

Next
Raspberry Sangria

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Nutrition Facts for Diabetics | Fitness and Freebies

Nutrition Facts for Diabetics

All the food we eat is made up of nutrients, the substances that provide the body what it needs to grow, stay warm, and provide a wide range of other functions.

The three major nutrients of concern for diabetics are carbohydrates, protein and fat. In addition, research suggests that other nutrients may also be important in the care of diabetes (vitamins and minerals).

How Diabetes Affects the Food We Eat

That old saying, "You are what you eat" can apply to all, but with diabetics, it applies more than most realize.

This is due to the fact that the types of food you eat and when you eat can have a dramatic effect on your blood sugar. Food can also be a factor in the prevention of long-term complications from diabetes.

Let's move on with a break-down of the essential nutrients for diabetics.

Next
Carbohydrates

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Nutty Apple Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Nutty Apple Salad

The skins on the red and green apples add holiday color to the salad greens, but if you prefer no skin, peeling the fruit will not harm the flavor.

Ingredients:
Romaine leaves
9 cups torn mixed greens
One small tart green apple, cored and cut into wedges
One small red apple, cored and cut into bite-size pieces
3 tablespoons cider vinegar
3 tablespoons olive oil
1/4 teaspoon pepper
1/8 teaspoon salt
1/3 cup mixed nuts, toasted

Directions:
Lay several romaine leaves on a large platter. Top with the torn greens and apples.

Combine cider vinegar, olive oil, pepper, and salt in a small screw-top jar. Place lid on jar and shake dressing well. Drizzle dressing over salad. Sprinkle with nuts.

Recipe makes eight to ten servings.

Nutrition information per serving:
Calories: 107
Total Fat: 8g
Saturated Fat: 1g
Cholesterol: 0mg
Sodium: 43mg
Carbohydrate: 8g
Fiber: 2g
Protein: 2g
Exchanges: .5 Fruit, Vegetables .5, 1.5 Fat,

Next
Pickled Carrots

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Nutty Wild Rice Salad with Kiwifruit and Red Grapes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Nutty Wild Rice Salad with Kiwifruit and Red Grapes

Ingredients:
2-1/2 cups chicken stock
1 cup wild rice
3 tablespoons lemon juice
2 teaspoons olive oil
2 teaspoons honey
2 kiwis, peeled and diced
1 cup seedless red grapes, halved
1-1/2 tablespoons toasted, chopped pecans

Directions:
Place broth in a medium saucepan, and bring to a boil. Add rice, reduce heat to low, and simmer, covered, for 45 minutes, or until tender. Drain excess liquid, cover and let cool. Whisk together lemon juice, oil, and honey in a small bowl until honey is dissolved. Season with salt and pepper. Place cooled rice in a salad bowl, along with kiwi, red grapes and pecans. Add dressing, and gently toss.

Next
Broiled Steak Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Oatmeal-Banana Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal-Banana Muffins

Ingredients:
3 cups whole wheat flour
3/4 cup rolled oats
1 tablespoon baking powder
1/2 teaspoon ground cinnamon
1/4 teaspoon ground nutmeg
1 tablespoon sugar
One egg
2 tablespoon olive oil
1-1/2 cups low fat milk
One small banana, cubed
1/4 cup sunflower seeds, toasted

Directions:
Combine the flour, oats, baking powder, cinnamon, nutmeg and sugar in a bowl. Add the remaining ingredients and blend.

Spoon into oiled muffin tins or paper muffin cups.

Bake in a 375-degree oven for 15 to 20 minutes.

Recipe makes 12 muffins.

Nutritional Information per muffin:
Calories: 180
Carbohydrates: 29
Protein: 5
Fat: 5
Sodium: 91
Cholesterol: 23
Exchange value: 1 bread exchange + 1 fruit exchange + 1 fat exchange

Yield: 12 muffins

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Banana-Oatmeal Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Banana-Oatmeal Bread

Ingredients:
2-1/4 cup all-purpose flour
2/3 cup honey-crunch wheat germ
1/2 cup oats, uncooked
1/4 cup brown sugar, packed
1 tablespoon baking powder
1/2 teaspoon salt
1/4 teaspoon baking soda
10 tablespoons light corn oil spread
1-1/2 cup mashed bananas, about 3 medium-sized
One, 6-ounce can frozen apple-juice concentrate, thawed
1/2 cup egg substitute, thawed
1/3 cup walnuts, chopped
1 teaspoon vanilla extract

About two hours before serving, or early in the day:
Preheat oven to 350-degrees. Spray a 9"x5" loaf pan. In large bowl, mix first seven ingredients. With pastry blender, cut in corn oil spread until mixture resembles coarse crumbs.

Stir in bananas, undiluted apple-juice concentrate, egg substitute, walnuts, and vanilla just until flour is moist. Spoon batter into pan.

Bake 60 minutes or until toothpick inserted into center of bread comes out clean. Cool bread in pan on a wire rack for ten minutes; remove from pan and cool slightly. Serve warm, or cool completely to serve later.

Recipe makes 18 servings.

Nutritional information per serving:
Calories: 180
Cholesterol: 0
Sodium: 130mg
Diabetic exchanges: one starch, one fruit, and one of fat

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Oatmeal Bran Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Bran Bread

Ingredients:
1 cup oatmeal
2 cups water
1/4 cup light or dark molasses
2 tablespoons olive oil
1/2 teaspoon salt 1 package of active dry yeast (1 tablespoon)
1/2 cup warm water (110-115-degrees) 1 cup bran
1/4 cup soy flour
1/2 cup wheat germ
3 cups whole wheat flour

Directions:
Cook the oatmeal according to directions in two cups of water. Add the molasses oil and salt. Cool to lukewarm.

Dissolve the yeast in the warm water and add to the oatmeal mixture. Stir in the bran, soy flour, and wheat germ.

Beat in the whole-wheat flour, adding a little at a time, until the dough is stiff. Knead the dough on a floured surface until it is smooth and elastic.

Cover with a damp towel and let rise in a lightly oiled bowl until mixture doubles. Punch down and knead again until smooth and elastic.

Divide the dough into two loaves. Shape and put into lightly oiled bread pans. Let rise until doubled.

Bake in a 375-degree oven about 40 minutes, or until brown and sounds hollow when tapped on top. Remove from pan immediately and cool on wire rack.

Recipe makes two loaves.

Food energy per slice (1/15 of one loaf): 79 calories.

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Jumbo Fruited Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Jumbo Fruited Oatmeal Cookies

Ingredients:
3/4 cup butter, softened
3 eggs
3/4-cup apple juice, concentrate
1-1/2 teaspoon vanilla
1-1/2 cup flour
1-1/2 cup oats
1/2 teaspoon baking soda
1/2 teaspoon salt
1/2 teaspoon cinnamon, ground
1/2 teaspoon allspice, ground
Six ounces fruit, dried mixed
1/2 cup nuts, chopped

Directions:
Chop fruit. Preheat oven to 350-degrees.

Beat butter in large bowl until creamy. Blend in eggs, apple juice concentrate, and vanilla. Add flour, oats, baking soda, salt, cinnamon, and allspice; mix well. Stir in dried fruit and nuts. Drop scant ј-cupfuls of dough, 3-inches apart, onto lightly greased cookie sheets; flatten slightly. Bake 12-14 minutes, until edges are lightly brown. Cool one minute on cookie sheets, then transfer to wire racks to cool completely. Store in tightly covered container.

Recipe makes 18 servings.

Nutrition information per cookie:
Calories: 209
Protein: 4g
Carbohydrate: 24g
Fat: 11g
Calories from fat: 32%
Cholesterol: 56g
Sodium: 239mg
Diabetic Exchanges: 1 diabetic starch/bread exchange, 2-ј diabetic fat exchange, Ѕ diabetic fruit exchange.

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Special Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Special Oatmeal Cookies

Ingredients:
1-1/2 cups rolled oats
2/3 cup butter, melted
Four egg -whites
1 cup granulated artificial sweetener
1 1/2 cups all-purpose flour
1/2 teaspoon salt
2 teaspoons baking powder
1/2 cup milk
1 teaspoon vanilla extract
1/2 cup raisins
1/2 cup chopped walnuts

Directions:
Preheat oven to 375-degrees. Grease cookie sheets.

Stir together the oatmeal and margarine. Blend in the egg whites and sweetener. Stir together the flour, salt and baking powder; add to the mixture alternately with the milk and vanilla; stirring between additions. Finally, stir in the raisins and walnuts.

Drop by teaspoonfuls 1 to 2 inches apart onto the prepared cookie sheets. Bake for 10 to 15 minutes in the preheated oven.

Recipe makes approximately three-dozen cookies.

Nutrition information per serving:
Calories: 241
Fat: 10g
Cholesterol: 19g
Sodium: 209mg
Protein: 18g
Carbohydrate: 21g

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Oatmeal Cookies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Cookies

Ingredients:
1/2 cup margarine
1/4 cup sugar
1/4 cup brown sugar
Dry sugar substitute equal to ј-cup of sugar
1/4 cup egg, whites
1 teaspoon vanilla
1/2 teaspoon black walnut flavoring
ј cup water, at room temperature
1-1/2 cup all-purpose flour
1 teaspoon baking soda
1/4 teaspoon salt
1/2 cup black or English walnuts -chopped

Directions:
Cream margarine, sugars and dry sugar substitute together at medium speed until light and fluffy. Add egg whites, flavorings, and water, and mix at medium speed for 30 seconds, scraping down the bowl before and after adding egg whites, flavorings, and water. Stir flour, baking powder, salt, oatmeal and walnuts together to blend, and add to creamy mixture. Mix to blend.

Drop dough by 1-Ѕ teaspoonful onto cookie sheets sprayed with pan spray or lined with aluminum foil. Press each cookie down lightly with the back of a tablespoon dipped in color water.

Bake at 350-degrees for 12 to 14 minutes, or until cookies are lightly brown. Remove them to a wire rack and cool to room to temperature.

Recipe makes approximately 24 cookies.

Food exchanges per serving: 1 starch/bread exchange + 1 fat exchange

Nutrition information per serving:
Calories: 122
Fat: 6g
Sodium: 209mg
Protein: 1.5g
Carbohydrate: 21g

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Oatmeal Recipe List | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Recipes for Diabetics

Button Oatmeal Pancakes

Button Peach Oat Bran Muffins

Button Oatmeal-Banana Muffins

Button Banana-Oatmeal Bread

Button Oatmeal Bran Bread

Button Jumbo Fruited Oatmeal Cookies

Button Special Oatmeal Cookies

Button Oatmeal Cookies

Button Pumpkin-Oatmeal Bars

More oatmeal recipes in the cookies section!

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

Back
Table of Contents


Oatmeal in the Diabetic Diet | Fitness and Freebies

Oatmeal in the Diabetic Diet

Living with diabetes is not easy.

It involves sacrifice and change, as you well know.

That is why this section on oatmeal is so important. The fiber in oatmeal may slow the absorption of carbohydrates to help you maintain a healthy blood sugar level. It would do you well to incorporate oatmeal into your diet in as much a variety as possible.

Moreover, more than 40 scientific studies show that eating oatmeal can help lower blood cholesterol levels. Experts believe it's the soluble fiber found in oats that helps reduce blood cholesterol levels.

The oatmeal recipes will help you do just that!

Next
Oatmeal Recipes

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Oatmeal Pancakes | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Oatmeal Pancakes

Mix together:
1-1/2 cup oatmeal
1/2 cup whole wheat flour
2 teaspoons baking powder
1 teaspoon cinnamon

Beat in:
1 cup low-fat milk
One egg
1 tablespoon olive oil
1/4 cup raisins

Directions:
Lightly oil a frying pan and spoon batter on by tablespoon turning when the top bubbles.

Notes: The pancakes are great for lunch sandwiches too. The oatmeal is especially good with peanut butter.

Yield: nine pancakes.

Food exchanges per serving:
3 pancakes = 3 starch/breads exchange + 1 fruit exchange + 1 milk exchange + 1 fat exchange

Calories: 484
Protein: 18gm
Fat: 12gm
Carbohydrates: 76gm

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Peach Oat Bran Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peach Oat Bran Muffins

Ingredients:
3/4 cup pecans
1/2 cup date pieces
2 1/2 cup chopped peaches
1/2 cup fruit sweetener
Two eggs
Ѕ cup oil
1 teaspoon vanilla extract
2 teaspoon peach extract
1 1/4 cup unsweetened applesauce
1 cup oat bran
3/4 cup rolled oats
2 cups brown rice flour
1/3 cup oat flour
2-1/2 teaspoon baking powder
1 teaspoon baking soda
Ѕ teaspoon salt
2 teaspoons cinnamon
Ѕ teaspoon nutmeg

Directions:
Preheat oven to 375-degrees. Lightly spray a regular-size muffin tin with lecithin spray.

Notes: The pancakes are great for lunch sandwiches too. The oatmeal is especially good with peanut butter.

Toast the pecans in the oven for 7-10 minutes, stirring occasionally. Allow the nuts to cool and then coarsely chop them with a knife or with a pulsing action in a food processor.

Coarsely chop the peaches.

In a medium size bowl, mix the fruit sweetener, eggs, oil, vanilla, peach extract and applesauce together. Stir in the oat bran and the rolled oats.

Let this mixture sit for a minimum of ten minutes while you prepare the rest of the ingredients.

Sift the dry ingredients into a large bowl, stir in the pecans and the date pieces. Make a well in the center of the dry ingredients, and stir in the wet mix. When half mixed, stir in the chopped peaches. Be careful not to over mix, the muffin batter should be lumpy.

Use a #12 (Ѕ-cup) scoop to place the batter into the prepared muffin tins. Bake the muffins in the preheated oven for 35-40 minutes.

NOTES: Let the muffins cool in the muffin pans before removing them. Take extra care when handling these muffins because they are very fragile when warm.

Yield: 12 muffins

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Pumpkin-Oatmeal Bars | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pumpkin-Oatmeal Bars

Ingredients:
1/3 cup sugar
1/2 cup olive oil
1 egg
1 cup canned or cooked pumpkin
1-1/2 cup whole wheat flour
3 teaspoons baking powder
Ѕ teaspoon baking soda
ј teaspoon ground nutmeg
1-1/2 teaspoon ground cinnamon
ј teaspoon ground cloves
Ѕ cup orange juice
Ѕ cup chopped walnuts
Ѕ cup raisins (dark or golden)
ј cup coconut

Directions:
Cream together the sugar, oil, egg, and pumpkin until light and fluffy. Stir in the flour, baking powder, soda, nutmeg, cinnamon, coves and orange juice. Add the walnuts and raisins. Mix to blend.

Stir to blend. Pour into a lightly oiled 9-by-13-inch pan.

Sprinkle on the coconut. Bake in a 350-degree oven for 25 to 30 minutes.

Cool the pan completely on a wire rack for five minutes. Cut into bars.

Recipe yields about 24 cookies.

Next

To Your Health!
Fitness and Freebies

space Oatmeal Pancakes | Oatmeal-Banana Muffins | Banana-Oatmeal Bread | Oatmeal Bran Bread | Jumbo Fruited Oatmeal Cookies | Special Oatmeal Cookies | Oatmeal Cookies | Pumpkin-Oatmeal Bars |


Orange Juice Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Orange Juice Muffins

Ingredients:
2 cups all purpose flour
7-1/4 teaspoons sugar substitute for recipes or 24 packets or 1-cup measurable sugar substitute
2 teaspoons baking powder
1/8 teaspoon salt
1 cup orange juice
4 tablespoons margarine, melted
2 egg whites, slightly beaten or egg substitute equivalent to one egg
1 teaspoon grated orange rind

Directions:
Combine flour, sugar substitute, baking powder and salt in a large bowl. Add orange juice, margarine, egg and orange rind. Mix well. Spray muffin tins with non-stick cooking spray. Fill tins 2/3 full. Bake at 375-degrees for 20 to 25 minutes. Cool on wire rack.

Recipe makes about nine muffins.

Nutrition information per serving:
Calories: 177
Fat: 3g
Carbohydrate: 27g
Cholesterol: 24mg
Sodium: 208mg
Protein: 4g
Exchanges: 2 Starch/Bread, 1 Fat

Next
Marvelous Bran Muffins

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Orange Chocolate Chip Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Orange Chocolate Chip Bread

Ingredients:
3 cups reduced-calorie all-purpose baking mix
1 cup skim milk
1/4 cup fresh orange juice
One large egg
1 tablespoon grated orange peel
Granulated sugar substitute to equal 1/2-cup sugar
1 teaspoon vanilla extract
1/2 cup semi-sweet chocolate mini chips

Directions:
Preheat oven to 350-degrees. Spray 9 X 5 X 2-3/4-inch loaf pan with vegetable cooking spray.

Place baking mix in medium bowl. Combine milk, orange juice, egg, orange peel, sugar substitute and vanilla; add all at once to baking mix. Beat until well blended, about one minute. Stir in small chocolate chips. Spoon batter into prepared pan.

Bake 40 to 56 minutes or until wooden pick inserted in center comes out clean. Cool ten minutes. Remove from pan to wire rack. Cool completely. Wrap in foil or plastic wrap; store overnight before slicing.

Variation:
Orange Chocolate Chip Muffins: Heat oven to 350-degrees. Paper-line or spray 16 muffin cups (2-1/2-inches in diameter) with vegetable cooking spray. Prepare as directed above. Fill muffin cups 2/3 full. Bake 12 to 15 minutes or until wooden pick inserted in center comes out clean.

Nutrition information per serving:
Calories: 120
Protein: 3g
Total Fat: 3g
Carbohydrate: 20g
Cholesterol: 0mg
Sodium: 260mg
Exchanges: 2 carbohydrate (1 bread/starch, 1 fruit), 1/2 fat

Next
Succulent Zucchini Bread

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


The Diabetic Pantry | Fitness and Freebies

The Diabetic Pantry

Basically, one could say cooking for diabetes is cooking healthy on a daily basis. Following are some items you may wish to keep on hand at all times.

Vinegar
Balsamic, fruit-infused, herb-infused, red wine, white wine, sherry, malt, rice wine, cider

Cooking Sprays
Now available in aerosol and refrigerated pumps. Purchase butter-flavored, olive oil, vegetable, etc.

Oils
Canola, olive, safflower, sesame. For added flavor you may wish to try almond, avocado, grapeseed, hazelnut, peanut, and walnut

Grains
Stone-ground yellow and white cornmeal, couscous, kasha, millet, rolled oats, instant polenta, rice-white, basmati, brown, quick-cooking and wild, quinoa.

Beans and Legumes
Dried beans-black, cannellini, chick peas, navy, pinto and white, black-eyed peas, lentils-brown and red.

Pasta
Angel hair, bow ties (farfalle), lasagna, linguine, penne, Oriental rice sticks, rotelle, spaghetti, ziti

Baking Needs
Unbleached all-purpose flour, nonfat pancake mix, graham cracker crumbs, cornstarch, dry bread crumbs (unseasoned), baking powder, baking soda, cream of tarter, cocoa powder, salt and kosher salt, vanilla extract, sugar substitutes (capable of retaining sweetness during extended heat), sugar, brown sugar, honey, baker's spray (combined with flour).

Canned and Packages Goods
No-salt-added tomato paste, no-salt-added canned tomatoes, canned pumpkin, unsweetened fruit juices, fat-free no-salt-added chicken and vegetable broth, cannellini, garbanzo (chick peas), navy, pinto, white and black beans, beans, reduced-sodium soy sauce, no-sugar-added fruit spread, dry roasted peanuts, natural peanut butter, no-sugar added dried fruits, evaporated skim milk, powdered buttermilk, Worcestershire sauce, hot pepper sauces, regular and coarse ground Dijon mustard, dry red and white wine for cooking, cognac for cooking, dry sherry for cooking, rum for cooking, tequila for cooking, hoisin sauce, sun-dried tomatoes (dry-packed), black bean sauce, Asian chili sauce, capers, garlic sauce, dried chiles, dried mushrooms

Dried Herbs and Spices
Ground allspice, basil, bay leaves, dill, caraway seed, celery seed, chili powder, ground cinnamon, cloves, coriander, ground cumin, curry powder, fennel seed, fines herbes, ground ginger, marjoram, dry mustard, paprika, peppercorns, poppy seeds, crushed red pepper flakes, rosemary, sage, saffron, savory, sesame seeds, thyme

In the Freezer
Frozen no-sugar-added fruits and berries, puff pastry dough, filo dough, bread dough, unsalted butter, reduced-calorie margarine, nuts, vegetables in bags, multi-grain breads and rolls, pita

In the Refrigerator
Part-skim Parmesan cheese, fat-free mozzarella cheese, fat-free ricotta cheese, fat-free cream cheese, reduced-fat tub margarine, fat-free sour cream, fresh ginger, lemons, limes, oranges, other fresh fruit in season, scallions, fresh herbs and parsley, salad ingredients, fresh vegetables in season, dill pickles, tomato paste in a tube, anchovy paste in a tube, egg substitute, eggs, skim milk

Miscellaneous
Garlic; shallots; onions-white, yellow, sweet (seasonal), and red; potatoes-red, Russet, and Yukon Gold; sweet potatoes

Next
Baking With Sugar Substitutes

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Peanut Butter "Pie" | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peanut Butter "Pie"

Cookie crust ingredients:
2 cups biscuit mix
1/4 cup pecan pieces
2/3 cup pitted dates
Two egg whites
1 teaspoon vanilla
3 tablespoons warm water
6 tablespoons butter

Filling ingredients:
Two small bananas, thinly sliced
3 cups 1% milk
2/3 cup smooth unsweetened peanut butter
6-serving package non-instant sugar-free vanilla pudding
2 tablespoons finely chopped pecans (reserved)
Directions:
Preheat oven to 350-degrees.

Crust:
Use a blender or food processor to chop pecan pieces until finely ground. Sift biscuit mix, and stir in 1/4-cup pecans. Set aside.

Use a food processor or blender to purйe dates, gradually adding egg whites and warm water. Beat several minutes until creamy. Melt butter, and then stir in date cream and vanilla. Fold liquid ingredients into biscuit mix. Stir only until blended.

Press the moist dough to the edges of a 9 x 11-inch pan or into two 9-inch pie pans. The crust will be about 1/4-inch thick.

Bake seven to ten minutes at 350-degrees until light brown on top edges. Set aside.

Filling:
Leave oven at 350 degrees.

Distribute banana slices on the baked cookie crust; set aside.

Warm peanut butter in microwave oven until "melted." Whisk peanut butter and vanilla pudding powder into milk. Heat on medium, stirring constantly, until at a full boil and smoothly blended.

Pour hot pudding mix evenly over banana slices, just covering the edges of the crust. Sprinkle 2-tablespoons finely chopped pecans on top.

Bake at 350-degrees for seven to ten minutes. Allow at least 20 minutes to cool and set. Serve warm or at room temperature.

Recipe makes 18, 2-by-3-inch servings.

Next
Key Lime Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Peach Almond Upside Down Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Peach Almond Upside Down Cake

Ingredients:
One can (8-1/4 ounces) light peaches in fruit juice
1 teaspoon baking powder
1/2 cup unsweetened applesauce
1/4 teaspoon baking soda
3/4 cup measurable sweetener
1/2 teaspoon ground cinnamon
1/8-1/4 teaspoon ground nutmeg
1/4 teaspoon salt
One egg
1/2 cup buttermilk
1/2 teaspoon vanilla Fruit Topping (recipe below)
1 cup cake flour
1/4 cup sliced almonds, toasted

Directions:
Cut peach slices into thirds; arrange in bottom of lightly greased 8-inch cake pan.

Mix applesauce, sweetener, egg and vanilla until smooth in medium bowl. Mix in combined cake flour, baking powder, baking soda, cinnamon, nutmeg, and salt alternately with buttermilk, beginning and ending with dry ingredients. Pour batter over peach slices in pan.

Bake in preheated 350-degrees oven until cake is browned and toothpick inserted in center comes out clean, about 20 minutes. Invert cake immediately onto serving plate. Spread Fruit Topping over warm cake and sprinkle with almonds.

Serve warm.

Recipe makes eight servings.

Next
Easy Carrot Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Green Split Pea and Barley Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Green Split Pea and Barley Soup

Ingredients:
2 cups green split peas, rinsed and drained
Three carrots, chopped
Three or four stalks celery, chopped
One medium onion, chopped
12 cups water, chicken or vegetable broth
1/2 cup pearl barley, rinsed and drained
One bay leaf
Salt and pepper, to taste
2 cloves crushed garlic, if desired
2 teaspoons canola oil
2 medium onions, chopped
1/4 cup chopped fresh dill

Directions:
In a large soup pot, combine split peas, carrots, celery and 1 onion with water. Bring to a boil. Stir in barley, bay leaf and garlic, if using. Reduce heat and simmer partly covered for 1-1/2 to 2 hours. Stir occasionally. Add salt and pepper to taste.

In a nonstick skillet, heat oil. Saute the remaining two onions on medium heat until well-browned, about 6 to 8 minutes. Add onions to soup along with dill. Simmer soup five to ten minutes longer. Discard bay leaf (and turkey carcass, if using).

Reheats and/or freezes well. If soup gets thick, add a little water or broth.

Recipe makes 12 servings.

Nutrition information per serving:
Calories: 152
Fat: 1.3g
Cholesterol: 0
Sodium: 31mg
Carbohydrate: 21g
Protein: 8g
Exchanges: 1/2 Starch/Bread; 3 Vegetable

Next
Quick Minestrone

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Pear Spice Muffins | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pear Spice Muffins

Ingredients:
One, 16-ounce can pears, drained and diced
3/4 cup apple juice concentrate
1-1/2 Tablespoons vanilla
3/4 cup unbleached white flour
2 teaspoons baking soda
3/8 teaspoon lite (or regular) salt
1-1/2 teaspoons cinnamon
1/4 teaspoon nutmeg
1 cup wheat bran
2-1/2 tablespoons olive oil or safflower oil Two egg whites or 1/3-cup egg substitute
1/3 cup currants plumped (or raisins, if currants unavailable)

Directions:
Preheat oven to 350-degrees.

Combine apple juice concentrate and vanilla. Soak chopped pears in this mixture while preparing the remaining ingredients.

Preheat oven to 350-degrees. Meanwhile, mix together dry ingredients: flour, soda, salt, cinnamon, nutmeg, and bran.

Add oil, lightly beaten egg whites, and plumped currants to the pear mixture, and gently stir. Pour this over the dry ingredients, and mix with a fork, just until moistened. Fill muffin cups 3/4 full, and bake at 350 degrees for 13 to 18 minutes.

Muffins are done when they spring back to the touch or a toothpick inserted comes out clean.

Let cool 10-15 minutes.

Note: If you cannot use sugar at all, you can subsitute honey, applesauce, or natural fruit.

Recipe makes 12 muffins.

Next
Branapple Muffin

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Black Pepper Ring Biscuits | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Black Pepper Ring Biscuits

Ingredients:
12 eggs
1/2 cup butter, melted
1/3 cup vegetable oil
6 cups all-purpose flour
1 tablespoon salt
2 tablespoons coarsely ground black pepper
3 tablespoons baking powder

Directions:
Bring a large pot of water to boil over medium-high heat. Preheat oven to 450-degrees. In a large bowl, beat eggs. Stir in melted butter and oil. In a Separate bowl, mix together flour, salt, pepper and baking powder.

Make a well in the center of the flour mixture and pour in the egg mixture. Mix until dough pulls together. Turn dough out onto a lightly floured surface and knead briefly. Divide dough into 12 equal pieces.

Roll each piece into an 8-inch long cylinder. Bend each cylinder into a ring shape and pinch ends together. With a sharp knife, score each ring around its outside edge. Drop rings two at a time into boiling water and boil for one minute. Remove rings from water and place on lightly greased cookie sheets. Bake in preheated oven for 20 minutes, until golden brown.

Recipe makes 12 servings.

Next
Date-Nut Coffee Cake

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Pickled Carrots | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pickled Carrots
Variations Follow

Ingredients:
1 pound baby carrots, peeled
1/2 teaspoon dried dill weed
1 teaspoon mustard seed

Pickling Solution:
3/4 cup cider vinegar
1/2 cup water
1/2 teaspoon pickling spices
12 whole black peppercorns

Directions:
Trim carrots so they fit vertically 3/4-inch below the rim of a wide-mouth pint glass jar.

In a large skillet, cook carrots in water to cover until crisp-tender, about 5 minutes. Drain.

Loosely pack carrots vertically into a sterilized wide-mouth point glass jar along with dill weed and mustard seed.

In a small saucepan, bring pickling solution ingredients to a boil. Pour hot liquid over carrots to cover. Reserve any extra liquid.

Cover and refrigerate. If needed, add reserved liquid after carrots are chilled to keep carrots covered with liquid. Use within one week.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 28
Total Fat: trace
Saturated Fat: 0g
Cholesterol: 0mg
Sodium: 16mg
Carbohydrate: 6g
Fiber: 1g
Protein: 1g
Exchanges: Free Food

VARIATIONS:
Pickled Asparagus: Follow the recipe for Pickled Carrots, using 1-1/2 pounds pencil-thin asparagus, tough ends timed, in place of the carrots. Cook in boiling water until barely tender, about five minutes. Drain, immerse in ice water, then drain again. Pack asparagus vertically into jar along with four fresh tarragon sprigs in place of the dill and mustard seed. Fill jar with hot pickling solution. Refrigerate; use within one week. Makes ten servings. Per serving: 24 calories, 4 g carbohydrate.
Exchanges, free.

Pickled Green Beans: Follow the recipe for Pickled Carrots, suing 3/4 pound small green beans, ends trimmed, in place of carrots. Cook beans in boiling water until just tender, about three minutes. Drain, immerse in water, and drain again. Pack beans vertically in sterilized jar along with two small dried red chile peppers and 1-teaspoon cumin seed in place of the dill and mustard seed. Fill jar with hot pickling solution. Refrigerate; use within one week. Makes ten servings. Per serving: 13 calories, 4 g carbohydrate.
Exchanges: free

Pickled Okra: Follow the recipe for Pickled Carrots, using 3/4-pound fresh okra, about 3-inches long, instead of the carrots. Trim stems, taking care not to cut into the okra itself. Place 1 peeled garlic clove, 1-teaspoon dill seed, 1- teaspoon celery seed, 1/4-teaspoon mustard seed, and one small dried red chile pepper in the sterilized jar instead of the dill weed and mustard seed. Pack okra vertically in jar, stem end up. Fill jar with hot pickling solution. Refrigerate; use within one week. Makes ten servings. Per serving: 13 calories, 4 g carbohydrate.
Exchanges, free.

Apricot or Peach Vinegar: Sterilize two quart glass canning jars with lids. Peel, pit, and coarsely chop 1-1/2 pounds of fresh ripe apricots or peaches. Divide the fruit between the two jars. Add a 3-inch cinnamon stick that has been broken into three pieces to each jar. Fill each jar with about 1-1/2-cup white wine vinegar, making sure the fruit is covered by the vinegar. Run a narrow spatula between the fruit and the jar to remove any air bubbles. Cover and refrigerate for two weeks.
Sterilize two 12-fluid ounce decorative vinegar bottles with lid. Strain the vinegar mixture through a fine sieve, then through a coffee filter, discarding the solids. Pour the strained vinegar into the two prepared bottles. Seal and store at room temperature. Use within two months. Once opened, refrigerate.
Exchanges: free.

Lemon Rosemary Vinegar: Sterilize two 12-fluid ounce decorative vinegar bottles with lid. Place 2 fresh rosemary sprigs and 2 long strips of lemon zest in each bottle.
In a medium saucepan, bring 3-cups red wine vinegar to a boil. Using a funnel, pour hot vinegar into bottles, dividing equally. Seal and let stand at room temperature for two weeks to develop flavors before using. Use within six months. Once open, refrigerate.
Note: Don’t try to make this vinegar with cloves of garlic. Home preparation does not sufficiently process raw garlic so that it and the vinegar stay fresh.

Next
Broccoli with Black Olives

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Pies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pie Pies

Button Blueberry Pie

Button Blueberry Yogurt Pie

Button Blueberry Lemon Pie

Button Equal Lemon Meringue Pie

Button Lemon Meringue Pie

Button Easy Lemon Pie

Button Dutch Apple Pie

Button Apple Cranberry Streusel Pie

Button Banana Cream Pie

Button Banana Yogurt Pie

Button Glazed Blackberry Pie

Button Bavarian Cream Pie

Button Chocolate Raspberry Cream Pie

Button Chocolate Covered Cherry Pie

Button Brownie Sunday Pie

Button Cream Cheese Peanut Butter Pie

Button Peanut Butter "Pie"

Button Key Lime Pie

Button Nectarine and Berry Pie

back
Main Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Pizza Pockets | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pizza Pockets

Ingredients:
One 10-ounce can refrigerated pizza dough
1/4 cup jarred pizza sauce
1 cup part-skim shredded mozzarella cheese
1/4 cup reduced-fat ricotta cheese
1 teaspoon crushed dried oregano
Vegetable cooking spray

Directions:
Open dough can and place on a work surface. Roll out and cut two 6-inch circles. Rework scraps, roll out, and cut out another two 6-inch circles for a total of four circles. Discard remaining scraps.

Place the dough circles on the work surface. Spread each circle with 1-tablespoon pizza sauce to within 1/4-inch of the edge. Place 1/4-cup of the mozzarella cheese near the center of each circle. Top each with 1 tablespoon ricotta cheese and sprinkle with 1/4-teaspoon oregano.

Dampen the edges of each circle with a little water. Fold circles in half, enclosing the cheese filling. Crimp the edges by pressing down with the tines of a fork along the edge. Cut two small slits in the top for steam vents. Cover and refrigerate until ready to bake.

Preheat oven to 425-degrees.

Lightly coat a baking sheet with cooking spray. Place pizza pockets on prepared baking sheet. Bake until golden brown, about ten minutes.

Allow to cool for a few minutes before eating.

Recipe makes four servings.

Nutrition information per serving:
Calories: 266
Total Fat: 8g
Saturated Fat: 4.0g
Carbohydrate: 33g
Cholesterol: 19mg
Sodium: 593mg
Fiber: 1g
Protein: 15g
Calories from fat: 27%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1 medium fat protein, 2 carbohydrate (bread/starch)

Next
Cheese Balls

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Yogurt Popsicles | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Yogurt Popsicles

Ingredients:
3 cups plain nonfat yogurt
2/3 cup no-sugar-added strawberry syrup
1/2 cup sliced fresh strawberries
6 paper cups
6 wooden popsickle sticks

Directions:
Blend yogurt and syrup. Lightly mash strawberries with a fork or potato masher.

Place paper cups in a muffin tin. Divide the yogurt equally between the paper cups. Add and equal amount of the mashed strawberries to each cup. freeze until slushy, about 30 minutes. Insert a wooden stick into each cup for a handle.

Freeze until firm. Peel off paper cups before eating. (Once frozen, store popsicles in a self-sealing plastic bag.)

Recipe makes six servings.

Nutrition information per serving:
Calories: 126
Total Fat: trace
Saturated Fat: 0.1g
Carbohydrate: 24g
Cholesterol: 0mg
Sodium: 98mg
Fiber: 1g
Protein: 8g
Calories from fat: 2%
Exchanges: 2 carbohydrate (1 fruit, 1 skim milk)

Next
Frozen Strawberry Pops

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Frozen Strawberry Pops | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Frozen Strawberry Pops

Ingredients:
Eight large ripe strawberries, hulled and cut into quarters
2/3 cup frozen pineapple juice concentrate, slightly thawed
2 8-ounce cans sugar-free lemon-lime soda

Directions:
Place the strawberries in a food processor or blender. Add the pineapple juice concentrate and pulse until fairly smooth.

Stir in the sugar-free soda until well blended.

Pour mixture into eight 6-ounce paper cups. Freeze for 30 minutes, then stick a clean wooden popsicle stick into the middle of each pop. Freeze for at least three hours.

To serve, Let stand at room temperature just until you can peel off the paper cup. Eat at once.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 49
Total Fat: 0g
Saturated Fat: 0g
Carbohydrate: 12g
Cholesterol: 0mg
Sodium: 3mg
Fiber: 1g
Protein: 1g
Calories from fat: 0%
Exchanges: 1 carbohydrate (1 fruit)

Next
Frozen Grape Pops

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Frozen Grape Pops | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Frozen Grape Pops

Ingredients:
1 6-ounce frozen grape juice concentrate, thawed
2 cups fat-free, no sugar added vanilla ice cream, softened

Directions:
In a food processor blender, combine the grape juice concentrate and ice cream until smooth.

Pour into six 6-ounce paper cups. Freeze for about one hour, then insert a wooden popsicle stick in the middle of each cup. Freeze for at least three hours.

Pour mixture into eight 6-ounce paper cups. Freeze for 30 minutes, then stick a clean wooden popsicle stick into the middle of each pop. Freeze for at least three hours.

To serve, let stand at room temperature for a minute or two, until you can peel away the paper cup. Eat at once.

Recipe makes six servings.

Nutrition information per serving:
Calories: 118
Total Fat: 0g
Saturated Fat: 0g
Carbohydrate: 28g
Cholesterol: 0mg
Sodium: 47mg
Fiber: 0g
Protein: 3g
Calories from fat: 0%
Exchanges: 2 carbohydrate (1 bread/starch, 1 fruit)

Next
Chocolate Yogurt Pops

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Chocolate Yogurt Pops | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Yogurt Pops

Ingredients:
8 ounces (240 g) plain nonfat yogurt
1/4 cup (45 g) sugar-free cocoa mix
4 6-ounce (180 ml) paper cups

Directions:
In a bowl, combine yogurt and cocoa mix. Mix well. Spoon into paper cups and set the cups in a muffin tin. Insert a wooden popsicle stick in the middle of each cup. Freeze solid.

To serve peel away the paper cup and eat at once.

Recipe makes four servings.

Nutrition information per serving:
Calories: 66
Total Fat: trace
Saturated Fat: 0g
Carbohydrate: 10g
Cholesterol: 3mg
Sodium: 132mg
Fiber: 1g
Protein: 6g
Calories from fat: 5%
Exchanges: 1 carbohydrate (skim milk)

Next
No Drip Popcicles

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


No Drip Popcicles | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

No Drip Popcicles

Ingredients:
1 cup boiling water
One (3 ounce) package fruit flavored gelatin mix
One banana
1 cup plain yogurt

Directions:
Combine boiling water and gelatin in a blender and pulse until gelatin is dissolved. Blend in banana until smooth, then blend in yogurt. Pour mixture into popsicle molds or small, plastic drinking cups and freeze until hard. (If using drinking cups, freeze until firm, insert popsicle sticks, then freeze completely.)

Next
Frozen Bananas

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Popcorn Treat | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Popcorn Treat

Ingredients:
2 cups popped popcorn
Three egg whites
1/2 teaspoon baking powder
1/4 teaspoon salt
1/4 teaspoon cream of tartar
2 tablespoons granulated artificial sweetener

Directions:
Preheat oven to 350-degrees. Lightly grease cookie sheets. Place popped popcorn into a food processor or blender; grind into small kernels.

In a large bowl, whip egg whites until frothy. Add baking powder, salt and cream of tartar; continue whipping to stiff peaks. Gradually mix in the sugar substitute. Fold in the popcorn pieces. Drop by teaspoonfuls onto the prepared cookie sheets.

Bake for 12 to 15 minutes in the preheated oven, or until lightly browned. Allow cookies to cool on cookie sheets before removing.

Note:
If you can't use sugar for various reasons, you can always subsitute with honey,applesauce, or natural fruit.

Next
Dilled-Ranch Popcorn

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Dilled-Ranch Popcorn | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Dilled-Ranch Popcorn

Ingredients:
4 quarts air-popped popcorn
Refrigerated butter-flavored cooking spray
One 1-ounce ranch-style dip mix
1 teaspoon dried dill weed
1/2 teaspoon onion powder
1/4 teaspoon dried lemon peel

Directions:
Put popcorn in a large bowl and lightly coat with cooking spray. Sprinkle with remaining ingredients. Toss and spray again. Toss again and serve.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 71
Total Fat: 1g
Saturated Fat: 0.1g
Carbohydrate: 15g
Cholesterol: 0mg
Sodium: 249mg
Fiber: 3g
Protein: 2g
Calories from fat: 9%
Exchanges: 1/2 carbohydrate, 3 fat

Next
Asian Popcorn

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Asian Popcorn | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Asian Popcorn

Ingredients:
8 cups air-popped popcorn
One 3-ounce can chow mein noodles
Refrigerated butter-flavored cooking spray
2 teaspoons low-sodium soy sauce

Directions:
Preheat oven to 300-degrees.

In a large baking pan, combine popcorn and chow mein noodles. Lightly coat with cooking spray. Toss to evenly coat. Drizzle with soy sauce and toss again.

Bake for ten minutes, stirring once. Let cool for ten minutes before eating.

Recipe makes four servings.

Nutrition information per serving:
Calories: 169
Total Fat: 1g
Saturated Fat: 1.1g
Carbohydrate: 26g
Cholesterol: 0mg
Sodium: 260mg
Fiber: 4g
Protein: 6g
Calories from fat: 28%
Exchanges: 1-1/2 carbohydrate (bread/starch), 1 fat

Next
Nacho Popcorn

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Nacho Popcorn | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Nacho Popcorn

Ingredients:
4 quarts air-popped corn Refrigerated butter-flavored cooking spray
2 teaspoons ground cumin
2 teaspoons garlic powder
2 teaspoons onion powder
2 teaspoons Worcestershire sauce
1/4 teaspoon Tabasco (optional)

Directions:
Preheat oven to 300-degrees. Spread popped corn in a large baking pan. Lightly coat with cooking spray. Toss and coat again.

Combine cumin, garlic powder, and onion powder. Sprinkle over popcorn. Toss to coat evenly. Drizzle with Worcestershire sauce and Tabasco (if using). Toss again. Bake for ten minutes, tossing once. Wrap tightly in a pouch made from a double sheet of heavy-duty aluminum foil.

Recipe makes 12 servings.

Nutrition information per serving:
Calories: 45
Total Fat: 1g
Saturated Fat: 0g
Carbohydrate: 2g
Cholesterol: 0mg
Sodium: 11mg
Fiber: 2g
Protein: 2g
Calories from fat: 10%
Exchanges: 1/2 carbohydrate (bread/starch)

Next
Honey Crunch Popcorn

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Honey Crunch Popcorn | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Honey Crunch Popcorn

Ingredients:
12 cups hot air-popped popcorn
1/2 cup chopped pecans
1/2 cup firmly packed brown sugar
1/2 cup honey

Directions:
Preheat oven to 300-degrees. Spray large nonstick sheet with nonstick cooking spray. Combine popcorn and pecans in large bowl; mix lightly. Set aside. Combine brown sugar and honey in small saucepan. Cook over medium heat just until brown sugar is dissolved and mixture comes to a boil, stirring occasionally. Pour over popcorn mixture; toss lightly to coat evenly. Transfer to prepared baking sheet.

Bake 30 minutes, stirring after 15 minutes. Spray large sheet of waxed paper with nonstick cooking spray. Transfer popcorn to prepared waxed paper to cool. Store in airtight containers.

Recipe makes 12, 1-cup servings.

Nutrition information per serving:
Calories: 133
Total Fat: 3g
Saturated Fat: <1g
Carbohydrate: 26g
Cholesterol: 0mg
Sodium: 4mg
Fiber: 1g
Protein: 1g
Calories from fat: 10%
Exchanges: 1 Starch, 1/2 Fat, 1/2 Fruit (2 Carbohydrate Choices)

Next
Chocolate Popcorn

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Chocolate Popcorn | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Popcorn

Ingredients:
4 quarts of hot air-popped corn
Refrigerated butter-flavored cooking spray
12 tablespoons purchased powdered fat-free, sugar-free cocoa mix
4 teaspoons ground cinnamon

Directions:
Working in four batches, place 1-quart of the hot popped corn in a large clean paper grocery bag and lightly spray with cooking spray. Close the bag and shake to distribute the spray onto the popped corn.

In a small bowl, mix 3-tablespoons of the cocoa mix with 1-teaspoon ground cinnamon. Sprinkle over the popped corn. Close the bag and shake well to coat the popped corn with the mix.

Pour the coated popcorn into a large bowl. Repeat the process with the remaining three batches of popped corn. Serve.

Recipe makes 16 cups.

Nutrition information per 2-cup serving:
Calories: 91
Total Fat: 1g
Saturated Fat: 0.1g
Carbohydrate: 18g
Cholesterol: 1mg
Sodium: 76mg
Fiber: 3g
Protein: 4g
Calories from fat: 7%
Exchanges: 1 carbohydrate (1 bread/starch)

Next
Kiwi Yogurt

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Lemon Pound Cake with Strawberries | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Lemon Pound Cake with Strawberries

Ingredients:
2 cups flour
1 teaspoon baking powder
1 teaspoon baking soda
Ѕ teaspoon salt
Ѕ cup low-fat sour cream
Ѕ cup fat free (skim) milk
1/3 cup sugar
ј cup olive oil
ј cup egg substitute
2 tablespoons lemon juice
1 teaspoon grated lemon peel
Three pints of strawberries
Artificial sweetener (optional)

Directions:
Preheat oven to 350-degrees. Coat 8 X 4-inch loaf pan with nonstick cooking spray. Combine flour, baking powder, baking soda and salt in large bowl.

Combine sour cream, milk, sugar, oil, egg substitute, lemon juice and lemon peel in medium bowl. Stir sour cream mixture into flour mixture until well combined; pour batter into prepared pan. Bake 45 to 50 minutes or until toothpick inserted in center comes out clean.

Let cake cool 20 minutes before removing from pan; cool completely. Meanwhile, slice strawberries. Sprinkle to taste with sweetener, if desired. Slice cake and serve with strawberries.

Recipe makes 16 servings.

Nutrition information per serving:
Calories: 180
Total Fat: 6g
Saturated Fat: 1g
Carbohydrates: 28g
Cholesterol: 4mg
Protein: 4g
Sodium: 264mg
Fiber: 2g
Exchanges: 1 Starch, 2 Fruit, 1 Fat

Next
Strawberry Short Cut Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Printable Page of Snacks for Diabetics | Fitness and Freebies

Each of the listed snacks provides 12 to 15 grams of carbohydrate or one carbohydrate (1 bread/starch) exchange:

One small apple
Eight animal crackers
Four medium fresh apricots or seven dried halves
1/2 of a banana rolled with 2-tablespoons Grape Nuts cereal
1 cup cubed cantaloupe
Twelve Bing cherries
Two chocolate mousse bars (Weight Watchers)
1/2 cup chow mein noodles
Three dried dates
Two small dried figs
Two sugar-free fudgesickles
Three gingersnaps
36 Goldfish (adds 1 fat exchange)
Three graham crackers (2 1/2-inch square)
1/2 low-fat granola bar
15 grapes
Five kumquats
Three Lorna Doones (adds 1 fat exchange)
12 loquats
Five slices melba toast
One small nectarine
1 cup skim milk
Three thin sliced Norwegian Kavli flatbread (2 thick sliced)
One small orange
One small peach
Three peanut butter sandwich crackers (adds 1 fat exchange)
One small pear
16 Mr. Phipps Tater Crisps (adds 1 fat exchange)
Two small plums
24 oyster crackers
3 cups popcorn (popped by hot air, or low-fat microwave)
Three dried pitted prunes
15 fat-free potato or tortilla chips
3/4 ounce pretzels
2 tablespoons raisins
Two rice cakes (4" diameter)
Seven Ritz crackers (adds 1 fat exchange)
Six saltine crackers
Two Stella d'Oro Sesame Breadsticks (adds 1 fat exchange)
One tangerine
15 Teddy Grahams (adds 1 fat exchange)
Five reduced-fat Triscuits
Six Vanilla Wafers (adds 1 fat exchange)
Six Waverly Wafers (adds 1 fat exchange)
12 Original Wheat Thins (adds 1 fat exchange)
13 Reduced-fat Wheat Thins (adds 1/2 fat exchange)
1 cup nonfat fruit-flavored yogurt (sweetened with sugar substitute)
1/2 cup of either I Can't Believe It's Yogurt or TCBY frozen yogurt or Baskin Robbins, Sugar-Free Ice Cream

To your health!

back

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Protein | Fitness and Freebies

Protein

Protein is the second major nutrient needed by your body. Your body uses protein to build and repair body tissue. Muscles, organs, bones, skin and many of the chemical messengers in your body are made of protein. Protein can also provide energy for your body if carbohydrates are not available.

Protein is a chain of building blocks called amino acids. In the human body, there are 22 amino acids. They combine with each other in an almost infinite number of arrangements. The human body can only make 13 of the 22 amino acids it needs for survival. This means nine of the amino acids must come from the foods we eat.

You get amino acids from eating plant protein or by eating the meat from animals that consumed protein. Protein is found in food such as meat, poultry, fish, eggs, cheese and milk. Grain, legumes and nuts also contain protein with other sources including foods such as oatmeal, lentils and peanuts.

Next
Fat

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Toasted Pumpkin Seeds | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Toasted Pumpkin Seeds

Ingredients:
2 cups pumpkin seeds, scooped from a fresh pumpkin
2 tablespoons olive oil
Salt (optional)

Directions:
Rinse, removing all pulp and strings. Spread seeds in a single layer on a large baking sheet. Let air-dry for at least three hours.

Preheat oven to 375-degrees.

Drizzle the oil over the seeds and lightly sprinkle with salt (if using). Toss and again spread out in a single layer. Bake for 15 to 20 minutes, until lightly browned and toasted. Hull like sunflower seeds to eat.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 217
Total Fat: 19g
Saturated Fat: 3.2g
Carbohydrate: 6g
Cholesterol: 0
Sodium: 6mg
Fiber: 1g
Calories from fat: 75%
Dietary Exchanges: 1 Starch

Next
Curried Snack Mix

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Cranberry Lime Margarita Punch | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Cranberry Lime Margarita Punch

Ingredients:
6 cups water
One container (12 ounces) frozen cranberry juice cocktail
1/2 cup fresh lime juice
Six packets sweetener or 1/4-cup measurable sweetener
2 cups ice cubes
1 cup diet ginger ale or tequila
One lime, sliced

Directions:
Combine water, cranberry juice, lime juice and sweetener in punch bowl; stir until sweetener dissolves. Stir in ice cubes, ginger ale and sliced lime; garnish with fresh cranberries if desired.

Nutritional information per serving:
Calories: 87
Fat: 0g
Cholesterol: 0mg
Sodium: 9mg
Carbohydrate: 23g
Protein: 1g
Diabetic Exchanges: 1-1/2 Fruit

Next
Hot Merry Cherry Punch

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Hot Merry Cherry Punch | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Hot Merry Cherry Punch

Ingredients:
One can or bottle (46 ounces) cherry juice blend
2 tablespoons sugar
Juice and peel of one lemon
1/2 teaspoon whole cloves
One cinnamon stick
One lemon, thinly sliced (for garnish)

Directions:
Combine all ingredients in large saucepan. Simmer over low heat ten minutes or until hot. Remove and discard lemon peel, cloves and cinnamon stick. Carefully pour into heat-proof punch bowl or cups. Garnish with lemon slice.

Recipe makes 10 to 12 (1/2-cup) servings.

Nutrition information per serving:
Calories: 71
Calories from Fat: 0
Total Fats: 0
Carbohydrate: 17g
Cholesterol: 0
Sodium: 5mg
Exchanges: 1 fruit

Next
Root Beer Float

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Powdered Sugar Replacement | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Powdered Sugar Replacement

Ingredients:
2 cups nonfat dry milk powder
2 cups cornstarch
1 cup granulated sugar replacement

Directions:
Combine all ingredients in food processor or blender. Whip until well blended and powdered.

Yield: 4 cups

Calories per 1/4-cup, 81

Diabetic Exchange per 1/4-cup: 1 bread, 1/2 nonfat milk, or 1/2 bread

Candy

To Your Health!
Fitness and Freebies

space Sunny Citrus Cubes | Butter Rum Candy | Fruit Candy Bars | Peanut Candy | Peanut Clusters | Peanut Butter Fudge Crunchies | Peanut Butter Crunchies | Peanut Butter Candy | Fudge I | Fudge II | Chocolate Dipped Creams | Double Fudge Balls | Chocolate Chews | Pecan Fudgies | Melt-Away Mints | space


Raisin Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Raisin Cake

Ingredients:
2 cups raisins
3 cups water
Two eggs
3 tablespoons liquid sweetener
3/4 cup vegetable oil
1 teaspoon vanilla extract
1 teaspoon baking soda
1/2 teaspoon salt
1 1/2 teaspoons ground cinnamon
1/2 teaspoon ground nutmeg
2 cups all-purpose flour
1 cup chopped walnuts
1 cup unsweetened applesauce

Directions:
Preheat oven to 350-degrees. Grease and flour one 10-inch bundt or tube pan. In a saucepan combine raisins with water and cook until the water is absorbed, cool.

Combine eggs, applesauce, vegetable oil, vanilla, and liquid sweetener. Mix well. Sift flour, baking soda, salt, ground cinnamon, and ground nutmeg into egg mixture. Stir until just combined. Mix in raisins and chopped nuts. Pour batter into prepared pan.

Bake at 350-degrees for one hour.

Next
Applesauce Cake

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Low-Fat Ranch Dressing | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Low-Fat Ranch Dressing

Ingredients:
1/2 cup fat-free sour cream
1 tablespoon fresh lime juice
One clove garlic, chopped
One thin slice red onion
1/2 teaspoon pepper
1/4 teaspoon salt
1/4 teaspoon celery seed
Three drops red pepper sauce or to taste, optional

Directions:
Combine all ingredients in jar of blender or food processor bowl. Process until smooth, scraping down sides with rubber spatula as necessary.

Refrigerate, covered, in glass or plastic container. Keeps four days refrigerated.

Recipe makes 1/2-cup. Serving size is 4-tablespoons, total two servings.

Nutrition information per serving:
Calories: 78
Fat: <1g
Saturated Fat: <1g
Calories from fat: 1%
Protein: 4g
Carbohydrates: 14g
Cholesterol: 0mg
Sodium: 342mg
Fiber: <1g
Dietary Exchanges: 1 Starch

Next
Mustard Mushroom Vinaigrette

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Frosty Raspberry Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Frosty Raspberry Pie

Ingredients:
9-inch pie crust brushed with egg whites, baked and cooled

Filling Ingredients:
1-1/2 cups fruit-sweetened raspberry yogurt
Two packets sweetener
One small package (4 serving size) raspberry sugar-free gelatin
3/4 cup boiling water
Two ice cubes
2/3 cup ice cold fruit-sweet raspberry juice concentrate
1-1/2 Tablespoons ice water
2-1/3 cups rinsed, drained, raspberries
Raspberry to garnish each slice (optional)
Mint sprig to garnish each slice (optional)

Directions:
Mix sweetener into yogurt, and set aside.

Stir boiling water into gelatin powder until dissolved. Add ice cubes until melted. Stir in juice concentrate and ice water. Finally, using a wire whip, whisk yogurt into the gelatin mixture until smooth. Spread raspberries on the bottom of the pie crust, and pour the gelatin liquid over the raspberries.

Refrigerate 2-1/2 to 3 hours, or hasten the gelling process by putting the pie in the freezer for not more than 30 minutes and then into the refrigerator until ready. Decorate each slice with a mint sprig and a raspberry (optional).

Recipe makes eight servings.

Next
Chocolate Raspberry Cream Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Hearty Corn Cakes | space


Chocolate Raspberry Cream Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chocolate Raspberry Cream Pie

Ingredients:
9-inch pie crust brushed with egg whites, baked and cooled

Raspberry ingredients:
1/4 - 1/3 cup all fruit raspberry jam

Pudding ingredients:
3-1/2 cups 1% milk
Two small (4 serving size) packages chocolate sugar-free instant pudding

Topping ingredients:
1/4 cup whipping cream
One packet sweetener
1/2 teaspoon vanilla
1 teaspoon sugar-free hot chocolate mix (optional)

Raspberry layer:
Evenly spread jam over the bottom and half way up the sides of the pie crust.*

Pudding layer:
Thoroughly beat together milk and pudding mix for one to two minutes. Gently pour the pudding over the raspberry layer, and refrigerate. Allow two hours to gel.

Topping layer:
For best results, wait until just before serving the pie to prepare the topping. Beat the whipping cream until peaks form and then droop. Add Equal® and vanilla. Beat until stiff. Spread a thin layer of topping over the entire pie. Dust topping with sugar-free hot chocolate mix.

Recipe makes eight servings.

Next
Chocolate Covered Cherry Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Roasted Red Pepper Dip | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Roasted Red Pepper Dip

Ingredients:
8 ounces nonfat sour cream alternative
One, (7 ounce) jar roasted red peppers, drained
4 ounces nonfat cream cheese
One clove garlic
1 tablespoon fresh basil leaves
1/2 teaspoon dried oregano leaves
Wheat Thins® reduced fat crackers

Directions:
In food processor or electric blender, add all ingredients except crackers. Process just until red peppers are finely chopped. Pour into bowl.

Chill at least one hour. Serve as a dip with crackers.

Recipe makes 96, 1-teaspoon servings.

Nutrition information per serving:
Calories: 5.9
Fat: 4g
Protein: .2g
Carbohydrates: .3g
Cholesterol: 0mg
Sodium: 6mg
Dietary Exchanges: 1 Fat

Next
Chile Cheese Log

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Dietary Rewards | Fitness and Freebies

Dietary Rewards

By following a meal plan, you will gain both long and short-term benefit due to giving your body the ability to maintain blood sugar. In turn, this will make you feel better and give you more energy.

For some people with Type II diabetes, a meal plan can help reduce insulin resistance. Insulin resistance is linked to excessive weight and heredity. If you are overweight, shedding just a few extra pounds can enable your cells to use insulin more efficiently. In addition, simply eating the right amount and variety of foods at the right time will also help your body combat insulin resistance - even before losing so much as one pound!

So you see, your diet is crucial in treating your diabetes so you can live a happy, healthy, long life with few, hopefully none - of the negative consequences of diabetes.

When one has had diabetes for many years, the risk of developing complications increases significantly. Some can be life threatening. In the past, the onset of these complications was very common due to the lack of knowledge we now have and the ability to help yourself through your diet.

The right meal plan can avert risks for both Type I and Type II diabetics. The worst and most serious complications now only occur in diabetic patients who do not learn how to control and work with their diabetes via diet, exercise and good health risks that come with diets high in saturated fat, salt and cholesterol. Food high in these substances increases the risk of heart and blood vessels. When you have diabetes your risk is increased.

Next
Creating A Diet Plan

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Gray and Silver and the Diabetic Ribbon | Fitness and Freebies

~ The Gray and Silver Diabetic Ribbon~

Gray is a rather indistinct color. Diabetes does not distinguish between races, ages, sexes, or nationalities. Diabetes cripples and kills all.

Gray corresponds with the degree of public knowledge and awareness of diabetes.

Gray is to bring the public's attention to the large number of persons with diabetes who were blind and who did not see green fields and snow. Just a universal gray. That later many of them would not even see that colour.

We the 190,000,000 diabetics diagnosed so far MUST polish the gray and make it silver, lest another generation follow in our footsteps.

~~AUTHOR UNKNOWN

The Diabetic Gray and Silver Ribbon


Root Beer Float | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Root Beer Float

Ingredients:
1/3 cup no sugar added vanilla frozen yogurt
6 ounces diet sugar-free root beer
Two straws

Directions:
Place scoop of frozen yogurt into a large glass and pout root beer over it.

Nutrition information per serving:
Calories: 57
Calories from Fat: 0
Protein: 2g
Total Fats: 0
Carbohydrate: 13g
Fiber: 0
Cholesterol: 0
Sodium: 55mg
Exchanges: 1 bread/starch

Next
Mulled Rosy Cider

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Russian-Style Tea | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Russian-Style Tea

Ingredients:
1 (.55-ounce) container sugar-free lemonade-flavored soft drink mix
1 (.55-ounce) container sugar-free orange-flavored breakfast beverage crystals
1 cup unsweetened iced tea mix
36 packets sweetener or 1-1/2 cup measurable sweetener
1 teaspoon ground cinnamon
1/2 teaspoon ground cloves
1/2 teaspoon ground allspice
Boiling water

Directions:
Mix dry ingredients together, stirring well. Measure 1-tablespoon mixture if using packets, or 2-tablespoons mixture measurable sweetener into each 8-ounce mug; fill with boiling water and stir to blend.

Store remaining mixture in covered jar.

Recipe makes about 20, 8-ounce servings.

Nutrition information per serving (8-ounces):
Calories: 18
Total Fat: 0
Saturated Fat: 0g
Carbohydrate: 4g
Cholesterol: 0mg
Sodium: 16mg
Protein: 0g
Fiber: 3g
Exchanges: Free Food

Next
Spicy Berry Cider

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Raspberry Sangria | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Pureиd raspberries give this sangria an extra fruity new twist.

Raspberry Sangria

Ingredients:
1 quart fresh or frozen, thawed raspberries
1 quart dry white wine*
2/3 to 1-cup measurable sweetener of choice
Two oranges, cut into halves, sliced
One lime, cut into halves, sliced
Ice

Directions:
Process raspberries in blender or food processor until smooth; strain and discard seeds.

Stir raspberry pureи into wine in large pitcher. Stir in sweetener and fruit. Serve over ice in tall glasses.

*Champagne or sparkling mineral water can be substituted for the white wine.

Serving Size: Approximately 8 fluid ounces

Nutrition information per serving (with white wine):
Calories: 145 - 160
Total Fat: trace
Saturated Fat: 0g
Carbohydrate: 10g
Cholesterol: 0mg
Sodium: 7mg
Protein: <1g
Fiber: 3g
Exchanges: 1 Fruit, 2 Fat

Next
Russian-Style Tea

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Sweet and Sassy Cherry Sauce | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Sweet & Sassy Cherry Sauce

Ingredients:
2 cups pitted, sweet cherries
2 tablespoons sugar
2 tablespoons water
Pinch of salt (1/8 teaspoon)
2 tablespoons fresh lemon juice
1/2 teaspoon freshly grated lemon rind
1 tablespoon Kirsch (or 1 teaspoon cherry flavoring)

Directions:
Place cherries, sugar and water in a medium saucepan. Simmer for four minutes. Using a slotted spoon, remove the cherries and set aside.

Dissolve the 2-tablespoons cornstarch in 2-tablespoons cold water. Bring the syrup to a boil and stir the cornstarch mixture into the boiling juice, stirring as it thickens. Add salt, lemon juice, lemon rind, and Kirsch. Cook, stirring occasionally for seven minutes.

Return the cherries to the syrup and cook for three minutes more. Remove from heat and pour into a sterile jar. Syrup may be stored for up to two weeks in the refrigerator.

Recipe makes 2 cups (1 tablespoon per serving).

Nutrition information per serving:
Calories: 45
Protein: 1g
Carbohydrates: 10g
Cholesterol: 0mg
Sodium: 22mg
Dietary Exchanges: 1/2 Fruit

Next
Sweet & Sassy Cherry Sauce

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Country-Style Semolina Loaf | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Country-Style Semolina Loaf

Ingredients:
1-3/4 teaspoon active dry yeast or 7/10 small cake yeast
1/4 cup water - warm
1-1/4 cup plus 1-teaspoon water
2-1/2 cups flour - semolina
3/4 cup flour - unbleached
1/2 teaspoon malt
2 teaspoons salt

Directions:
Dissolve the yeast in 1/4-cup water and allow it to stand for approximately five to ten minutes. Add the additional water (1 cup plus 1-teaspoon water), to the dissolved yeast. Gradually add the semolina and unbleached flour (2-1/2 and 3/4-cup), malt and salt to this mixture and continue to mix until the dough begins to hold together. Knead the dough to until it is smooth and elastic.

Place the dough in a bowl, and cover it. Set the dough in a relatively cool (68-70-degrees) and draft free area and allow it to rest for 35-40 minutes. Gently punch the dough down and allow it to continue to rest for an additional 1 to 1-1/3 hours. (The total fermentation times is two hours.)

Turn the risen dough onto a flour dusted work surface. Dust a piece of canvas (untreated, 100% cotton) with flour. Divide and shape the dough into a round and place on the canvas or board. Cover the dough with a cotton towel, and allow it to rise for approximately 30-40 minutes.

As the dough is rising, place a baking stone in the oven and set the temperature to 450-degrees. Allow the oven to heat for 30 minutes.

Transfer the dough to a lightly floured sheet of parchment paper. Slide a baker’s peel beneath the parchment paper. Slide the parchment paper from the peel onto the baking stone. Allow the dough to bake for approximately 20-25 minutes.

Remove the bread from the oven and allow it to cool on a rack.

Recipe makes one loaf.

Next
Yummy Apple Biscuits

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Strawberry Short Cut Cake | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Strawberry Short Cut Cake

Ingredients:
One package (13.6 ounces) fat free pound cake
3 cups strawberries, sliced, sweetened with sweetener of choice
3-1/4 cup thawed whipped topping

Directions:
Cut cake into 16 slices. Place eight of the cake slices on individual dessert plates.

Spoon about 3-tablespoons of the strawberries over each cake slice. Top each with ј-cup whipped topping. Repeat layers, ending with whipped topping. Serve immediately.

Recipe makes eight servings.

*Note:
You can eliminate all the fat by using fat free whipped topping instead of the "lite" whipped topping.

Nutrition information per serving (with "lite" whipped topping):
Calories: 270
Total Fat: 2g
Saturated Fat: 2g
Carbohydrates: 64g
Cholesterol: 0mg
Protein: 3g
Sodium: 170mg
Fiber: 3g
Exchanges: 4 Starch

Next
Angel Food Cake with Blueberry Yogurt Sauce

Cakes

To Your Health!
Fitness and Freebies

space Chocolate Cake | Chocolate Zucchini Cake | Raisin Cake | Applesauce Cake | Jewish Apple Cake | German Apple Cake | Peach Almond Upside Down Cake | Easy Carrot Cake | Carrot Cake | Lemon Chiffon Cake | Lemon Pound Cake with Strawberries | Strawberry Short Cut Cake | Angel Food Cake with Blueberry Yogurt Sauce | Hearty Corn Cakes | space


Apple Slaw with Poppy Seed Dressing | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Apple Slaw with Poppy Seed Dressing

Ingredients:
1 cup coarsely chopped Jonathan apples, not peeled
1 teaspoon lemon juice
2 tablespoons non-fat sour cream
4-1/2 teaspoons skim milk
1 tablespoon frozen apple juice concentrate, thawed
1 teaspoon sugar
3/4-teaspoon poppy seeds
1/2 cup sliced carrots
1/3 cup shredded red cabbage
1/3 cup shredded green cabbage
2 tablespoons finely chopped green bell pepper
Additional cabbage leaves, optional

Directions:
Combine apple and lemon juice in resealable plastic food storage bag. Seal bag; toss to coat. Combine sour cream, milk, apple juice concentrate, sugar and poppy seeds in a small bowl until well blended. Add apple mixture, carrots, cabbages and pepper; toss to coat. Serve on cabbage leaves and garnish with fresh greens and carrot slice, if desired.

Recipe makes two servings.

Nutrition information per serving:
Calories: 94
Protein: 3g
Total Fat: 1g
Carbohydrate: 21g
Cholesterol: <1mg
Sodium: 34mg
Exchanges: 1 Fruit, 1 Vegetable

Next
Maple Glazed Squash

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Fresh Fruit Slush | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fresh Fruit Slush

Ingredients:
1-1/2 cups chopped fresh fruit or unsweetened frozen fruit of your choice
Eight to ten ice cubes

Directions:
Using a food processor or blender, blend the fruit until smooth.

While machine is running, add the ice cubes one at a time until the mixture takes on a slushy consistency. Pour into glasses and serve immediately.

Recipe makes four servings.

Nutrition information per serving:
Calories: 25
Total Fat: trace
Saturated Fat: 0g
Carbohydrate: 6g
Cholesterol: 0mg
Sodium: 0mg
Fiber: 1g
Protein: trace
Calories from fat: 6%
Exchanges: 1/2 carbohydrate, 3 fat Dietary Exchanges: 1/2 carbohydrate (fruit)

Next
Frozen Fruit Cups

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Fruit Smoothie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Fruit Smoothie

Ingredients:
1 cup orange juice
1 cup fatfree plain yougart
1 frozen banana*
1 cup of frozen strawberries
Six packets of artificial sweetener

Directions:
Place all ingredients in a blender or food processor. Blend all ingredients until smooth.

Peel and cut banana into large chunks. Place in ziplock bag, seal and freeze at least five to six hours or overnight.

Recipe makes two servings.

divider

Very Intense Fruit Smoothie

Ingredients:
1 (10 ounce) package frozen mixed berries
1 (15 ounce) can sliced peaches, drained
2 tablespoons honey

Directions:
In a blender, combine frozen fruit, canned fruit and honey. Blend until smooth.

Next
Instant Cocoa Mix

Beverage List

To Your Health!
Fitness and Freebies

space Coffee Latte | Berry Apricot Frappe | Lemonade | Blushing Hot Spiced Cider | Buttermilk Nectarine Blush | Cranberry Lime Margarita Punch | Hot Merry Cherry Punch | Root Beer Float | Mulled Rosy Cider | Fitness Shake | Fresh Limeade | Iced Orange Cappuccino | Orange Banana Nog | Raspberry Sangria | Russian-Style Tea | Spicy Berry Cider | Tangy Cherry Milkshake | Fruit Smoothie | Instant Cocoa Mix | Holiday Eggnog |


Smunchies | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Smunchies

Ingredients:
Two graham crackers
Sugar-free chocolate pudding
Sliced bananas

Directions:
Spread one graham cracker with sugar-free chocolate pudding that has been made up. Top with thinly sliced banana. Place other graham cracker on top, top with more thinly slices of banana. Put another graham cracker on top. Wrap and freeze. (Will be "gooey" when thawed).

Note:
When making, be sure to break each long graham cracker in half.

Recipe makes one serving.

Dietary Exchanges: 1 Starch

Next
Toasted Pumpkin Seeds

Snacks

To Your Health!
Fitness and Freebies

space Smunchies | Toasted Pumpkin Seeds | Curried Snack Mix | Apple Crisp with Honey | Ants on a Log | Peanut Butter Granola | Snacking Granola | Pizza Pockets | Cheese Balls | Fresh Fruit Slush | Frozen Fruit Cups | Popcorn Treat | Dilled-Ranch Popcorn | Asian Popcorn | Nacho Popcorn | Honey Crunch Popcorn | Chocolate Popcorn | Kiwi Yogurt | Yogurt Popsicles | Frozen Strawberry Pops | Frozen Grape Pops | Chocolate Yogurt Pops | No Drip Popcicles | Frozen Bananas | Maple Banana Blast | Banana Fingers | space


Snacks | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Snacks

Button Smunchies

Button Toasted Pumpkin Seeds

Button Curried Snack Mix

Button Apple Crisp with Honey

Button Ants on a Log

Button Peanut Butter Granola

Button Snacking Granola

Button Pizza Pockets

Button Cheese Balls

Button Fresh Fruit Slush

Button Frozen Fruit Cups

Button Popcorn Treat

Button Dilled Ranch Popcorn

Button Asian Popcorn

Button Nacho Popcorn

Button Honey Crunch Popcorn

Button Chocolate Popcorn

Button Kiwi Yogurt

Button Yogurt Popsicles

Button Frozen Strawberry Pops

Button Frozen Grape Pops

Button Chocolate Yogurt Pops

Button Frozen Bananas

Button Maple Banana Blast

Button Banana Fingers

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Snacks | Fitness and Freebies

Snacks

Snacks do play an important role in the daily life of a diabetic, particularly those with type 1 diabetes and insulin-requiring type 2 diabetes. For these people between-meal and bedtime snacks are essential to keep blood glucose levels as close to normal as possible and to help prevent low blood sugar (hypoglycemia).

Always carry a supply of snacks to eat in case of low blood sugar.

Following is a list of snacks you can purchase at most supermarkets. They are calculated to supply 12 to 15 grams of carbohydrate or one carbohydrate (1 bread/starch) exchange:

One small apple
Eight animal crackers
Four medium fresh apricots or seven dried halves
1/2 of a banana rolled with 2-tablespoons Grape Nuts cereal
1 cup cubed cantaloupe
Twelve Bing cherries
Two chocolate mousse bars (Weight Watchers)
1/2 cup chow mein noodles
Three dried dates
Two small dried figs
Two sugar-free fudgesickles
Three gingersnaps
36 Goldfish (adds 1 fat exchange)
Three graham crackers (2 1/2-inch square)
1/2 low-fat granola bar
15 grapes
Five kumquats
Three Lorna Doones (adds 1 fat exchange)
12 loquats
Five slices melba toast
One small nectarine
1 cup skim milk
Three thin sliced Norwegian Kavli flatbread (2 thick sliced)
One small orange
One small peach
Three peanut butter sandwich crackers (adds 1 fat exchange)
One small pear
16 Mr. Phipps Tater Crisps (adds 1 fat exchange)
Two small plums
24 oyster crackers
3 cups popcorn (popped by hot air, or low-fat microwave)
Three dried pitted prunes
15 fat-free potato or tortilla chips
3/4 ounce pretzels
2 tablespoons raisins
Two rice cakes (4" diameter)
Seven Ritz crackers (adds 1 fat exchange)
Six saltine crackers
Two Stella d'Oro Sesame Breadsticks (adds 1 fat exchange)
One tangerine
15 Teddy Grahams (adds 1 fat exchange)
Five reduced-fat Triscuits
Six Vanilla Wafers (adds 1 fat exchange)
Six Waverly Wafers (adds 1 fat exchange)
12 Original Wheat Thins (adds 1 fat exchange)
13 Reduced-fat Wheat Thins (adds 1/2 fat exchange)
1 cup nonfat fruit-flavored yogurt (sweetened with sugar substitute)
1/2 cup of either I Can't Believe It's Yogurt or TCBY frozen yogurt or Baskin Robbins, Sugar-Free Ice Cream

Click Here for a printer-friendly list of the snacks.

Next
Diabetes Food Pyramid

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Spicy Chicken Rice Soup | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Spicy Chicken Rice Soup

Ingredients:
4 cups fat free chicken broth
2 cups cubed cooked chicken breast
2 celery ribs, chopped
2 medium carrots, chopped
1 medium green pepper, chopped
1 medium onion, chopped
1/3 cup uncooked long grain rice
1/4 cup minced fresh cilantro or parsley
1/2 teaspoon dried oregano
1/2 teaspoon salt, optional
1/2 teaspoon pepper
1/4 teaspoon ground cumin
1/8 to 1/4 teaspoon crushed red pepper flakes

Directions:
In a large saucepan, combine all ingredients. Bring to a boil. Reduce heat; cover and simmer for 20 - 25 minutes or until rice and vegetables are tender.

Recipe makes six servings.

Nutrition information per serving:
Calories: 135
Fat: 3g
Cholesterol: 14mg
Sodium: 100mg
Carbohydrate: 17g
Fiber: 2g
Exchanges: 1-1/2 Very Lean Meat, 1 Starch

Next
Clam Chowder

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Maple Glazed Squash | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Maple Glazed Squash

Ingredients:
One large acorn squash, seeded and cut into quarters
Butter flavored vegetable cooking spray
One large tart cooking apple, unpeeled, cored and sliced
1/4 cup raisins
1/4 cup walnuts
Sugar Free Maple Syrup

Directions:
Place squash; cut sides up, in baking pan. Add 1/2-cup hot water. Bake covered, in preheated 400-degree oven until squash is tender, 30 to 40 minutes. Spray medium skillet with cooking spray; heat over medium heat until hot. Add apple, raisins and walnuts. Cook over medium heat until apple slices are tender, about five minutes. Add maple-flavored syrup; cook until heated through, two to three minutes. Place squash wedges on serving platter and spoon apple mixture over squash.

Nutrition information per serving:
Calories: 228
Protein: 3g
Total Fat: 8g
Carbohydrate: 21g
Cholesterol: 0mg
Sodium: 41mg

Next
Cranberry Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Salads, Soups and Sides | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Salads, Soups and Sides
Fruits and Vegetables

Button Apple Slaw with Poppy Seed Dressing
Button Maple Glazed Squash
Button Cranberry Salad
Button Chicken Waldorf Salad
Button Cheesy Potato Skins
Button Crazy Carrots
Button Stuffed Bell Peppers
Button Curried Chicken Salad
Button Chicken Dijon Pasta Salad
Button Chicken Salad Chinois
Button Dried Fruit Salad
Button Green Beans and Fennel
Button Nutty Apple Salad
Button Pickled Carrots
Button Broccoli with Black Olives
Button Cheesy Baked Eggplant
Button Citrus Spinach and Rice Salad
Button Winter Salad
Button Garlic Mashed Potatoes
Button Nutty Wild Rice Salad with Kiwifruit and Red Grapes
Button Broiled Steak Salad
Button Spicy Chicken Rice Soup
Button Clam Chowder
Button Chinese Chicken Corn Soup
Button Hearty Italian-Style Soup
Button Chili-Bean Soup
Button Beef Vegetable Soup
Button Basil Chicken Soup
Button Green Split Pea and Barley Soup
Button Quick Minestrone
Button Cool 'n Creamy Beet Soup
Button Quick Minestrone
Button Cool 'n Creamy Beet Soup
Button Chilled Tomato Soup

back
Main Contents

More Diabetic Recipes: Diabetic Recipes One | Diabetic Recipes Two

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Easy Sticky Buns | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Easy Sticky Buns

Ingredients:
One packet Butter Buds Mix, dry
1/4 cup hot water
3 tablespoons packed light brown sugar
1/2 teaspoon ground cinnamon
1-1/2 tablespoons chopped walnuts
One package (7.5 ounces) refrigerated biscuits

Directions:
Preheat oven to 375-degrees. Spray an 8-inch round baking pan with nonstick cooking spray.

In a small bowl, combine the Butter Buds, water, brown sugar, and cinnamon. Pour into the prepared pan. Sprinkle with nuts. Arrange the biscuits in a single layer on top of the nuts. Bake 15 to 20 minutes or until well browned. Immediately invert onto a serving plate.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 80
Protein: 1g
Total Fat: 2g
Saturated Fat: <1g
Carbohydrate: 16g
Cholesterol: 0mg
Sodium: 240mg
Exchanges: 1 carbohydrate (1 bread/starch)

Next
Up-and-Down Biscuits

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Your Diet Strategy | Fitness and Freebies

Your Diet Strategy

The basic strategy is to coordinate your food intake with the action of the insulin in your body. Although no two cases of diabetes are exactly alike, a meal planning approach may be recommended for both Type I and Type II diabetes patients.

When you have Type I diabetes, you must use insulin injections to replace the insulin your pancreas no longer reproduces. The insulin will act at specific times after it is injected. These action times will vary, depending on the type of insulin you use - short acting, immediate-acting or long-acting. Your diet must coordinate with these action times. The diabetic needs to follow one more important guideline in addition to the above guidelines:

For Type II diabetics who may take insulin to supplement the small amount of insulin still produced by your pancreas. Alternatively, perhaps you take medication to aid your body's ability in insulin production according to your specific needs.

Whichever way you and your doctor are managing your diabetes, and in both types, your food intake still must be timed to coincide with your own insulin production. The way you time your food intake in accordance with the action of insulin is important for all diabetic patients. The main question - whether you have Type I or Type II Diabetes: When is the insulin in your body acting? This, in part, will determine when and how much you will be able to eat. To sum this up, you must carefully coordinate the amount and time your insulin is acting in your body. Following is an equation that can help you do this:

Sugar in bloodstream = Sugar that the insulin in your bloodstream can handle.

It is also a good idea to know what a serving size truly is. Here are some examples of what "one" serving means:
  • Meat: 2-3 ounces chicken, beef or fish or 1/2 to 3/4 cup tuna or cottage cheese.
  • Fruits: 1/2-cup juice, one small fresh fruit or 1/2-cup canned fruit.
  • Vegetables: 1-cup lettuce or 1/2-cup green beans.
  • Breads: One slice, four to six small crackers or 1/3-cup cooked rice.
  • Dairy: 1-cup milk or 1-cup yogurt.

Next
Dietary Rewards

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Stuffed Bell Peppers | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Stuffed Bell Peppers

Ingredients:
Four bell peppers
1-1/2 pound lean ground beef
One package sloppy joe seasoning mix
1 cup tomato sauce (no salt)

Directions:
In nonstick skillet brown meat. Drain off remaining fat from pan.

Add sloppy joe mix and tomato sauce. Simmer for five minutes.

Fill peppers with meat mixture and place in baking pan.

Pour 1/8-inch water in baking pan around bell peppers. Cover with foil and bake at 350-degrees for 25 minutes.

Recipe makes four servings.

Nutrition information per serving:
Calories: 339
Protein: 35g
Total Fat: 14g
Carbohydrate: 18g
Cholesterol: 87mg
Sodium: 693mg
Fiber: 4g
Exchanges: 1/2 Starch, 2 Vegetables, 4-1/2 Ounces Lean Meat

Next
Curried Chicken Salad

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Sugar and Sugar Substitutes | Fitness and Freebies

Sugar and Sugar Substitutes

Refined sugar has many functions in food other than providing sweetness. In small amounts, added sugar helps yeast begin producing gas for raising yeast dough. Sugar tenderizes doughs and batters, helps brown baked goods, and makes the crumb of these products moist. It aids in the structure of cakes. It is the white sugar in cookie dough that helps spreading to occur during baking. For these reasons, we suggest replacing only one half of the refined sugar in a recipe with another type of sugar. You can increase or decrease the amount replaced incrementally to achieve the results you want. If you simply want to reduce the amount of sugar you are consuming, many recipes can be modified to decrease the amount of sugar simply by reducing the sugar by one third.

Sugar by Any Name
Refined sugar is 99 percent pure sucrose, a simple carbohydrate. All of the sweeteners listed here are also simple carbohydrates. Each has a unique flavor, and each brings different qualities to baked goods.

Refined fructose is sweeter than granulated sugar. It can be substituted in baking recipes with little trouble. Simply add one third less. Fructose attracts more water than sucrose, therefore fructose sweetened products tend to be moist. Baked products made with fructose will be darker than if they were made with white sugar.

Honey is a liquid sugar made by bees, and consists of several components: fructose, glucose, maltose, and sucrose. It is sweeter than sugar, and has a distinctive flavor. Baked goods made with honey are moist and dense, and tend to brown faster than those made with granulated sugar. Use 3/4 cup plus 1 tablespoon honey in place of 1 cup sugar, and reduce the other liquid ingredients by 2 tablespoons. Unless the recipe includes sour cream or buttermilk, add a pinch of baking soda to neutralize the acidity.

Molasses is a byproduct of refined sugar production. It is made up of sucrose, glucose, fructose, and also contains small amounts of B vitamins, calcium, and iron. Molasses imparts a dark color and strong flavor to baked foods, but is not as sweet as sugar. When substituting molasses for sugar, use 1 1/3 cups molasses for 1 cup sugar, and reduce the amount of liquid in the recipe by 5 tablespoons. Molasses is also more acidic than sugar; add 1/2 teaspoon baking soda for each cup of molasses used in substitution for sugar. Replace no more than 1/2 the sugar called for in a recipe with molasses.

Maple syrup is made from the sap of sugar maple trees, and is a combination of sucrose and glucose. The sap is boiled down into the sweet, delectable syrup we pour over our pancakes and waffles. It is also very good in cookies, pies, and cakes. There are several grades of syrup available. Grade A maple syrup is golden brown and has a light flavor. Grade B is heavier, darker, and has more of that mapley flavor. Like honey, it's very sweet; use 3/4 cup for every cup of white sugar. Decrease the amount of liquid by 3 tablespoons.

Brown rice malt syrup consists of maltose, glucose, and complex carbohydrates. It is an amber hued syrup resembling honey, but it is not as sweet as honey. It can be substituted cup per cup for granulated sugar, but the liquid ingredients should be reduced by 1/4 cup per cup of rice syrup. Enzyme treated syrup, as opposed to malted syrup, will tend to liquefy the batter of a baked product. Use the malted syrup for best results.

Fruit juice concentrates, such as apple juice concentrate, orange juice concentrate, or white grape juice concentrate, are wonderful substitutes for sugar. Juice concentrates are made up of fructose and glucose. Use 3/4 cup for every cup of white sugar, and decrease the amount of liquid by 3 tablespoons.

Artificial Sweeteners
The following artificial sweeteners have been approved by the FDA and are available for home use. They provide sweetness, but lack the browning, tenderizing, and moisture retaining properties of granulated sugar. There is no need to substitute artificial sweeteners for the small amount of sugar used for proofing the yeast in breads. Instead, use milk or potato water for the liquid: the sugar found in either of these is enough to jump start the yeast.

Saccharine is 200 to 700 times sweeter than sugar. It can be used in baked goods. However, the manufacturer recommends substituting it for only half of the sugar in a recipe. Substitute 6 (1 gram) packets for each 1/4 cup sugar. It is sold under the name Sweet and Low®.

Aspartame is 160 to 220 times sweeter than granulated sugar. This sweetener is heat sensitive, it loses its sweetening power when heated, and can not be used for cookies or cakes. The manufacturer does recommend adding it to pie fillings for no-bake pies, and to puddings after they have been removed from the heat. Substitute 6 (1 gram) packets for each 1/4 cup of sugar. It is sold under the names Equal® and Nutrasweet®.

Acesulfame potassium is 200 times sweeter than sugar. It is heat stable so it can be used in baking and cooking. Use acesulfame K in combination with granulated sugar when baking. Substitute 6 (1 gram) packets for each 1/4 cup sugar. It is sold under the brand names Sunette® and Sweet One®.

Sucrolose is made from sugar, but is 66 times sweeter than sugar. Granular sucrolose is the form used when baking. Substitute 1 cup granular sucrolose for each cup of sugar called for in the recipe. Recipes made with this product tend to bake faster than usual. It is sold under the Splenda brand name.

Remember, these substitution guidelines are just that - guidelines. You can tailor your recipes for your tastes by adding more or less sweetener to your recipes. Also, you may not get exactly what you were looking for. It might be better! Live a little; experimentation is fun!

Next
Aspartame: The World Agrees, It is Safe!

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


High Sugar Foods | Fitness and Freebies

High Sugar Foods

Used in large amounts, sugar can cause an abnormally high rise in blood sugar. This is due to the quick digestion of carbohydrates in the intestinal tract, which turns into glucose causing quick entry into the bloodstream. If your body does not contain enough insulin to handle this surge, our blood sugar levels could rise too high. The following list of foods are those with a high sugar content that can cause difficulties with diabetic management. If you use carbohydrate counting as part of your eating plan, you may be able to use these techniques to incorporate some of these foods into your meals. Foods high in sugar are often high in fat and calories and contribute little nutritional value. They are best avoided entirely. Note that on the Food Choice Lists that the portion sizes for foods containing sugar are much lower than their low-sugar alternatives.

Avoid the following foods until you meet with a dietitian to learn if they can be included in your diet.
  • *Alcohol: Sweet wines, liqueurs, cordials
  • Candy
  • Carbonated beverages with sugar, including "regular" soda
  • Sugar coated cereals
  • Chewing gum with sugar
  • Dates, figs and other dried fruits
  • Desserts containing sugar:
    • Cake
    • Cookies with filling or frosting
    • Ice cream, including sodas, shakes and sundaes
    • Ice milk
    • Gelatin dessert, sweetened
    • Pie
    • Pudding
    • Sherbet
  • Fructose
  • Fruited yogurt
  • Honey
  • Jelly and Jam (non-dietetic)
  • Marmalade
  • Pastries
  • Preserves
  • Special "dietetic" foods
  • Sugar
  • Sugar-sweetened fruit drinks (Kool-Aid, Hi-C, etc.)
  • Sweetened condensed milk
  • Syrups (maple, molasses, etc.)

*Alcohol may interfere with the management of diabetes. Always consult with your doctor or dietitian before consuming alcohol.

Perhaps you are aware that today diabetics do not have to give up their sweet treats entirely, thanks to artificial sweeteners. There is a wide range available that you can fit into your diet program. Sweeteners that contain calories, called nutritive sweeteners, will affect your blood sugar. These sweeteners are all carbohydrates and contain four calories per gram. Non-nutritive sweeteners contain few, if any, calories and are therefore called non-caloric sweeteners. These will have no effect on your blood sugar so people with diabetes can use these types of sweeteners. You will find artificial sweeteners have different cooking properties and tastes. You may want to try a variety, depending on the way you wish to use them and according to your taste.

Next
Herbs For Your Health

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Brownie Sunday Pie | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Brownie Sunday Pie

Ingredients:
Vegetable cooking spray 2/3 cup sugar 1/4 cup reduced-calorie margarine, melted
One large egg
2 tablespoons Butter Buds Sprinkles
1 teaspoon vanilla extract
1/2 cup all-purpose flour
1/3 cup European-style unsweetened cocoa powder
1/2 teaspoon baking powder
1/8 teaspoon salt
1/2 cup reduced-calories frozen whipped topping, thawed
1/2 cup sliced bananas
2 tablespoons chopped walnuts
1-1/2 cups nonfat vanilla frozen yogurt (optional)

Directions:
Preheat oven to 350-degrees. Lightly spray a 9-inch pie pan with cooking spray. In a large bowl, combine the sugar, margarine, egg, Butter Buds, and vanilla until well blended. Stir in the flour, cocoa, baking powder, and salt. Spread in the prepared pan. Bake 20 minutes.

Cool on a wire rack. Just before serving, spoon the whipped topping decoratively around the edges of the pie. Garnish with banana slices and walnuts.

Cut the pie into eight wedges and serve with nonfat frozen vanilla yogurt, if desired. (Note if using yogurt be sure to add the extra calories and carbo exchanges -- check the label for specifics).

Recipe makes eight servings.

Nutrition information per serving:
Calories: 150
Total Fat: 4g
Saturated Fat: 1g
Carbohydrates: 28g
Cholesterol: 25mg
Protein: 2g
Sodium: 160mg
Exchanges: 2 carbohydrate (2 bread/starch), 1/2 fat

Next
Cream Cheese Peanut Butter Pie

Pies

To Your Health!
Fitness and Freebies

space Blueberry Pie | Blueberry Yogurt Pie | Blueberry Lemon Pie | Equal® Lemon Meringue Pie | Lemon Meringue Pie | Easy Lemon Pie | Dutch Apple Pie | Apple Cranberry Streusel Pie | Banana Cream Pie | Banana Yogurt Pie | Glazed Blackberry Pie | Bavarian Cream Pie | Frosty Raspberry Pie | Chocolate Raspberry Cream Pie | Chocolate Covered Cherry Pie | Bavarian Cream Pie | Brownie Sunday Pie | | Cream Cheese Peanut Butter Pie | Peanut Butter "Pie" | Key Lime Pie | Nectarine and Berry Pie | space


Low-Fat Techniques for Holiday Cooking | Fitness and Freebies

Low-Fat Techniques for Holiday Cooking

When purchasing meat, buy only the leanest cuts of beef, pork, lamb, and veal. Trim all visible fat from the meat before cooking. Fish is a good low-fat option to meat. The higher fat fish (bluefish, mackerel, salmon, tuna, etc.) are good sources of Omega-3 oils which medical experts claim may be a defense against some health problems.

As long as you don't eat the skin of roasted poultry, you won't be getting any extra fat. The skin acts as a flavor-sealing envelope, keeping the flesh moist.

Make soup stock and soups ahead of time and chill overnight in the refrigerator. The hardened fat can be easily lifted away with a spoon. If you're short on time, you can quick-chill a stock or soup in the freezer with the same results.

If you're making a gravy or sauce from the meat drippings, be sure to chill first to remove all possible fat before adding your liquids and seasonings. Create sauces or gravies by adding wine and/or stock to the pan juices and cook over high heat until reduced and thickened. If necessary to thicken, add a little cornstarch or arrowroot.

Use nonfat cooking sprays instead of butter, margarine, or oil when sauteing garlic, onions, celery, etc. In addition, use cooking sprays to coat baking dishes, baking pans, and casseroles instead of greasing the pans with butter, oil, or solid shortening.

Marinate meats and poultry in fat-free (no-oil) marinades before cooking to enhance flavors, using fresh herbs, spices, a special mustard (just a smidgeon as they are high in sodium), flavored vinegars, wine, or citrus juices. If using dried herbs instead of fresh, use 1/3 of the fresh amount.

Baste meats and poultry with stock or wine instead of butter, margarine, or oil.

Steam dishes to concentrate the natural flavors, instead of adding butter or margarine. Works especially well with vegetables and fruits.

Use your microwave for fat-free cooking of vegetables, fruits, fish, and poultry -- everything cooks so quickly so that natural flavors and juices are retained.

Use egg substitute or egg whites instead of whole eggs in your baking. One-fourth cup of liquid egg substitute or two large egg whites equal one large whole egg.

Replace fat-laden whipped cream with whipped evaporated skim milk. For best results, pour the canned evaporated skim milk in a metal mixing bowl. Place the mixing bowl and the beaters of your electric mixer into the freezer for about 30 minutes, until ice crystals form around the edges. Remove the bowl and beaters from the freezer; whip on high speed until soft peaks form. Use at once.

Use fat-free cream cheese and sour cream in your dips and spreads or make yogurt cheese by draining nonfat yogurt (without added gelatin) in a yogurt funnel or a sieve lined with cheesecloth suspended over a bowl in the refrigerator for 12 hours or overnight to extract the whey. The results will be a soft cheese with the consistency of soft cream cheese. Discard the whey and refrigerate the yogurt cheese for up to a week, discarding any liquid that accumulates.

Next
Beverage Recipes

Table of Contents


Diabetes And Holiday Food Temptations | Fitness and Freebies

Diabetes And Holiday Food Temptations

Rich, sugary holiday foods offer a special challenge for people with diabetes. Holiday celebrations offer temptation for partygoers to abandon healthy nutritional habits, but calorie-laden festivities pose a special challenge to the 16 million (and growing) Americans who have diabetes.

Diabetes, the sixth leading cause of death by disease in the Untied States, is a metabolic disorder in which the body does not produce or properly use insulin (a hormone needed to convert sugar into energy). Maintaining a healthy lifestyle during the holidays can have a positive influence on your blood sugar and health.

Dr. Perfetti, Director of the Endocrine Training Program and the Outpatient Diabetes and Weight Management programs for Cedars-Sinai Medical Center recommends that the following tips will help people with diabetes enjoy a healthy holiday season:
  • Follow a regular exercise routine to help regulate metabolism. If time is tight, try taking 10 or 15 minute brisk walks at intervals throughout the day. Remember, after a holiday meal, to wait 60 to 90 minutes before taking your walk.
  • Keep your blood sugar as close to normal as possible and take your diabetes medicine regularly. Watch for symptoms of low and high blood sugar.
  • "Know when enough is enough." Practice portion control. If you control the portion sizes of the food you eat, you will be able to eat a wider variety of foods including your favorites. A small portion is less likely to upset blood sugar levels.
  • Do a "trade-off." Eating more during the holidays can be - in part - offset by a moderate and daily increase in physical exercise.
  • Choose nonfat or low fat foods. A healthy diet includes less than 30% of calories from fat, with less than 10% of those from saturated fat. Monounsaturated fats found in almonds, walnuts, canola and olive oil are the healthiest for your body.
  • At parties and other social events, gravitate toward the veggies and fresh fruit.
  • Take extra care to be certain that your meals are nutritious, varied and balanced. If you do have a treat, make sure you substitute it for an equivalent item in your regular menu.
  • Be positive. Remember that you control your diabetes; it doesn't control you.
The preceding information has been provided with the kind permission of Cedars-Sinai Medical Center, Los Angeles, California.

Next
Low-Fat Techniques for Holiday Cooking

Table of Contents


Cholesterol and Triglycerides | Fitness and Freebies

Cholesterol and Triglycerides

Cholesterol is not fat, but does act in connection with fats in the body. Cholesterol is a wax-like substance that gets into your bloodstream in several ways. The liver and the intestines can manufacture it. Or, it can enter the body through the foods you eat. Cholesterol is found in animal products such as fatty red meats, egg yolks and whole dairy products.

When the body contains too much cholesterol, the cholesterol deposits itself on the walls of your arteries, which causes them to close down or clog completely. The amount of cholesterol consumed in a day should not exceed 300 milligrams.

The body makes two types of cholesterol: HDL (good) and LDL (bad). HDL (high-density lipoprotein) is "good" because it sweeps cholesterol from the arteries and carries it back to the liver, where it is reprocessed or eliminated. LDL (low-density lipoprotein) is "bad" because it is deposited into the arteries. In addition, saturated fat is bad because it raises the level of LDL cholesterol in your bloodstream, making your more susceptible to clogged arteries. By contrast, unsaturated fat is thought to help prevent heart and vessel disease. Researchers and experts believe unsaturated fats work to lower the amount of bad cholesterol. They may even help raise the level of good (HDL) cholesterol - but this is not a free ride to go nuts on fat, mind you! What this information tells you is why unsaturated fats are recommended over saturated fats.

Because you or someone you love has diabetes, your doctor will recommend certain tests to check your HDL's and LDL's. HDL's should be over 35mg/dl and LDL's under 130mg/dl. Triglycerides, a type of storage fat in your body, needs to be checked as well. High blood sugar can raise the amount of triglycerides in your body. To reduce triglycerides one needs to lower their intake of carbohydrates, shed any extra pounds, avoid alcohol and exercise regularly. Diabetics are more likely to have problems with HDL and LDL levels, as well as triglycerides, which increases the threat of heart and artery disease. This is why it is important you understand their role in your dietary needs.

Next
Vitamin K and Diabetes

Table of Contents

This E-book is brought to you by:
Fitness and Freebies
Copyright © Fitness and Freebies. All rights reserved.


Up-and-Down Biscuits | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Up-and-Down Biscuits

Up and Down Biscuits

Ingredients:
2 cups all-purpose flour
4 teaspoons baking powder
1/2 teaspoon cream of tartar
1/4 teaspoon salt
1/4 cup shortening
3/4 cup fat-free milk
Sugar and cinnamon (optional)

Directions:
Preheat oven to 450-degrees. Stir together flour, baking powder, cream of tartar, and salt in a large mixing bowl. Cut in shortening until mixture resembles coarse crumbs. Make a well in the center; add milk. Stir just until dough clings together.

Knead dough gently for 10 to 12 strokes on a lightly floured surface. Divide dough in half. Roll one portion into a 12x10-inch rectangle. If desired, sprinkle sugar and cinnamon over rectangle. Cut rectangle into five 12x2-inch strips. Stack the strips one on top of the other. Cut into six 2-inch-square stacks. Place stacks, edge-side down, in greased muffin cups. Repeat with remaining dough.

Bake in preheated oven for 10 to 12 minutes or until golden. Serve warm.

Recipe makes 12 biscuits.

Nutrition information per serving:
Calories: 115
Protein: 3g
Total Fat: 4g
Saturated Fat: 1g
Carbohydrate: 16g
Cholesterol: 0mg
Sodium: 188mg
Fiber: 1g
Exchanges: 1 carbohydrate (1 bread/starch)

Next
Black Pepper Ring Biscuits

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Mustard Mushroom Vinaigrette | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Mustard Mushroom Vinaigrette

Ingredients:
1/4 cup extra-virgin olive oil
1/4 cup rice or apple cider vinegar
1 ounce (about 1/4-cup packed) sliced white mushrooms
2 tablespoons Dijon mustard
Two cloves garlic
1/2 teaspoon black pepper
1/4 teaspoon salt

Directions:
Combine all ingredients in jar of blender or food processor bowl. Process until smooth, scraping down sides with rubber spatula as necessary.

Refrigerate, covered, in glass or plastic container. Keeps four days refrigerated.

Recipe makes 3/4-cup - or 12 servings of 1-tablespoon each.

Nutrition information per serving:
Calories: 47
Fat: 5g
Saturated Fat: <1g
Calories from fat: 91%
Protein: <1g
Carbohydrates: <1g
Cholesterol: 0mg
Sodium: 63mg
Fiber: <1g
Dietary Exchanges: 1 Starch

Next
Apple-Cherry Chutney

Dips, Spreads and Sauces List

To Your Health!
Fitness and Freebies

space Strawberry Jam | Strawberry Jiffy Jam | Fresh Tomato Ketchup | Mexican Bean Dip | Chunky Applesauce | Maple Flavored Syrup | Linguine with Red Pepper Sauce | Easy BBQ Sauce | Broccoli and Bean Dip | Herb and Mustard Dressing | Low-Fat Ranch Dressing | Mustard Mushroom Vinaigrette | Apple-Cherry Chutney | Cranberry Cracker Spread | Sweet & Sassy Cherry Sauce | Roasted Red Pepper Dip | Chile Cheese Log | Creamy Garlic Dressing | Caesar Dressing | Basic Turkey Gravy | Low Fat Gravy | Fat-Free Gravy | Chocolate Frosting | Chocolate Cream Cheese Frosting | Diabetic Frosting | Sugar Free Frosting |
Chocolate Sauce | 		space


Vitamin K and Diabetes | Fitness and Freebies

Vitamin K and Diabetes

Vitamin K is essential for normal blood clotting as well as being an important nutrient for strong bones. However, people who take blood-thinning medications like Coumadin need to be aware of the interaction between vitamin K and those drugs. Interestingly, a smaller intake of vitamin K will increase the effectiveness of Coumadin, while too much vitamin K will decrease its effectiveness. Here are tips to help you get enough vitamin K without sacrificing the optimal benefits of your medication.
  • Consistency is the key. You may continue to enjoy foods high in vitamin K such as eggs, cheese, tomatoes, ham, lettuce and more.
  • Your doctor can adjust the medication to your diet.
  • Be consistent when taking vitamin/mineral pills and medical nutritional supplements such as Glucerna. They contain vitamin K.
  • Do not drastically cut back on your fat intake. Oils and margarine's contain vitamin K and all fats will increase the absorption of it.

    Next
    Blood Sugar

    Table of Contents

    This E-book is brought to you by:
    Fitness and Freebies
    Copyright © Fitness and Freebies. All rights reserved.


Chicken Waldorf Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Chicken Waldorf Salad

Tidbit: Waldorf Salad was created at New York's Waldorf-Astoria Hotel in 1896 by the maitre d' hotel Oscar Tshirky. The original version of this salad contained only apples, celery and mayonnaise.

Waldorf Salad

Ingredients:
2 cups cubed or shredded cooked chicken breast
2 cups chopped, cored apples
1 cup sliced celery
2/3 cup halved seedless grapes
1/4 cup chopped pecans, toasted
1/2 cup fat-free mayonnaise
1/2 cup fat-free sour cream
3 to 4 teaspoons lemon juice
2 teaspoons Dijon style mustard
Sugar substitute equal to 2-1/2 teaspoons
Salt and pepper
Red leaf lettuce
1/4 cup chopped pecans, optional

Directions:
Combine chicken, apples, celery, grapes and ј-cup pecans in bowl. Blend mayonnaise, sour cream, lemon juice, mustard and sweetener; stir into chicken mixture. Season to taste with salt and pepper. Spoon salad onto lettuce-lined plates; sprinkle with ј-cup chopped pecans, if using.

Tips:
Cubed, lean smoked ham can be substituted for the chicken Pineapple chunks can be substituted for the grapes; spoon salad into a hollowed-out pineapple half to serve.

Recipe makes four servings.

Nutrition information per 1-cup serving:
Calories: 251
Protein: 1g
Total Fat: 8g
Carbohydrate: 27g
Cholesterol: 48mg
Sodium: 489mg
Exchanges: 1-1/2 fruit, 3 lean meat

Next
Cheesy Potato Skins

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Winter Salad | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Winter Salad

This festive Winter Salad can help you eat right any time of year.

Ingredients:
One envelope Italian salad dressing mix
1/4 cup water
1/4 cup vinegar
1/4 cup vegetable oil
Three pears , cut into 3/4-inch cubes
One package (8 ounces) mixed salad greens
1/2 cup dried cranberries
1/4 cup chopped toasted walnuts

Directions:
Place dressing mix, water and vinegar in cruet or container with tight-fitting lid. Add oil; cover. Shake until well blended.

Toss pears with 1/4-cup of the dressing in large bowl. Let stand 15 minutes. Add greens, cranberries, walnuts and remaining 1/2-cup dressing; toss lightly. Serve immediately.

Recipe makes ten servings.

Nutrition information per serving:
Calories: 130
Total Fat: 7g
Saturated Fat: 1g
Cholesterol: 0mg
Sodium: 280mg
Carbohydrate: 15g
Fiber: 2g
Protein: <1g
Exchanges: 1 Fruit, 1-1/2 Fat

Next
Garlic Mashed Potatoes

Soups, Salads and Sides

To Your Health!
Fitness and Freebies

space Apple Slaw with Poppy Seed Dressing | Maple Glazed Squash | Cranberry Salad | Chicken Waldorf Salad | Cheesy Potato Skins | Crazy Carrots | Stuffed Bell Peppers | Curried Chicken Salad | Chicken Dijon Pasta Salad | Chicken Salad Chinois | Dried Fruit Salad | Green Beans and Fennel | Nutty Apple Salad | Pickled Carrots | Broccoli with Black Olives | Cheesy Baked Eggplant | Citrus Spinach & Rice Salad | Winter Salad | Garlic Mashed Potatoes | Nutty Wild Rice Salad | Broiled Steak Salad | Spicy Chicken Rice Soup | Clam Chowder | Chinese Chicken Corn Soup | Hearty Italian-Style Soup | Chili-Bean Soup | Beef Vegetable Soup | Basil Chicken Soup | Green Split Pea and Barley Soup | Quick Minestrone | Cool 'n Creamy Beet Soup | Chilled Tomato Soup | space


Yummy Apple Biscuits | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Yummy Apple Biscuits

Ingredients:
Five, jumbo-size refrigerated biscuits, cut into quarters
1/4 cup margarine, melted
1-1/4 cups spoonful sugar substitute or 30 packets of sweetener substitute
2-1/2 tablespoons cinnamon
Two medium Granny Smith apples, peeled, cored, sliced into 1/4-inch thin circles, cut in half
3 tablespoons apple juice concentrate, thawed

Directions:
Roll biscuit quarters into melted margarine. Coat biscuit pieces with combined sweetener and cinnamon. Arrange biscuits in an 8-inch round cake pan. Stand eight apple halves around the edge. Fill in remaining apple slices between the biscuit quarters. Sprinkle any remaining margarine and sweetener/cinnamon mixture over the top. Drizzle thawed apple juice over the top. Bake at 375-degrees for 20 to 25 minutes until golden brown and apples are tender.

Recipe makes eight servings.

Nutrition information per serving:
Calories: 235
Protein: 3g
Total Fat: 12g
Carbohydrate: 28g
Cholesterol: 0mg
Sodium: 425mg
Exchanges: 1 Fruit, 1 Bread, 2 Fat

Next
Easy Sticky Buns

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space


Succulent Zucchini Bread | Fitness and Freebies

Amaryl for Diabetes Generic Glucophage for Diabetes Generic Actos for Diabetes

Succulent Zucchini Bread

Ingredients:
Butter-flavored cooking spray
Three large eggs or 3/4-cup egg substitute
1/3 cup olive oil
Seven packets sweetener
1 tablespoon natural vanilla
1 8-ounce can crushed pineapple, packed in natural juice, well drained
2 cups grated zucchini
1-1/2 cups all-purpose flour
1-1/2 cups whole wheat flour
2 teaspoons baking soda
1/2 teaspoon baking powder
1-1/2 teaspoons ground cinnamon
3/4 teaspoon ground nutmeg
1 teaspoon salt (optional)
1 cup chopped walnuts or pecans (optional)

Directions:
Preheat the oven to 375-degrees. Lightly coat two 8-inch loaf pans with cooking spray.

In a large bowl, beat the eggs; add the oil, sweetener, vanilla, pineapple, and zucchini.

In a second large bowl, sift together the all-purpose flour, whole wheat flour, baking soda, baking powder, cinnamon, nutmeg, and salt (if using). If using, add the walnuts and toss.

Mix the dry ingredients into the egg mixture until just combined. Spoon into the prepared loaf pans.

Bake for 40 minutes or until a tester inserted near the middle comes out clean. Cool in pan for 5 minutes, then turn out and cool on wire racks.

Note: This loaf freezes well. You can top it with frozen fat-free whipped topping, or fat free, sugar-free vanilla yogurt, if desired.

Recipe makes two loaves, ten servings each.

Nutrition information per serving:
Calories: 118
Calories from fat: 35%
Protein: 3g
Total Fat: 5g
Saturated Fat: 0.6g
Carbohydrate: 16g
Fiber: 2g
Cholesterol: 32mg
Sodium: 149mg
Exchanges: 1 carbohydrate (1 bread/starch), 1 fat

Next
Country-Style Semolina Loaves

Breads, Muffins and Rolls

To Your Health!
Fitness and Freebies

space Orange Juice Muffins | Marvelous Bran Muffins | Cran-Orange Oat Muffins | Pear Spice Muffins | Branapple Muffins | Blueberry Cornmeal Muffins | Graham Muffins | Banana Bread | Almond-Apricot Bread | Orange Chocolate Chip Bread | Succulent Zucchini Bread | Country-Style Semolina Loaf | Yummy Apple Biscuits | Easy Sticky Buns | Up-and-Down Biscuits | Black Pepper Ring Biscuits | Cinnamon Bread Pudding | Chocolate Bread Pudding | space